3.2.0-24-generic-pae panics on an encrypted LVM/LUKS root mount - system unaccessible

Bug #1000655 reported by jno on 2012-05-17
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Unassigned

Bug Description

I have a full disk encrypted using LVM/LUKS.
When I boot with 3.2.0-23-generic-pae, that's ok.
With 3.2.0-24-generic-pae I get kernel panic and system freeze.

/dev/dm-0 is active and is in use.
  type: LUKS1
  cipher: aes-cbc-essiv:sha256
  keysize: 256 bits
  device: /dev/sda5
  offset: 4096 sectors
  size: 312074240 sectors
  mode: read/write

LUKS header information for /dev/sda5

Version: 1
Cipher name: aes
Cipher mode: cbc-essiv:sha256
Hash spec: sha1
Payload offset: 4096
MK bits: 256
MK digest: xx xx xx xx xx xx xx xx xx xx xx xx xx xx xx xx xx xx xx xx
MK salt: xx xx xx xx xx xx xx xx xx xx xx xx xx xx xx xx
                xx xx xx xx xx xx xx xx xx xx xx xx xx xx xx xx
MK iterations: 34500
UUID: xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx

Key Slot 0: ENABLED
 Iterations: 138458
 Salt: xx xx xx xx xx xx xx xx xx xx xx xx xx xx xx xx
                        xx xx xx xx xx xx xx xx xx xx xx xx xx xx xx xx
 Key material offset: 8
 AF stripes: 4000
Key Slot 1: DISABLED
Key Slot 2: DISABLED
Key Slot 3: DISABLED
Key Slot 4: DISABLED
Key Slot 5: DISABLED
Key Slot 6: DISABLED
Key Slot 7: DISABLED

# Generated by LVM2 version 2.02.66(2) (2010-05-20): Thu May 17 12:06:48 2012

contents = "Text Format Volume Group"
version = 1

description = "vgcfgbackup -v -f lvmbkp.txt"

creation_host = "HHHHHHHH" # Linux HHHHHHHH 3.2.0-23-generic-pae #36-Ubuntu SMP Tue Apr 10 22:19:09 UTC 2012 i686
creation_time = 1337242008 # Thu May 17 12:06:48 2012

HHHHHHHH {
 id = "XXXXXX-xxxx-XXXX-xxxx-XXXX-xxxx-XXXXXX"
 seqno = 8
 status = ["RESIZEABLE", "READ", "WRITE"]
 flags = []
 extent_size = 8192 # 4 Megabytes
 max_lv = 0
 max_pv = 0

 physical_volumes {

  pv0 {
   id = "XXXXXX-xxxx-XXXX-xxxx-XXXX-xxxx-XXXXXX"
   device = "/dev/dm-0" # Hint only

   status = ["ALLOCATABLE"]
   flags = []
   dev_size = 312074240 # 148.809 Gigabytes
   pe_start = 384
   pe_count = 38094 # 148.805 Gigabytes
  }
 }

 logical_volumes {

  lv_root {
   id = "XXXXXX-xxxx-XXXX-xxxx-XXXX-xxxx-XXXXXX"
   status = ["READ", "WRITE", "VISIBLE"]
   flags = []
   segment_count = 1

   segment1 {
    start_extent = 0
    extent_count = 11920 # 46.5625 Gigabytes

    type = "striped"
    stripe_count = 1 # linear

    stripes = [
     "pv0", 0
    ]
   }
  }

  lv_swap {
   id = "XXXXXX-xxxx-XXXX-xxxx-XXXX-xxxx-XXXXXX"
   status = ["READ", "WRITE", "VISIBLE"]
   flags = []
   segment_count = 1

   segment1 {
    start_extent = 0
    extent_count = 1430 # 5.58594 Gigabytes

    type = "striped"
    stripe_count = 1 # linear

    stripes = [
     "pv0", 11920
    ]
   }
  }

  lv_home {
   id = "XXXXXX-xxxx-XXXX-xxxx-XXXX-xxxx-XXXXXX"
   status = ["READ", "WRITE", "VISIBLE"]
   flags = []
   segment_count = 1

   segment1 {
    start_extent = 0
    extent_count = 24744 # 96.6562 Gigabytes

    type = "striped"
    stripe_count = 1 # linear

    stripes = [
     "pv0", 13350
    ]
   }
  }
 }
}
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
ApportVersion: 2.0.1-0ubuntu7
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: jno 2223 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xfc020000 irq 48'
   Mixer name : 'Conexant CX20561 (Hermosa)'
   Components : 'HDA:14f15051,17aa2100,00100000 HDA:14f12c06,17aa2122,00100000'
   Controls : 20
   Simple ctrls : 12
Card29.Amixer.info:
 Card hw:29 'ThinkPadEC'/'ThinkPad Console Audio Control at EC reg 0x30, fw 7VHT16WW-1.06'
   Mixer name : 'ThinkPad EC 7VHT16WW-1.06'
   Components : ''
   Controls : 1
   Simple ctrls : 1
Card29.Amixer.values:
 Simple mixer control 'Console',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
DistroRelease: Ubuntu 12.04
HibernationDevice: RESUME=UUID=7939c7d0-cc04-46c5-8cee-3d1dc66c7312
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release i386 (20120423.2)
MachineType: LENOVO 4061BS4
Package: linux (not installed)
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcEnviron:
 TERM=xterm
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.2.0-23-generic-pae root=/dev/mapper/jno--rstl-lv_root ro quiet splash
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic-pae 3.2.14
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-23-generic-pae N/A
 linux-backports-modules-3.2.0-23-generic-pae N/A
 linux-firmware 1.79
SourcePackage: linux
StagingDrivers: mei
Tags: precise staging precise staging
Uname: Linux 3.2.0-23-generic-pae i686
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 11/26/2009
dmi.bios.vendor: LENOVO
dmi.bios.version: 6FET82WW (3.12 )
dmi.board.name: 4061BS4
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr6FET82WW(3.12):bd11/26/2009:svnLENOVO:pn4061BS4:pvrThinkPadW500:rvnLENOVO:rn4061BS4:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 4061BS4
dmi.product.version: ThinkPad W500
dmi.sys.vendor: LENOVO

affects: ubuntu → linux (Ubuntu)

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1000655

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: precise
jno (jnoster) wrote : AcpiTables.txt

apport information

tags: added: apport-collected staging
description: updated
jno (jnoster) wrote : AlsaDevices.txt

apport information

jno (jnoster) wrote : BootDmesg.txt

apport information

apport information

apport information

apport information

apport information

jno (jnoster) wrote : IwConfig.txt

apport information

jno (jnoster) wrote : Lspci.txt

apport information

jno (jnoster) wrote : Lsusb.txt

apport information

apport information

apport information

apport information

apport information

jno (jnoster) wrote : PulseList.txt

apport information

jno (jnoster) wrote : RfKill.txt

apport information

jno (jnoster) wrote : UdevDb.txt

apport information

jno (jnoster) wrote : UdevLog.txt

apport information

jno (jnoster) wrote : WifiSyslog.txt

apport information

jno (jnoster) wrote :

the "apport-collect 1000655" command has issued two Python tracebacks:

No packages found matching linux.
ERROR: hook /usr/share/apport/general-hooks/ubuntu.py crashed:
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/apport/report.py", line 718, in add_hooks_info
    symb['add_info'](self, ui)
  File "/usr/share/apport/general-hooks/ubuntu.py", line 45, in add_info
    match_error_messages(report)
  File "/usr/share/apport/general-hooks/ubuntu.py", line 129, in match_error_messages
    if report['ProblemType'] == 'Package':
  File "/usr/lib/python2.7/UserDict.py", line 23, in __getitem__
    raise KeyError(key)
KeyError: 'ProblemType'
Traceback (most recent call last):
  File "/usr/share/apport/apport-gtk", line 499, in <lambda>
    GLib.idle_add(lambda: self.collect_info(on_finished=self.ui_update_view))
  File "/usr/lib/python2.7/dist-packages/apport/ui.py", line 867, in collect_info
    icthread.exc_raise()
  File "/usr/lib/python2.7/dist-packages/apport/REThread.py", line 34, in run
    self._retval = self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib/python2.7/dist-packages/apport/ui.py", line 111, in thread_collect_info
    if report['ProblemType'] == 'Crash' and \
  File "/usr/lib/python2.7/UserDict.py", line 23, in __getitem__
    raise KeyError(key)
KeyError: 'ProblemType'

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
jno (jnoster) wrote :

And again: this data were collected in

Linux XXX 3.2.0-23-generic-pae #36-Ubuntu SMP Tue Apr 10 22:19:09 UTC 2012 i686 i686 i386 GNU/Linux

while the kernel panic was observed in 3.2.0-24-generic-pae

Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.4kernel[1] (Not a kernel in the daily directory). Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the other tags). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.4-rc7-precise/

Changed in linux (Ubuntu):
importance: Undecided → High
tags: added: kernel-da-key
tags: added: regression-update
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
jno (jnoster) wrote :

> Would it be possible for you to test the latest upstream kernel?

Sorry, guys.
It's my workplace box (Lenovo W500, if it matters) and I have no much time for testing :(

BTW, when the kernel panics, the CAPSLOCK (builtin one, not on the external USB keyboard) LED blinks...

jno (jnoster) wrote :

I could take a "screenshot" (literally, using a digital still image camera) of the panic "dump" which is attached.

Transcript is as follows:

[1.993960] Lernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0.0)
[1.994005] Pid: 1, comm: swapper/0 Not tainted 3.2.0.-24-generic-pae #37-Ubuntu
[1.994046] Call Trace:
[1.994086] [<c1592732>] ? printk+0x2d/0x2f
[1.994124] [<c1592600>] panic+0x5c/0x161
[1.994163] [<c1879b5e>] mount_block_root+0xb9/0x14c
[1.994203] [<c115280c>] ? sys_mknod+0x2c/0x30
[1.994241] [<c1879d69>] mount_root+0x59/0x5f
[1.994279] [<c1879ebd>] prepare_namespace+0x14e/0x192
[1.994319] [<c11434f5>] ? sys_access+0x25/0x30
[1.994357] [<c18798d2>] kernel_init+0x140/0x145
[1.994396] [<c1879792>] ? start_kernel+0x35d/0x35d
[1.994436] [<c15af6be>] kernel_thread_helper+0x6/0x10

tags: added: kernel-key
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
jno (jnoster) wrote :

After a routine update I could boot it normally into:

Linux XXX 3.2.0-24-generic-pae #38-Ubuntu SMP Tue May 1 16:40:26 UTC 2012 i686 i686 i386 GNU/Linux

ii linux-image-3.2.0-24-generic-pae 3.2.0-24.38 Linux kernel image for version 3.2.0 on 64 bit x86 SMP

Fixed?

jno (jnoster) wrote :

Routine update to:

Linux XXX 3.2.0-24-generic-pae #39-Ubuntu SMP Mon May 21 18:54:21 UTC 2012 i686 i686 i386 GNU/Linux

ii linux-image-3.2.0-24-generic-pae 3.2.0-24.39 Linux kernel image for version 3.2.0 on 64 bit x86 SMP

tags: removed: kernel-key
Julian Wiedmann (jwiedmann) wrote :

jno,

in comment #26 you said this issue was fixed after a kernel update. Has it popped up again since then or can this bug be closed? Thanks.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete

no. never again.

On Tue, Jul 16, 2013 at 11:35 PM, Julian Wiedmann <
<email address hidden>> wrote:

> jno,
>
> in comment #26 you said this issue was fixed after a kernel update. Has
> it popped up again since then or can this bug be closed? Thanks.
>
> ** Changed in: linux (Ubuntu)
> Status: Confirmed => Incomplete
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1000655
>
> Title:
> 3.2.0-24-generic-pae panics on an encrypted LVM/LUKS root mount -
> system unaccessible
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1000655/+subscriptions
>

--
-jno
"Tiger got to hunt, bird got to fly; Man got to sit and wonder, 'Why, why,
why?' Tiger got to sleep, bird got to land; Man got to tell himself he
understand." K,Vonnegut

Julian Wiedmann (jwiedmann) wrote :

Great, thanks.

Changed in linux (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers