Ubuntu

After suspending laptop, can't resume, can't reboot, no BIOS

Reported by Dan Furlani on 2012-05-16
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linux
Incomplete
Medium
linux (Ubuntu)
Medium
Unassigned

Bug Description

Toshiba Satellite C675D-S7109 with Ubuntu 12.04 (64-bit).

After suspending, there's no way to resume (tried keys, mouse buttons, power button). The fan was still running and both power LEDs were on (one indicating the laptop is plugged in, one indicating it's powered on).

I held down the power button for 8s to force it to power off. Fan goes off, HD spins down, power light goes out, all as expected.

When I hit the power button to turn it back on, fan comes on, HD spins up, but it doesn't show the BIOS splash screen or anything -- just a totally black screen, like before I powered it off.

Removing and replacing the battery allows it to boot normally.

I tried sudo pm-hibernate -- it worked, except it didn't actually shut down the laptop. After I heard the HD spin down I forced power off. On power-on, it resumed from hibernation just fine.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.2.0-24-generic 3.2.0-24.37
ProcVersionSignature: Ubuntu 3.2.0-24.37-generic 3.2.14
Uname: Linux 3.2.0-24-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: SB [HDA ATI SB], device 0: ALC269VB Analog [ALC269VB Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
ApportVersion: 2.0.1-0ubuntu7
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: SB [HDA ATI SB], device 0: ALC269VB Analog [ALC269VB Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: dan 1962 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'SB'/'HDA ATI SB at 0xfeb40000 irq 16'
   Mixer name : 'Realtek ALC269VB'
   Components : 'HDA:10ec0269,1179fd78,00100100'
   Controls : 18
   Simple ctrls : 10
Date: Tue May 15 19:25:35 2012
HibernationDevice: RESUME=UUID=779be664-2a45-4295-822e-8570a5937ab3
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
MachineType: TOSHIBA Satellite C675D
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 radeondrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-24-generic root=UUID=9e3d7179-cda7-440c-9853-922d2b9f6f7b ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-24-generic N/A
 linux-backports-modules-3.2.0-24-generic N/A
 linux-firmware 1.79
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 07/01/2011
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1.60
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: TKBSB
dmi.board.vendor: PEGATRON CORPORATION
dmi.board.version: 1.60
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: TOSHIBA
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1.60:bd07/01/2011:svnTOSHIBA:pnSatelliteC675D:pvrPSC4AU-029015:rvnPEGATRONCORPORATION:rnTKBSB:rvr1.60:cvnTOSHIBA:ct10:cvrToBeFilledByO.E.M.:
dmi.product.name: Satellite C675D
dmi.product.version: PSC4AU-029015
dmi.sys.vendor: TOSHIBA

Dan Furlani (dan-furlani) wrote :
Brad Figg (brad-figg) on 2012-05-16
Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Did this issue start happening after an update/upgrade? Was there a kernel version where you were not having this particular problem? This will help determine if the problem you are seeing is the result of the introduction of a regression, and when this regression was introduced.

Changed in linux (Ubuntu):
importance: Undecided → Medium
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.4kernel[1] (Not a kernel in the daily directory). Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the other tags). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.4-rc7-precise/

tags: added: needs-upstream-testing
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Dan Furlani (dan-furlani) wrote :

Thanks for the quick reply! I'm not sure if it's a regression -- I just got the laptop this week, blew away Windows and installed Ubuntu.

I tried the v3.4-rc6-precise kernel since the rc7 image wasn't available. Installed with dpkg, rebooted, uname to verify:
Linux rizzo 3.4.0-030400rc6-generic #201205061835 SMP Sun May 6 22:36:08 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Same behavior with suspend. Actually, one difference: when I held down the power key to force power off, it shut down as expected, but as soon as I lifted my finger from the power button it immediately started back up. It could be switch bounce or something but it happend a handful of times before I was able to get it to stay powered down and remove the battery. Also, that behavior was with the power cord unplugged, I believe all my testing yesterday was plugged in.

One other thing I should mention -- occasionally the keyboard and mouse won't work when Ubuntu boots up. What's interesting is that the keyboard will work in Grub, but then once the splash/login screen comes up, no dice. Force shutdown and startup fixes. I'm not too worried about this right now, just mentioning in case it could be related somehow.

tags: added: kernel-bug-exists-upstream
removed: needs-upstream-testing
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Dan Furlani (dan-furlani) wrote :

I tried a few more things.

I rebooted in single-user mode using the 3.4.0 rc6 kernel and followed directions here:
https://wiki.ubuntu.com/DebuggingKernelSuspend

I see this in dmesg:
[ 2.268515] Magic number: 12:953:1001
[ 2.268604] pnp 00:03: hash matches

I don't see any 00:03 in lspci output (previously attached).

find /sys/devices -name "*00:03*"
/sys/devices/pnp0/00:03
/sys/devices/pci0000:00/0000:00:15.1/0000:03:00.0
/sys/devices/pci0000:00/0000:00:15.1/pci_bus/0000:03

Contents of files under .../pnp0/00:03/
/sys/devices/pnp0/00:03/id: PNP0200
/sys/devices/pnp0/00:03/power/control: auto
/sys/devices/pnp0/00:03/power/async: disabled
/sys/devices/pnp0/00:03/power/runtime_enabled: disabled
/sys/devices/pnp0/00:03/power/runtime_active_kids: 0
/sys/devices/pnp0/00:03/power/runtime_active_time: 0
/sys/devices/pnp0/00:03/power/autosuspend_delay_ms:
cat: /sys/devices/pnp0/00:03/power/autosuspend_delay_ms: Input/output error
/sys/devices/pnp0/00:03/power/runtime_status: unsupported
/sys/devices/pnp0/00:03/power/runtime_usage: 0
/sys/devices/pnp0/00:03/power/runtime_suspended_time: 0
/sys/devices/pnp0/00:03/uevent:
/sys/devices/pnp0/00:03/resources:
  state = active
  dma 4
  io 0x0-0xf
  io 0x81-0x83
  io 0x87-0x87
  io 0x89-0x8b
  io 0x8f-0x8f
  io 0xc0-0xdf
/sys/devices/pnp0/00:03/options:

Does any of this help?

Joseph Salisbury (jsalisbury) wrote :

This issue appears to be an upstream bug, since you tested the latest upstream kernel. Would it be possible for you to open an upstream bug report at bugzilla.kernel.org [1]? That will allow the upstream Developers to examine the issue, and may provide a quicker resolution to the bug.

If you are comfortable with opening a bug upstream, It would be great if you can report back the upstream bug number in this bug report. That will allow us to link this bug to the upstream report.

[1] https://wiki.ubuntu.com/Bugs/Upstream/kernel

Changed in linux (Ubuntu):
status: Confirmed → Triaged
Dan Furlani (dan-furlani) wrote :

Reported upstream and linked. Thanks for your assistance Joseph!

Changed in linux:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in linux:
status: Confirmed → Incomplete

Dan Furlani, as per http://support.toshiba.com/support/driversResults?freeText=3335975 an update is available for your BIOS (1.70). If you update to this following https://help.ubuntu.com/community/BiosUpdate , does it change anything?

If not, could you please both specify what happened, and provide the output of the following terminal command:
sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date

Please note your current BIOS is already in the Bug Description, so posting this on the old BIOS would not be helpful.

For more on BIOS updates and linux, please see https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette .

Thank you for your understanding.

tags: added: bios-outdated-1.70
Changed in linux (Ubuntu):
status: Triaged → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.