please merge linux-wlan-ng 0.2.9+dfsg-1 from Debian main unstable

Bug #192772 reported by Tormod Volden on 2008-02-17
10
Affects Status Importance Assigned to Milestone
linux-wlan-ng (Ubuntu)
Low
Tim Gardner

Bug Description

Binary package hint: linux-wlan-ng

This will sync the userland package with the kernel module source which already is in linux-ubuntu-modules. The new upstream version fixes bug #189345 as well.

Changed in linux-wlan-ng:
assignee: nobody → tormodvolden
status: New → In Progress
Tormod Volden (tormodvolden) wrote :

Thanks to MoM.

 linux-wlan-ng (0.2.8+svn1851+dfsg-1ubuntu1) hardy; urgency=low
 .
   * Merge from debian unstable (LP: #192772), remaining changes:
     - Ubuntu maintainer fields in control*
     - debian/control: comment on Ubuntu kernel modules
     - debian/control.firmware: drop recommends on -modules package
   * debian/control comment updated to reflect that the package
     now is only needed for firmware RAM loading
   * Upstream fix for firmware loading (LP: #189345)
 .

Tormod Volden (tormodvolden) wrote :

Added a workaround for NetworkManager weirdness: n-m-dispatcher (in 0.6.5) calls ifdown a bit too often which by means of the linux-wlan-ng post-down script normally would turn off the radio - the result is an empty list of available networks in the drop-down menu. (See also http://lists.linux-wlan.com/pipermail/linux-wlan-devel/2008-January/003781.html "But in the mean time, the debian ifdown script should be updated to not
call ifstate=disable when running in pure wext mode.")

Changed in linux-wlan-ng:
assignee: tormodvolden → nobody
status: In Progress → New
Tormod Volden (tormodvolden) wrote :

Can we please get this in before the Alpha 6 soft freeze?

Daniel Holbach (dholbach) wrote :

Could somebody of the Kernel Team please take a look at this?

Daniel Holbach (dholbach) wrote :

Tim: can you take a look at it?

This release also effectively works around a problem in the module which prevents firmware loading if the wireless card is un-plugged and re-plugged.

This problem in the driver module has been fixed upstream (but too late to go into Hardy now I guess), where as this proposed merge nicely works around it in userspace for the time being.

Tim Gardner (timg-tpi) wrote :

Tormod - I released the fix for #189345. Will that be sufficient for Hardy? The Intrepid sync will pull the latest linux-wlan-ng.

Changed in linux-wlan-ng:
assignee: nobody → timg-tpi
importance: Undecided → Low
milestone: none → later
status: New → In Progress
Tormod Volden (tormodvolden) wrote :

No, IIRC that will not be enough to make firmware loading work reliably. At least a "sleep 3" in wlan-udev.sh is needed. I can test the new package you released and see how it works, but the safest would be to do the merge. Also the above NetworkManager workaround would be good to have.

Note that I posted the 189345 fix because I knew it would be needed, but I did not test the package much afterwards and rather focused on getting it fixed upstream and in Debian for then to merge. I have tested the merged version pretty well.

Tim Gardner (timg-tpi) wrote :

Tormod - can you give me a diff against the current Ubuntu linux-wlan-ng-0.2.8+svn1839+dfsg package that includes _only_ the minimum required to make this thing work properly? At this late stage in the Hardy cycle I'm not making wholesale changes.

Tormod Volden (tormodvolden) wrote :

Don't forget that most of the changes are already in Hardy - since we ship the updated, built modules in l-u-m. So all the changes in the src/ tree (and documentation) just reflect the new modules that we ship already.

As you can see in the attached debdiff from the current Ubuntu version 0.2.8+svn1839+dfsg-2ubuntu3 to my proposed merge 0.2.8+svn1851+dfsg-1ubuntu1, most changes are:
- src/ in sync with l-u-m source
- debian/patches/ - patch descriptions added

Which of the other changes scare you?

Tormod Volden (tormodvolden) wrote :

Tim, can we please do something with this before the freeze? It would be sad to ship with an inconsistent and non-functional package. I have gone through and verified every hunk of the above debdiff.

Tormod Volden (tormodvolden) wrote :

This is the most important hunk from the above debdiff. But I strongly recommend applying the above debdiff instead, which also have had more testing.

Tormod Volden (tormodvolden) wrote :

I added the (now for real) fix for bug #189345 to the last quick and dirty debdiff. The merge debdiff had this correct all the time.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-wlan-ng - 0.2.8+svn1839+dfsg-2ubuntu4

---------------
linux-wlan-ng (0.2.8+svn1839+dfsg-2ubuntu4) hardy; urgency=low

  [Tormod Volden]

  * wlan-udev.sh: wait 3 seconds to have modules fully initialized
  * debian/patches/00list: add patch from last upload (LP: #189345)
   - LP: #192772

 -- Tim Gardner <email address hidden> Wed, 09 Apr 2008 00:43:42 +0200

Changed in linux-wlan-ng:
status: Fix Committed → Fix Released
Tim Gardner (timg-tpi) wrote :
Changed in linux-wlan-ng:
status: In Progress → Fix Committed
Tormod Volden (tormodvolden) wrote :

This bug is not at all resolved by the package you uploaded. The firmware uploading now works in more cases than before. But there are still issues with network-manager, the documentation is wrong, the source package is not consistent with the modules we ship, and package descriptions are misleading. If someone needs to rebuild the modules with their own kernel, it won't even build.

All these issues would be resolved by the merge debdiff I submitted to the sponsor queue two months ago!

Changed in linux-wlan-ng:
status: Fix Released → Confirmed
Tim Gardner (timg-tpi) wrote :

Tormod,

> All these issues would be resolved by the merge debdiff I submitted to the
> sponsor queue two months ago!

Be that as it may, I didn't see it. How about attaching a patch that makes this package exhibit the behavior you want? I don't have the time to chase down all of the details and issues as I am quite busy with the final phases of the Hardy release.

Thanks.

Tormod Volden (tormodvolden) wrote :

That would be the patch in comment 2. I am not sure if it's worth breaking up that patch further, from the technical point of view it would be best to take it completely, to ensure a high quality package for the LTS release. I put quite some effort into the merge and testing it (for months now). I am afraid I don't have so much time I can start all over with newer patches. (It doesn't fill me with Ubuntu love to see my efforts wasted either.)

For maintaining it in Hardy, staying close to Debian and upstream is a definite advantage.

Either way, not so many people use or need to use this package. In that sense, maybe the most important change in the merge debdiff is the updated documentation and description, which can help keeping people from installing this package when they shouldn't.

Tormod Volden (tormodvolden) wrote :

Can you please upload this to intrepid now? (The debdiff in comment 2)

Tormod Volden (tormodvolden) wrote :

There's a new Debian version out, but please upload this merge first, to help MoM.

Tim, can you please take a look at this, or reassign to someone else?

Uploaded linux-wlan-ng_0.2.8+svn1854+dfsg-1ubuntu1

Tim Gardner (timg-tpi) on 2008-06-19
Changed in linux-wlan-ng:
milestone: later → intrepid-alpha-1
status: Confirmed → Fix Committed
Tormod Volden (tormodvolden) wrote :

Tim, what does "Accept upstream package as is."? Did you just scrap the Ubuntu changes that I had prepared in the debdiff?

Tim Gardner (timg-tpi) wrote :

I uploaded linux-wlan-ng_0.2.8+svn1854+dfsg-1 for Intrepid with no changes other then a note in debian/changelog. Martin Pitt immediately chastised me for not requesting a Debian sync (I'm a debian noob). As soon as this point release is done I can also upload something for Hardy, just attach a diff against the current Hardy package.

Tormod Volden (tormodvolden) wrote :

Tim, I think Martin's point was that _if_ there are no Ubuntu changes, you should just sync the package and not make a Ubuntu package with an empty "Ubuntu delta" out of it. However, some packages, like linux-wlan-ng, need some adjustment for Ubuntu. In this case it is needed because we ship the kernel modules with l-u-m, but I think you know that.

Anyway, Debian 0.2.9+dfsg-1 is out, and we would like to get it into Ubuntu, with most of the debdiff in comment 2 applied (again). SInce you uploaded your delta-free new package, MoM will not do the job, so I guess someone has to start all over again for a new merge...

My time for this is limited, so I can not keep on preparing debdiffs if I am not sure they will get serious and timely treatment.

Tormod Volden (tormodvolden) wrote :

I'll give it another try:

 linux-wlan-ng (0.2.9+dfsg-1ubuntu1) intrepid; urgency=low
 .
   * Merge from Debian unstable (LP: #192772), remaining changes:
     - Ubuntu maintainer fields in control*
     - debian/control: comment on Ubuntu kernel modules
     - debian/control.firmware: drop recommends on -modules package
   * debian/control comment updated to reflect that the package
     now is only needed for firmware RAM loading

At the same time, we should update the l-u-m kernel code to match this version, but I can file a separate bug for that if needed.

Tormod Volden (tormodvolden) wrote :

I filed bug #245026 for the l-u-m part.

I would like to see this merge as well - it would synchronise us with the upstream release which has been stable and working well for a while now.

It is also nice that the debdiff between us and debian is now purely comments/maintainer-ids/changelog, i.e. no functional difference. Thats a good place for us to be with this package.

Steve Langasek (vorlon) wrote :

Tormod,

I don't see why it's necessary to maintain a delta with Debian just over the package description and recommends. The recommends will of course be unsatisfied, but this won't cause problems for users trying to install the package; and the description, while suboptimal, is suboptimal for Debian as well since it *is* possible to use the linux-wlan-ng package without a linux-wlan-ng-modules-2.6.xx package on Debian (by not using a packaged kernel, for instance), so the description ought to be improved there as well - perhaps we could find a description that's appropriate for both distributions, so this can become a straight sync from Debian?

Tormod Volden (tormodvolden) wrote :

Steve, yes, it would be ideal to find a common description. I think that correct and clear documentation is important. Following the linux-wlan-ng package for some years in forums and bug reports, I see the confusion and that many people install it when they shouldn't.

Any suggestions for a good description? Until then, I would have just added this Ubuntu modification for now.

With the new Recommends policy, there's no problem with uninstallable recommends?

Colin Watson (cjwatson) on 2008-07-11
Changed in linux-wlan-ng:
milestone: intrepid-alpha-1 → intrepid-alpha-2

How about the following for package descriptions (keeping in all cases the existing first paragraph about the range of cards this applies to).

linux-wlan-ng:
This package installs additional utilities to set up and configure cards using the linux-wlan-ng driver. Note that the driver kernel modules themselves are normally installed by the relevant linux-ubuntu-modules package. Furthermore, the driver and wireless card can normally be controlled satisfactorily without these utilities - you only need install this package if you want to customise the configuration sequence.

linux-wlan-ng-firmware:
This package doesn't contain the firmware files, but a script to download the upstream source tarball and build a deb package that contains them. Once built you can then install that package separately to give your system access to the firmware. Note that only some adapters really need a firmware file and that firmware files are not completely free (in the sense of freely redistributable), that's why this package exists.

linux-wlan-ng-doc:
This package contains documentation for linux-wlan-ng that is not included in the main package.
[no change from before]

linux-wlan-ng-source:
This package provides the full source code for the linux-wlan-ng kernel modules, to allow you to compile the modules yourself from scratch (e.g. using module-assistant). Note however that these kernel modules are normally installed by the relevant linux-ubuntu-modules package, and thus the source for that package can also be used to compile these modules for use in an Ubuntu kernel tree.

With regards to having common descriptions with debian, I'm not we can do this 100%. Thats because I can't see in debian an equivalent to our linux-ubuntu-modules, which I think we will want to refer to in our package descriptions (to be completely clear to our users).

Tormod Volden (tormodvolden) wrote :

Karl, thanks for your suggestion. However, Steve's point is that we should get rid of any Ubuntu delta. We therefore need new descriptions for the Debian package. They must fit well with Debian's situation and still be useful and correct for the Ubuntu situation. I agree this is not easy.

Tormod Volden (tormodvolden) wrote :

Steve/Tim, please do not let this hold back any sync/merge. Otherwise we end up with the same story again with too late action and upload freezes. It's already past alpha-2. If we get better descriptions later that's fine. Please upload 0.2.9, with or without my debdiff from comment 27.

Steve Langasek (vorlon) wrote :

The 0.2.8+svn1851+dfsg-1 that this patch is against is no longer available. Is 0.2.9+dfsg in Debian testing/unstable suitable for syncing?

Steve Langasek (vorlon) wrote :

s/syncing/merging/, I mean...

Tormod Volden (tormodvolden) wrote :

As you can see from comment 27, the patch is against 0.2.9+dfsg-1.

Steve Langasek (vorlon) wrote :

confirmed for freeze exception, will upload after the end of the alpha-5 milestone freeze.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-wlan-ng - 0.2.9+dfsg-2ubuntu1

---------------
linux-wlan-ng (0.2.9+dfsg-2ubuntu1) intrepid; urgency=low

  * Merge from Debian unstable (LP: #192772), remaining changes:
    - Ubuntu maintainer fields in control*
    - debian/control: comment on Ubuntu kernel modules
    - debian/control.firmware: drop recommends on -modules package
  * debian/control comment updated to reflect that the package
    now is only needed for firmware RAM loading

linux-wlan-ng (0.2.9+dfsg-2) unstable; urgency=low

  [ Tormod Volden ]
  * SRC_build_on_2-6-26.dpatch:
    Cherry-picked upstream r1867 to fix build on 2.6.26
    (Closes: #495338)

linux-wlan-ng (0.2.9+dfsg-1) unstable; urgency=low

  [ Chris Lamb ]
  * Fix bashism in debian/rules (Closes: #484403)

  [ Enrico Tassi ]
  * New upstream release
  * Watch file fixed to strip +dfsd tag from debian version before comparing
    it with the upstream version
  * Bumped standards-version to 3.8.0, no changes needed

 -- Tormod Volden <email address hidden> Thu, 03 Jul 2008 00:04:24 +0200

Changed in linux-wlan-ng:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers