Ubuntu

gutsy/amd64: ftbfs / autopkgtest failure

Reported by Ian Jackson on 2007-07-24
8
Affects Status Importance Assigned to Milestone
linux-wlan-ng (Debian)
Fix Released
Unknown
linux-wlan-ng (Ubuntu)
High
Ian Jackson

Bug Description

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

 affects /ubuntu/linux-wlan-ng

An instance of autopkgtest (an automatic package testing system) has
found that this package either failed to build from source - or that
it declared some tests in its debian/tests/control and that at least
one of these tests failed.

A human has briefly looked at the transcript and concluded that the
fault is a bug in the package or one of its build-dependencies.

The test environment is an amd64 Xen guest with limited amounts of
memory. The relevant dependencies are installed for each test but
very few other packages.

The top and bottom of the mail sent by the autopkgtest instance to its
administrator is included below. The full log can be found at
 http://autopkgtest.ubuntu.com/autopkgtest-output/gutsy/linux-wlan-ng/

| Test executed for: gutsy source linux-wlan-ng
| Outcome: erroneous package!
| blame: arg:tmp/linux-wlan-ng/src/linux-wlan-ng_0.2.8+dfsg-1ubuntu2.dsc dsc:linux-wlan-ng
| badpkg: rules build failed with exit code 2
| quitting: erroneous package: rules build failed with exit code 2
|
| erroneous package!
...
| + pwd
| + origpwd=/root/adt-downtmp/dsc0-build
| + cd /root/adt-downtmp/dsc0-build
| + chown adtxenu .
| + TMPDIR=/root/adt-downtmp/dsc0-build/tmpdir
| + rm -rf -- /root/adt-downtmp/dsc0-build/tmpdir
| + export TMPDIR
| + su adtxenu -c mkdir -- "$TMPDIR"
| + spec=/root/adt-downtmp/dsc0/linux-wlan-ng_0.2.8+dfsg-1ubuntu2.dsc origpwd=/root/adt-downtmp/dsc0-build su adtxenu -c
| dpkg-source -x $spec
|
| gpg: new configuration file `/home/adtxenu/.gnupg/gpg.conf' created
| gpg: WARNING: options in `/home/adtxenu/.gnupg/gpg.conf' are not yet active during this run
| gpg: Signature made Wed May 30 17:51:11 2007 UTC using DSA key ID 17063E6D
| gpg: Can't check signature: public key not found
| dpkg-source: extracting linux-wlan-ng in linux-wlan-ng-0.2.8+dfsg
| dpkg-source: unpacking linux-wlan-ng_0.2.8+dfsg.orig.tar.gz
| dpkg-source: applying /root/adt-downtmp/dsc0/linux-wlan-ng_0.2.8+dfsg-1ubuntu2.diff.gz
| + cd linux-wlan-ng-0.2.8+dfsg/.
| + pwd
| + set +e
| + test -f debian/tests/control
| + echo 1
| adt-run: trace: * <dsc:dsc0> build needed for binaries
| adt-run: trace: $ dsc0: python -c <SCRIPT>
| adt-run: trace: $ dsc0-build: sh -ec <SCRIPT> x /root/adt-downtmp/dsc0-build/tmpdir /root/adt-downtmp/dsc0-build/linux-wlan-ng-0.2.8+dfsg
| + TMPDIR=/root/adt-downtmp/dsc0-build/tmpdir
| + rm -rf -- /root/adt-downtmp/dsc0-build/tmpdir
| + export TMPDIR
| + su adtxenu -c mkdir -- "$TMPDIR"
| + cd /root/adt-downtmp/dsc0-build/linux-wlan-ng-0.2.8+dfsg
| + dpkg-checkbuilddeps
| + su adtxenu -c debian/rules build
| test -d debian/patched || install -d debian/patched
| dpatch apply-all
| applying patch BUILD_config_in to ./ ...patch: **** Can't create file .modules/pomFB2Bd : No such file or directory
| failed.
| make: *** [patch-stamp] Error 1
| blame: arg:tmp/linux-wlan-ng/src/linux-wlan-ng_0.2.8+dfsg-1ubuntu2.dsc dsc:linux-wlan-ng
| badpkg: rules build failed with exit code 2
| adt-run: erroneous package: rules build failed with exit code 2
| adt-run: trace: ** stop
| adt-run: trace: ** close, scratch=tb-scratch~/root/adt-downtmp:-/|/root/adt-downtmp/!
| ++++++ RESULTS erroneous package! ++++++
| ++++++ bundling ++++++
| ++++++ uploading ++++++
| ++++++ contacting maintainer_email_override ++++++
| ++++++ tested. ++++++
|
|
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)

iD8DBQFGpipF05QTisYqw/QRAiTHAKCfWuRgtk4TjMYRzzgGg7kjleFz4QCghLsQ
nDEAKod/ocCqKoH7zB7e2ok=
=89Ls
-----END PGP SIGNATURE-----

Tormod Volden (tormodvolden) wrote :

If I download the sources and run "dpatch apply-all" or "debian/rules build" it all runs fine here.

Can someone (human or not) explain more what is supposedly wrong please?

Changed in linux-wlan-ng:
assignee: nobody → tormodvolden
status: New → Incomplete

Tormod Volden writes ("[Bug 128002] Re: gutsy/amd64: ftbfs / autopkgtest failure"):
> Can someone (human or not) explain more what is supposedly wrong please?

I don't know I'm afraid. Have you run it in a pbuilder ? Is your
/bin/sh bash or dash ?

What's the .modules directory referred to in the log ?

If you're really stumped I might be able to run the whole thing under
strace.

Ian.

Tormod Volden (tormodvolden) wrote :

I haven't run it in a pbuilder, I don't have enough space ATM. My /bin/sh is dash (Feisty).

The .modules is a temp directory used in debian/rules. It is not referred to in the patches, so I am a little confused why the above log seems to fail at that point.

Tormod Volden (tormodvolden) wrote :

I tried in a pbuilder (on my Feisty system) and it worked fine.
 sudo pbuilder build --distribution gutsy linux-wlan-ng_0.2.8+dfsg-1ubuntu2.dsc

I only noticed one thing from the pbuilder output:
The Configure called from debian/rules looks up the running kernel to prepare compiling kernel modules. This will be wrong in such a pbuild and is not needed either: no kernel modules are or should be built. The resulting linux-wlan-ng-source .deb can be installed to actually build the modules with module-assistant. The linux-wlan-ng-source .deb ships with the same Configure file. To make it perfectly clean, we could use two different Configure files, but I don't think it's worth the trouble.

Tormod Volden (tormodvolden) wrote :

Ian, can we close this bug now? Have you tried the autopkgtest again?

Tormod Volden (tormodvolden) wrote :

Ok, I found http://autopkgtest.ubuntu.com/autopkgtest-output/linux-wlan-ng/log but I can't reproduce this on a normal system.

Ian Jackson (ijackson) wrote :

Tormod Volden writes ("[Bug 128002] Re: gutsy/amd64: ftbfs / autopkgtest failure"):
> Ian, can we close this bug now? Have you tried the autopkgtest again?

No, the autopkgtest system hasn't got around to it again yet but will
do so shortly. However, when it does, it will re-file the bug
automatically if the build fails. So if you think this bug is fixed
you may close it.

However, looking at the change log for the most recent upload:

  linux-wlan-ng (0.2.8+dfsg-1ubuntu3) gutsy; urgency=low

    * No-change upload to build on lpia.

   -- Matthias Klose <email address hidden> Fri, 24 Aug 2007 19:27:14 +0200

and the version which is reported as having failed is
0.2.8+dfsg-1ubuntu2.

So it seems that there has been no source code change. Why do you
think the problem is fixed ?

FYI, I have reproduced the problem like this:

ian@anarres:/work/AutomatedTesting-packages $ dpkg-source -x /export/mirror/ubuntu/pool/main/l/linux-wlan-ng/linux-wlan-ng_0.2.8+dfsg-1ubuntu3.dsc
gpg: Signature made Fri Aug 24 18:27:49 2007 BST using DSA key ID 0F932C9C
gpg: Can't check signature: public key not found
dpkg-source: extracting linux-wlan-ng in linux-wlan-ng-0.2.8+dfsg
dpkg-source: unpacking linux-wlan-ng_0.2.8+dfsg.orig.tar.gz
dpkg-source: applying /export/mirror/ubuntu/pool/main/l/linux-wlan-ng/linux-wlan-ng_0.2.8+dfsg-1ubuntu3.diff.gz
ian@anarres:/work/AutomatedTesting-packages $ mkdir tmp
ian@anarres:/work/AutomatedTesting-packages $ export TMPDIR=/work/AutomatedTesting-packages/tmp
ian@anarres:/work/AutomatedTesting-packages $ cd linux-wlan-ng-0.2.8+dfsg/
ian@anarres:/work/AutomatedTesting-packages/linux-wlan-ng-0.2.8+dfsg $ debian/rules build
test -d debian/patched || install -d debian/patched
dpatch apply-all
applying patch BUILD_config_in to ./ ...patch: **** Can't create file .modules/po2faH4o : No such file or directory
 failed.
make: *** [patch-stamp] Error 1
ian@anarres:/work/AutomatedTesting-packages/linux-wlan-ng-0.2.8+dfsg $ ls -al ../tmp/
total 8
drwxrwsr-x 2 ian anarubun 4096 Aug 31 14:44 .
drwxrwsr-x 4 ian anarubun 4096 Aug 31 14:44 ..
ian@anarres:/work/AutomatedTesting-packages/linux-wlan-ng-0.2.8+dfsg $ ls -al .modules
ls: .modules: No such file or directory
ian@anarres:/work/AutomatedTesting-packages/linux-wlan-ng-0.2.8+dfsg $

Ian.

Changed in linux-wlan-ng:
importance: Undecided → High
status: Incomplete → Confirmed
Tormod Volden (tormodvolden) wrote :

I was hoping it was a bug in your auto-tester program :)
It is something with setting TMPDIR, I can also reproduce when I set it like you did. I will take a closer look.

Tormod Volden (tormodvolden) wrote :

debian/rules sets a variable TMPDIR for its own purpose, and creates the directory only for some make targets. The environment variable TMPDIR is also used by programs such as patch and tac, hence the error. I'll suggest changing the debian/rules variable name to something else. Its value should probably be something based on TMPDIR in the best case.

Does that sound reasonable? If so, I can make a patch, or maybe better, include it in the debdiff in bug #114793.

Ian Jackson (ijackson) wrote :

Tormod Volden writes ("[Bug 128002] Re: gutsy/amd64: ftbfs / autopkgtest failure"):
> debian/rules sets a variable TMPDIR for its own purpose, and creates the
> directory only for some make targets. The environment variable TMPDIR is
> also used by programs such as patch and tac, hence the error. I'll
> suggest changing the debian/rules variable name to something else. Its
> value should probably be something based on TMPDIR in the best case.
>
> Does that sound reasonable? If so, I can make a patch, or maybe better,
> include it in the debdiff in bug #114793.

That sounds sensible. You might consider sending the diff to the
Debian BTS as well.

Thanks,
Ian.

Tormod Volden (tormodvolden) wrote :

I added the fix to the debdiff in bug #114793.

Changed in linux-wlan-ng:
assignee: tormodvolden → nobody
Changed in linux-wlan-ng:
status: Unknown → New
Tormod Volden (tormodvolden) wrote :

Ian, since you milestoned it to tribe-6, can there be a chance you'll upload the fix?

Ian Jackson (ijackson) wrote :

Tormod Volden writes ("[Bug 128002] Re: gutsy/amd64: ftbfs / autopkgtest failure"):
> Ian, since you milestoned it to tribe-6, can there be a chance you'll
> upload the fix?

Absolutely, just done so.

Thanks for your patch.

Regards,
Ian.

Tormod Volden (tormodvolden) wrote :

I was hoping you would upload the whole debdiff in bug #114793... Thanks anyway.

Ian Jackson (ijackson) wrote :

Tormod Volden writes ("[Bug 128002] Re: gutsy/amd64: ftbfs / autopkgtest failure"):
> I was hoping you would upload the whole debdiff in bug #114793... Thanks
> anyway.

Oh! I hadn't spotted all that. I didn't realise you were looking for
a sponsor for a bunch of other changes. I'll see what I can do.

Ian.

Tormod Volden (tormodvolden) wrote :

> Oh! I hadn't spotted all that. I didn't realise you were looking for
> a sponsor for a bunch of other changes. I'll see what I can do.

Thanks! I am desperate!

Henrik Nilsen Omma (henrik) wrote :

Assigning FTBFS bug based on last upload.

Changed in linux-wlan-ng:
assignee: nobody → ijackson
Ian Jackson (ijackson) wrote :

This should be fixed in 0.2.8+dfsg-1ubuntu4.

Changed in linux-wlan-ng:
status: Confirmed → Fix Released
Tormod Volden (tormodvolden) wrote :

linux-wlan-ng (0.2.8+svn1832+dfsg-2ubuntu1) gutsy; urgency=low

  [ Tormod Volden ]
  * Merge from Debian unstable, remaining changes:
    - Ubuntu maintainer fields in control.*
    - debian/control updates concerning modules in Ubuntu kernels
    - etc/Makefile: no hotplug agent in Ubuntu
    - etc/rc.wlan: say p80211.ko instead of p80211.o
  * debian/control.firmware: drop recommends on -modules package
    in Ubuntu (LP: #115580)
  * wlan-udev.sh: remove dbus-send call
  * debian/rules: rename local TMPDIR variable which clashes with the
    environment variable of the same name (LP: #128002)
  * Ubuntu bugs resolved in new Debian version:
    - debian/linux-wlan-ng.modprobe: enable writeable extensions for
      network-manager operation (LP: #115594)

linux-wlan-ng (0.2.8+svn1832+dfsg-2) unstable; urgency=low

  * Removed spurious slash in .install file (Closes: #435008)
  * Fixed prism2_* loading in case p80211 is already loaded (Closes: #429624)
  * Moved linu-wlan-ng.modules to linux-wlan-ng.modprobe so that it actually
    does something. Added option wlan_wext_write=1 for 80211 so the wireless
    extensions are turned on by default. Restored dh_installmodules.
  * Integrated ubuntu changes to /etc/wlan/wlan-udev.sh that are friendly to
    NetworkManager. This should also close 429624 since now the firmware is
    loaded at the right time and the nic should be in an usable state just
    after plugging it (Closes: #429624)
  * Removed spurious patches
  * Removed from postinst the removal of /dev/nul that used to be created in
    version << 0.1.14-13 that is so obsolete that not even oldstable has it.
    This also avoids a bogus lintian error

linux-wlan-ng (0.2.8+svn1832+dfsg-1) unstable; urgency=low

  * Updated to svn revision 1832 that adds support for kernel 2.6.22
    (Closes: 434703)

 -- Tormod Volden <email address hidden> Wed, 15 Aug 2007 20:51:11 +0200

Changed in linux-wlan-ng:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.