Hardy: igb support for Intel 82576

Bug #352440 reported by Christian Gils on 2009-03-31
44
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux-ubuntu-modules-2.6.24 (Ubuntu)
Wishlist
Stefan Bader
Hardy
Undecided
Unassigned

Bug Description

SRU Justification:

Impact: The Intel 82576 network card is not supported on Hardy but newer motherboards are shipped with these.

Fix: Add the current Intel standalone igb driver under a new name and with already supported PCI IDs removed to LUM. Both the old and new driver can be used concurrently.

Testcase: Load old and new driver in parallel to check for concurrency. Successfully tested on real hardware (see below)

---

Can support for the Intel 82576 be backported to the igb driver in Hardy?

Some newer HP motherboards are shipping with the interface. [Note: almost *all* Nehalem-based motherboards ship with this interface]

Attached information is from a machine using the interface but installed with Jaunty.

Christian Gils (cgils) wrote :
Christian Gils (cgils) wrote :
Christian Gils (cgils) wrote :
Christian Gils (cgils) wrote :
remraf (sanjeev-friendfeed) wrote :

Any updates on this? It's not just HPs, new server boards from Supermicro, MSI, Tyan and Gigabyte also ship with the 82576, due to its better virtualization performance. Not being able to install 8.04 makes a farce of "LTS" :(

Michael Shadle (mshadle) wrote :
Michael Shadle (mshadle) wrote :
Michael Shadle (mshadle) wrote :
Michael Shadle (mshadle) wrote :

Please include this in 8.04.4.

Some internet providers only allow imaging for LTS releases. They also sell Nehalem-based machines, which have the new igb driver for networking, and they cannot be used. It looks like 8.04.3 backported an igb driver but either it's not new enough, or the pciids are not up to date.

This is extremely important, and should not be a big deal to fix.

I've attached a copy of dmesg, lspci -vnvn, and modinfo igb - all from a working 9.04 install on the machine. I have virtual media access and netboot, so I am able to install the non-LTS versions but all the configuration is manual and I do not get any of my ISP's automation benefits because of this.
uname -a = Linux abc123 2.6.28-14-server #47-Ubuntu SMP Sat Jul 25 02:03:55 UTC 2009 x86_64 GNU/Linux

I think the driver just needs to be updated. Please consider this a high priority, as Nehalems everywhere are unusable currently unless using 9.04 install media, which is not an option in many environments. CentOS/RHEL/FreeBSD all work out of the box, but Ubuntu LTS does not. This is not good for Intel if people are trying to use their brand new Nehalem with Ubuntu LTS.

Note that the 9.04 kernel/driver version works just fine, if that makes things any easier.

It *may* also help with this bug too:
https://bugs.launchpad.net/ubuntu/+source/xen-3.2/+bug/236268

Michael Shadle (mshadle) on 2009-08-04
description: updated
tags: added: igb nehalem
Stefan Bader (smb) wrote :

To avoid regressions with the current driver I added the latest standalone driver as igb-next to LUM. This module has the PCI IDs supported by the normal igb driver stripped away and the modules should be able to coexist with the present module. I placed test packages to http://people.canonical.com/~smb/bug352440/.
Please try one of those and report back if this works or not.

Changed in linux-ubuntu-modules-2.6.24 (Ubuntu):
assignee: nobody → Stefan Bader (stefan-bader-canonical)
importance: Undecided → Wishlist
status: New → In Progress
Stéphane Graber (stgraber) wrote :

I tried the generic amd64 on a HP Proliant server and it worked perfectly.
I needed to pxeboot the installer, so I had to manually copy the igb-next.ko and dca.ko (module dependency of igb-next.ko) using a USB stick, then it worked perfectly.

Stéphane

Stefan Bader (smb) on 2009-09-01
description: updated
Yingying Zhao (yingying-zhao) wrote :

Can we add this module to Hardy installer?

Yingying Zhao wrote:
> Can we add this module to Hardy installer?

Yes, I add it to the modules list, so it will be present when the 8.04.4 update
is built.

Stéphane Graber (stgraber) wrote :

Hi,

I'm running in an OpenVZ environment, do you have an ETA on when the kernel will be available in -proposed or could you provide an updated package for 2.6.24-24 openvz amd64 ?

Thanks

Stefan Bader (smb) wrote :

Stéphane, not sure how long it will take to get the real proposed modules, so I
placed some openvz versions to the same location.

Stéphane Graber (stgraber) wrote :

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Stefan Bader wrote:
> Stéphane, not sure how long it will take to get the real proposed modules, so I
> placed some openvz versions to the same location.
>

Thanks a lot.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iEYEARECAAYFAkqeVvQACgkQjxyfqkjBhuwghQCeLKtiXf2vWu/paeZr62hjmngf
wIUAn3gp5oOHDrQNoj0kVGBP7G6RTPLe
=1Rrc
-----END PGP SIGNATURE-----

Stefan Bader (smb) on 2009-09-08
Changed in linux-ubuntu-modules-2.6.24 (Ubuntu):
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

I suppose that this is fixed in Karmic.

Changed in linux-ubuntu-modules-2.6.24 (Ubuntu):
status: Fix Committed → Fix Released
Changed in linux-ubuntu-modules-2.6.24 (Ubuntu Hardy):
status: New → Fix Committed
tags: added: verification-needed
Martin Pitt (pitti) wrote :

Accepted linux-ubuntu-modules-2.6.24 into hardy-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Stéphane Graber (stgraber) wrote :

Work for me, thanks a lot.

Stéphane Graber (stgraber) wrote :

Actually, the igb-next.ko module is missing from the openvz kernel in the archive.
I got a bit confused having Stefan's package installed already.
Sorry for that.

Stéphane Graber (stgraber) wrote :

root@service01:~# dpkg --contents /var/cache/apt/archives/linux-ubuntu-modules-2.6.24-24-openvz_2.6.24-24.40_amd64.deb | grep igb-next

root@service01:~# dpkg --contents /root/linux-ubuntu-modules-2.6.24-24-openvz_2.6.24-24.39bug352440v1_amd64.deb | grep igb-next
drwxr-xr-x root/root 0 2009-09-02 03:55 ./lib/modules/2.6.24-24-openvz/ubuntu/net/igb-next/
-rw-r--r-- root/root 146864 2009-09-02 03:55 ./lib/modules/2.6.24-24-openvz/ubuntu/net/igb-next/igb-next.ko

First is Stefan's package, second is the one from hardy-proposed.

Sorry about this. Seems I failed to pick up a change from my local build system
  into the patch. I will fix that up tomorrow.

Martin Pitt (pitti) on 2009-09-15
tags: added: verification-failed
removed: verification-needed
Shang Wu (shangwu) wrote :

I can confirm the package from smb (http://people.canonical.com/~smb/bug352440/) fixes the Intel 82576 card.

Thanks Stefan!

Shang Wu (shangwu) wrote :

However, enable the propose, using the .40 linux-ubuntu-module doesn't seem to have the igb-next driver in it.

Martin Pitt (pitti) wrote :

Accepted linux into hardy-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Stefan Bader (smb) wrote :

@Shang, Stéphane, could one of you confirm that the .41 upload of LUM correctly contains the igb-next module? Thanks.

Stéphane Graber (stgraber) wrote :

root@service01:/lib/modules# dpkg --contents /var/cache/apt/archives/linux-ubuntu-modules-2.6.24-24-openvz_2.6.24-24.41_amd64.deb | grep igb-next
drwxr-xr-x root/root 0 2009-09-18 12:56 ./lib/modules/2.6.24-24-openvz/ubuntu/net/igb-next/
-rw-r--r-- root/root 146864 2009-09-18 12:56 ./lib/modules/2.6.24-24-openvz/ubuntu/net/igb-next/igb-next.ko

I can confirm it's there, rebooting the server now to check if it works (might take a while).

Stéphane Graber (stgraber) wrote :

Server is back online and working correctly with .41.
Tested on two boxes with the same NIC.

tags: added: verification-done
removed: verification-failed verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-ubuntu-modules-2.6.24 - 2.6.24-24.41

---------------
linux-ubuntu-modules-2.6.24 (2.6.24-24.41) hardy-proposed; urgency=low

  [Stefan Bader]

  * SAUCE: igb-next: Fix up the makefile to actually do a build
    - LP: #352440

linux-ubuntu-modules-2.6.24 (2.6.24-24.40) hardy-proposed; urgency=low

  [AceLan Kao]

  * SAUCE: Fix the MIC of the Lenovo webcam problem
    - LP: #310760

  [Stefan Bader]

  * Merge WEXT scan capabilities to iwlwifi
    - LP: #200950
  * SAUCE: Add support in e1000e for a couple of ICH10 PCI IDs
    - LP: #322737
  * Add standalone Intel igb driver as igb-next to support 82576 cards
    - LP: #352440

 -- Stefan Bader <email address hidden> Mon, 14 Sep 2009 21:05:16 +0200

Changed in linux-ubuntu-modules-2.6.24 (Ubuntu Hardy):
status: Fix Committed → Fix Released
Stéphane Graber (stgraber) wrote :

Would it be possible to have an updated initrd.gz for the netinstaller ?

Colin Watson (cjwatson) wrote :

I've uploaded debian-installer 20070308ubuntu40.12, which should be accepted in the not too distant future.

Benjamin Baumer (bbaumer-abm) wrote :

The dca module is missing in the initrd.gz for netinstaller. igb-next is depending on it.
I manually packed the module dca from linux-image-2.6.24-24-generic_2.6.24-24.61_amd64.deb in the initrd. Now netboot ist working.

Please add the dca module in initrd.gz for the netinstaller.

Adam Guthrie (therigu) wrote :

Is is possible to get an install CD with this fix in?

Michael Shadle (mshadle) wrote :

+1 that would greatly help the adoption of this. probably isn't -too- difficult for someone who knows what they're doing.

of course, i assume that once it is installed that it won't downgrade the kernel to a previous version - that the hardy kernels now all have this in it.

Mathieu Mitchell (mat128) wrote :

#32 this is affecting us too.
Manually loading igb-next (modprobe igb-next) says some errors happened.
Using dmesg, we can see a bunch of messages looking like this:
igb_next: Unknown symbol dca_remote_requester

Michael Shadle (mshadle) wrote :

Again - can someone make a CD w/ this kernel on it already for us? :) Even a vanilla server CD w/ the kernel injected in it would work. Ideally it would be an official CD, but even someone who knows how to do it would work.

Mathieu Mitchell (mat128) wrote :

I can arrange something to give you the initrd I just made to test. I was using the netboot i386 version (booting off PXE).

We won't be going in production with a custom fix like this but at least the operating kernel has the right modules.
This major issue (network driver aimed by this bug report isn't loaded) that could be solved by a minor fix.

For your medias, check hardy's release schedule and you will notice there is no more point releases. You will have to wait for the next LTS which is in 2 months.

Check out Ubuntu's documentation on building the installation medias. Pretty much everything is well documented and you only have to follow the steps.

Changed in linux-ubuntu-modules-2.6.24 (Ubuntu):
status: Fix Released → Incomplete
Steve Langasek (vorlon) wrote :

Setting this back to fixed for the linux-ubuntu-modules-2.6.24 package, which AIUI is the case. That it's not usable from the network installer is unfortunate, but not a bug of this particular package (and as noted, it's now too late to further fix this officially for hardy).

Changed in linux-ubuntu-modules-2.6.24 (Ubuntu):
status: Incomplete → Fix Released
vitich (vitich-gmail) wrote :

I tried to install 8.04.4 server downloaded from ubuntu.com but my intel 82576 network card is not supported!
Why not fixed yet?
I need LTS system and I have no time to wait for 10.04
Hope you answer me

Mathieu Mitchell (mat128) wrote :

Your card won't be supported in the installer due to issues previously mentioned. However, the card will be supported once the OS is fully installed.

Josh Enders (josh-enders) wrote :

I echo the sentiments of #35. I'll probably just end up rolling my own netinstall media. So that others are aware, I'm experiencing symptoms of a mis-matched kernel/initrd with the files currently located at:

    http://archive.ubuntu.com/ubuntu/dists/hardy/main/installer-amd64/20070308ubuntu40.13/images/netboot/ubuntu-installer/amd64/linux
    http://archive.ubuntu.com/ubuntu/dists/hardy/main/installer-amd64/20070308ubuntu40.13/images/netboot/ubuntu-installer/amd64/pxelinux.0

My SHA-1 checksums are:
    90f241a08c1d68380a207d2060b4029c460f2b54 initrd.gz
    6a7230ecd11b21cfc4cf49096b07a677f546a9e4 linux

~ # uname -a
Linux (none) 2.6.24-26-generic #1 SMP Tue Dec 1 17:55:03 UTC 2009 x86_64 unknown

~ # lspci -vv -nn | grep Ethernet
05:00.0 Ethernet controller [0200]: Intel Corporation Unknown device [8086:10c9] (rev 01)
05:00.1 Ethernet controller [0200]: Intel Corporation Unknown device [8086:10c9] (rev 01)

~ # insmod /lib/modules/2.6.24-26-generic/ubuntu/net/igb-next/igb-next.ko
insmod: error inserting 'igb-next.ko': -1 Unknown symbol in module

~ # dmesg | grep igb_next
[ 297.557857] igb_next: Unknown symbol dca_remove_requester
[ 297.558028] igb_next: Unknown symbol dca_get_tag
[ 297.558267] igb_next: Unknown symbol dca_add_requester
[ 297.558372] igb_next: Unknown symbol dca_unregister_notify
[ 297.558428] igb_next: Unknown symbol dca_register_notify
[ 297.563823] igb_next: Unknown symbol dca_remove_requester
[ 297.563993] igb_next: Unknown symbol dca_get_tag
[ 297.564232] igb_next: Unknown symbol dca_add_requester
[ 297.564337] igb_next: Unknown symbol dca_unregister_notify
[ 297.564393] igb_next: Unknown symbol dca_register_notify

Josh Enders (josh-enders) wrote :

Looking for a fix?

The tl;dr version is to copy /lib/modules/2.6.24-26-generic/kernel/drivers/dca/dca.ko from the linux-image-2.6.24-26-generic_2.6.24-26.64_amd64.deb to the root of the most current initrd. [1]

---

As a follow-up, my assertion was incorrect- It's not that the initrd/kernel are mismatched, although the symptoms are similar, it's that a dependency for igb-next.ko is missing in the latest netinstall media for hardy: dca.ko. This is all too clear when you examine dmesg output after a full night sleep: "igb_next: Unknown symbol dca_*". This was mentioned by an earlier commenter but I overlooked the post.

You can also verify this by using modinfo to check the module dependency:

$ modinfo igb-next.ko | grep depends
 depends: dca

In order to get igb-next.ko loaded and the kernel to recognize the Intel 82576 ethernet card properly, we need to do some modification of the initrd.

The following steps will create patched Hardy netinstall media that will recognize the Intel 82576 ethernet card. Do not forget to use the appropriate kernel for the initrd this process creates.:
    http://archive.ubuntu.com/ubuntu/dists/hardy/main/installer-amd64/20070308ubuntu40.13/images/netboot/ubuntu-installer/amd64/linux

$ sudo mkdir -p destroot/lib/modules/2.6.24-26-generic/kernel/drivers/dca/
$ wget http://archive.ubuntu.com/ubuntu/dists/hardy/main/installer-amd64/20070308ubuntu40.13/images/netboot/ubuntu-installer/amd64/initrd.gz
$ zcat initrd.gz | ( cd destroot && sudo cpio -i )
$ wget http://launchpadlibrarian.net/36450254/linux-image-2.6.24-26-generic_2.6.24-26.64_amd64.deb
$ dpkg --fsys-tarfile linux-image-2.6.24-26-generic_2.6.24-26.64_amd64.deb | sudo tar -xOf - ./lib/modules/2.6.24-26-generic/kernel/drivers/dca/dca.ko > destroot/lib/modules/2.6.24-26-generic/kernel/drivers/dca/dca.ko
$ ( cd destroot && find . -print0 | sudo cpio -0 -H newc -o ) | gzip -c > initrd.gz.patched

sudo is needed so that cpio can create the device files /dev/console and /dev/null in your buildroot and for consistent file permissions.

[1] I linked this file incorrectly in post #41, should NOT have been http://archive.ubuntu.com/ubuntu/dists/hardy/main/installer-amd64/20070308ubuntu40.13/images/netboot/ubuntu-installer/amd64/pxelinux.0 but instead http://archive.ubuntu.com/ubuntu/dists/hardy/main/installer-amd64/20070308ubuntu40.13/images/netboot/ubuntu-installer/amd64/initrd.gz . I apologize for the confusion.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers