linux: hardy: Add support for Atheros(R) AR8121/AR8113/AR8114/AR8131/AR8132 PCI-E Ethernet NICs

Bug #341183 reported by Colin Ian King on 2009-03-11
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux-ubuntu-modules-2.6.24 (Ubuntu)
Colin Ian King

Bug Description

SRU Request:

Add support for Atheros(R) AR8121/AR8113/AR8114/AR8131/AR8132 PCI-E Ethernet NICs for Hardy

Drivers are available from:

Changed in linux-ubuntu-modules-2.6.24:
assignee: nobody → colin-king
importance: Undecided → Low
milestone: none → ubuntu-8.04.3
status: New → In Progress
Colin Ian King (colin-king) wrote :

SRU justification:

Impact: Newer Atheros NICS AR8121/AR8113/AR8114/AR8131/AR8132 with PCI
ID's 0x1969:1026 0x1969:1062 0x1969:1063 0x1969:1066,0x1969:1067 are not
supported in Hardy.


Testcase: NICs with the PCI ID's listed above without the patch result
in no detection. With the patch they are detected and the NICs are

Colin Ian King (colin-king) wrote :
Changed in linux-ubuntu-modules-2.6.24:
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

Is that fixed in Jaunty? Please update the jaunty/karmic bug task.

Changed in linux-ubuntu-modules-2.6.24 (Ubuntu Hardy):
milestone: none → ubuntu-8.04.3
status: New → Fix Committed
Changed in linux-ubuntu-modules-2.6.24 (Ubuntu):
milestone: ubuntu-8.04.3 → none
tags: added: verification-needed
Martin Pitt (pitti) wrote :

Accepted into hardy-proposed; please test and give feedback here. Please see for documentation how to enable and use -proposed. Thank you in advance!

Steve Beattie (sbeattie) on 2009-05-01
tags: added: hw-specific
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-ubuntu-modules-2.6.24 - 2.6.24-24.39

linux-ubuntu-modules-2.6.24 (2.6.24-24.39) hardy-proposed; urgency=low

  [Colin Ian King]

  * Add support for Atheros AR8121/AR8113/AR8114/AR8131/AR8132 NICs
    - LP: #341183
  * atl1c: Enable ethtool support
    - LP: #349478

linux-ubuntu-modules-2.6.24 (2.6.24-24.38) hardy-proposed; urgency=low

  [Stefan Bader]

  * Update for bumped kernel ABI

 -- Stefan Bader <email address hidden> Wed, 08 Apr 2009 22:30:24 +0200

Changed in linux-ubuntu-modules-2.6.24 (Ubuntu Hardy):
status: Fix Committed → Fix Released
afeet (afeet) wrote :

This Bug is still in jaunty 2.6.28-14

The card Atheros AR8132 is in the new Aspire one D250 Netbook.

Jeremy Audet (ichimonji10) wrote :

This bug still affects me, using Jaunty 2.6.28-15-generic The card I am using is the Atheros AR8131 chipset.

By the way, I tried downloading the driver given by Atheros at this page:

The driver is given by Atheros and is specifically intended for linux distros. However, when I try to extract the file, it appears to be corrupt. (and this is after downloading 3 times)

AAARRRR, I'm just going to download 8.04 and install that instead until this bug has been fixed.

yaohua (johnsnowsyh) wrote :

here's how I solved this:

1. download the AR81Family-linux-v1.0.0.10.tar.gz from

2. extract it from Windows XP. Then copy the whole directory using a thumb drive to linux (Ubuntu). (I tried extract it under ubuntu, but there's errors).

3.say the extracted folder is now (in linux): <HOME_DIR>/network_driver, cd into HOME_DIR>/network_driver/src
4 then : sudo KBUILD_NOPEDANTIC=1 make
5 then : sudo KBUILD_NOPEDANTIC=1 make install
6 cd into /lib/modules/2.6.28-16-generic/kernel/drivers/net/atl1e/at1le.ko
7 cd into that director and i run: sudo insmod ./atl1e.ko

now it worked when I plug in the ethernet cable.

(I followed another post from the web, which I forgot the source, but the above procedure works for my Acer Aspire 5516, running a Ubuntu 9.04)

Jeremy Audet (ichimonji10) wrote :

@yaohua: THANK YOU

That fix worked perfectly for me running Ubuntu 9.04 64-bit on my Acer Aspire 3810TZ. This fix worked for me with both the 2.6.28-11 and 2.6.28-15 kernel.

Richard Humphries (2richardh) wrote :

Thank you yaohua !

This works for me also - Ubuntu Jaunty (9.04) 32bit for the Atheros AR8131 on-board gigabit NIC on my new Gigabyte GA-G31M-ES2L motherboard.

Andres Alonso (andresalonso-a) wrote :

This Bug is still in Karmic Beta.

Thank you yaohua! Your fix worked for me as well. I wanted to note that I already had a module present at /lib/modules/2.6.28-15-generic/kernel/drivers/net/atl1e/at1le.ko, but this pre-installed one didn't work. I had to download the one from Atheros.

Chris Coleman (chris-ascended) wrote :

Okay, I've tried yaohua's fix (on an Acer 5516 running Ubuntu 9.04), and it began to work, but at step six it informed me that there is no such file or directory as /lib/modules/2.6.28-15-generic/kernel/drivers/net/atl1e/at1le.ko (and I had already had to switch from -16 to -15 due to the nonexistence of the former). I figured the 1 and the l might have become transposed in that step, and, sure enough, I discovered a file named /lib/modules/2.6.28-15-generic/kernel/drivers/net/atl1e/atl1e.ko, but when I tried cd on it it told me it wasn't a directory. I can cd into /lib/modules/2.6.28-15-generic/kernel/drivers/net/atl1e, but if I try sudo insmod ./atl1e.ko from there it tells me "insmod: error inserting './atl1e.ko': -1 File exists"

I'm new to Ubuntu, and I really don't know how to interpret anything to do with the terminal, much less figure out what my problem is. I can provide more information if necessary (and if you tell me what information to provide... remember, I'm a n00b).


afeet (afeet) wrote :


just updated to kernel 2.6.28-16 and eth0 seems to work without compiling and inserting the module.
I can see eth0 using ifconfig.
I can't check the function. I'm connected via WLan and no cable at home.

Can anybody confirm that the bug is solved?


Martin Pitt (pitti) on 2009-10-28
Changed in linux-ubuntu-modules-2.6.24 (Ubuntu):
status: Fix Committed → Invalid
pawan (pawanspace) wrote :

I have also tried Its not working can any one please please upload the driver!

Jeremy Audet (ichimonji10) wrote :

@afeet From what I remember, I was able to upgrade to the 2.6.28-16 kernel and use both eth0 and wlan0 with zero extra configuration. However, it's been a while since I upgraded, so I can't let you know for sure. I'm currently running Ubuntu 9.10 with the 2.6.31-14 kernel, and both eth0 and wlan0 both work without any extra configuration at all.

@pawan I tried grabbing the driver off my own laptop, but to no avail. I've already upgraded to 9.10, and it looks like the driver is no longer needed. I'd guess that's why the driver is no longer available on the atheros website. Heck, I even tried looking on, but it looks like all the (outdated) downloads they link to are no longer available. My best advice is to go ahead and install the newest version of Ubuntu -- the upside being that you won't have to bother looking for an outdated driver at all.

That's all I've got for you. :\

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers