kernel upgrade 2.6.24-18-generic killed gspca

Bug #240107 reported by Neville Chandler on 2008-06-15
8
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
linux-ubuntu-modules-2.6.24 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: linux-ubuntu-modules-2.6.24-18-generic

After kernel upgrade 2.6.24-18-generic, the webcam ( Creative PD1170 ) has stopped working. The module 'gspca' will not load and generates an error message and /dev/vide0 is not created.

The package containing this module is linux-ubuntu-modules-2.6.24-18-generic 2.6.24-18.26
Ubuntu 8.04 Hardy Heron.
I expected the webcam to work as it usually did with ekiga and xawtv
Camera failed to work.

I've stopped using 2.6.24-18 and went back to 2.6.24-17-generic which works perfectly.

Plugging the camera in with 2.6.24.17

# lsusb
Bus 001 Device 005: ID 041e:401f Creative Technology, Ltd Webcam Notebook

# dmesg
[ 720.126712] usb 1-1.1: new full speed USB device using uhci_hcd and address 6
[ 720.140702] usb 1-1.1: configuration #1 chosen from 1 choice
[ 720.149731] usb 1-1.1: ZC0301[P] Image Processor and Control Chip detected (vid/pid 0x041E:0x401F)
[ 720.199872] usb 1-1.1: No supported image sensor detected
[ 720.215680] /build/buildd/linux-ubuntu-modules-2.6.24-2.6.24/debian/build/build-generic/media/gspcav1/gspca_core.c: USB GSPCA camera found.(ZC3XX)
[ 721.117057] /build/buildd/linux-ubuntu-modules-2.6.24-2.6.24/debian/build/build-generic/media/gspcav1/gspca_core.c: init isoc: usb_submit_urb(0) ret -28

 /dev/video0 is present.

Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

Hi Neville,

Is this still an issue with the more recent 2.6.24-19 release?

Also since development for the upcoming Intrepid Ibex 8.10 release is under way, care to confirm this is still an issue with the latest Alpha for the upcoming Intrepid Ibex 8.10. You should be able to test via a LiveCD - http://www.ubuntu.com/testing. Please let us know your results. If the issue still exists, per the kernel team's bug policy, can you please attach the following information. Please be sure to attach each file as a separate attachment.

* cat /proc/version_signature > version.log
* dmesg > dmesg.log
* sudo lspci -vvnn > lspci-vvnn.log

For more information regarding the kernel team bug policy, please refer to https://wiki.ubuntu.com/KernelTeamBugPolicies . Thanks again and we appreciate your help and feedback.

Additionally, beginning with the Intrepid Ibex 8.10 development cycle the linux-ubuntu-modules package was actually merged with the linux kernel package. Going forward, bugs that would have been reported against linux-ubuntu-modules should now just be reported against linux. I'll go ahead and add the 'linux' task for this report. Thanks.

Changed in linux-ubuntu-modules-2.6.24:
status: New → Incomplete
Changed in linux:
status: New → Incomplete
Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Revision history for this message
Warren Butler (grumpymole) wrote :

This camera still does not work under the new kernels.

I can get it recognised using this procedure: http://ubuntuforums.org/showpost.php?p=5968151&postcount=1

But I get green video now. But at least the camera is recognised by the system.

Revision history for this message
Andres Mujica (andres.mujica) wrote :

Hi thanks a lot for your bug report, i'm marking this as dupe from bug #144745 as that one is being worked on and is the same problem triggered by zc0301 and gspca handling same camera.

Thanks a lot, please further development there.

Revision history for this message
pushbx (kennytung) wrote :

I have the same green video problem as Warren using skype v2.0.0.72 on a clean install of ubuntu 8.10. The problem isn't a driver conflict as with the 2.6.24 kernels, but a problem with the v4l libraries that skype uses. The work around, from thread on bug #144745 is to do the follow:

LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype

video works now.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers