Intel 3945: please disable_hw_scan=1 by default --- struggling to connect to AP that worked fine in Gutsy

Bug #226410 reported by Neil Wilson on 2008-05-04
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux-ubuntu-modules-2.6.24 (Ubuntu)
Undecided
Unassigned
Hardy
Undecided
Unassigned

Bug Description

I have a WPA personal wireless network which worked fine with Gutsy - reconnected at logon and generally didn't cause any problems at all. Since upgrading to Hardy though I struggle to get the network to connect and get random drops for no good reason.

I can't quite work out from the traces whether it is network manager that is getting confused about what is coming from the kernel driver, or the kernel driver that isn't doing what it is supposed to. There seems to be a lot of 'moved out of area' and 'transmitted before authenticated' messages flying around.

Whatever it is, it ain't robust like it used to be, so from my point of view it is definitely a regression.

Neil Wilson (neil-aldur) wrote :

This is a trace when the network activated and then dropped seconds later.

Neil Wilson (neil-aldur) wrote :

uname -a
Linux neil-laptop 2.6.24-16-generic #1 SMP Thu Apr 10 12:47:45 UTC 2008 x86_64 GNU/Linux

modinfo iwl3945
filename: /lib/modules/2.6.24-16-generic/ubuntu/wireless/iwlwifi/iwlwifi/compatible/iwl3945.ko
license: GPL
author: Copyright(c) 2003-2007 Intel Corporation
version: 1.2.0
description: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux
srcversion: 8E95C617988943846696F97
alias: pci:v00008086d00004227sv*sd*bc*sc*i*
alias: pci:v00008086d00004222sv*sd*bc*sc*i*
depends: iwlwifi_mac80211
vermagic: 2.6.24-16-generic SMP mod_unload
parm: antenna:select antenna (1=Main, 2=Aux, default 0 [both]) (int)
parm: disable:manually disable the radio (default 0 [radio on]) (int)
parm: hwcrypto:using hardware crypto engine (default 0 [software])
 (int)
parm: debug:debug output mask (int)
parm: disable_hw_scan:disable hardware scanning (default 0) (int)
parm: queues_num:number of hw queues. (int)
parm: qos_enable:enable all QoS functionality (int)

Martin Zuther (mzuther) wrote :

Hi Neil,

I don't know if this article is related to your problem, but it solved my problems, so maybe you should give it a try:

http://ubuntuforums.org/showthread.php?t=820297

The solution in short:

# sudo rmmod -f iwl3945
# sudo modprobe iwl3945 disable_hw_scan=1

All the best from Germany,

Martin

Alexander Sack (asac) wrote :

tim, we should really disable this kind of automagic stuff in drivers ;) ... assigning to you to decide.

Changed in network-manager:
status: New → Invalid
Changed in linux:
status: Invalid → New
assignee: nobody → timg-tpi
importance: Undecided → Medium
status: New → Triaged
Tim Gardner (timg-tpi) wrote :

SRU Justification

Impact: iwl3945 performs asynchronous background channel scanning which confuses NetworkManager

Patch Description: disable hardware scanning

Patch: http://kernel.ubuntu.com/git?p=ubuntu/ubuntu-hardy-lum.git;a=commit;h=fbdb96b72104e432145c03349c4db1b8c79a25fe

Test case: see bug description

Changed in linux:
status: Triaged → Fix Committed
Martin Pitt (pitti) wrote :

Accepted into hardy-proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in linux-ubuntu-modules-2.6.24:
status: New → Fix Committed
Martin Zuther (mzuther) wrote :

Hi Martin,

I have been running the kernel 2.6.27-8-generic for a few days now, and so far my WLAN connection hasn't dropped out, nor has the kernel itself shown any problems. I have tried this both when the kill switch was off during startup and also when it was switched too the off state after the laptop had already been running.

The only thing that doesn't work is the automatic detection of networks after changing the kill switch. Network manager says something like "WLAN networks disabled" ("Funknetzwerke sind deaktiviert" in German...), which is also grayed out, and running "sudo iwlist scan" results in

  lo Interface doesn't support scanning.

  eth0 Interface doesn't support scanning.

  irda0 Interface doesn't support scanning.

  wmaster0 Interface doesn't support scanning.

  wlan0 Interface doesn't support scanning : Network is down

  pan0 Interface doesn't support scanning.

Running

  sudo modprobe -r iwl3945
  sudo modprobe iwl3945

actually starts a scan and connects me to known WLAN networks.

Thanks for working on this bug, and please tell me if you need further informations.

Martin

Martin Pitt (pitti) wrote :

Hello Martin,

thanks for testing. Your kill switch problem is most likely bug 193970. Maybe you can test 2.6.27-10 from intrepid-proposed? It is supposed to fix it.

Martin Pitt (pitti) wrote :

Oops, sorry, this update is for hardy, whereas bug 193970 only has a fix for intrepid.

Martin Zuther (mzuther) wrote :

Hi Martin,

I think this issue is closed for me. If something out of the normal happens, I'll be back... ;)

I have subscribed to bug 193970 to hear about the kill switch issue, so there's no need to cross-post here. Thanks for the hint!

Martin

Steve Langasek (vorlon) wrote :

Accepted into intrepid-proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Martin Zuther (mzuther) wrote :

Hi Steve,

too much to do for the last weeks... :)

I've been running "intrepid" with the fix for a long time, and everything's fine (apart from https://bugs.launchpad.net/bugs/193970). For details, see here: https://bugs.launchpad.net/proposed-tracking/+bug/300140/comments/2

Merry Christmas,

Martin

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-ubuntu-modules-2.6.24 - 2.6.24-23.36

---------------
linux-ubuntu-modules-2.6.24 (2.6.24-23.36) hardy-proposed; urgency=low

  [Adrian Bunk]

  * sms1xxx: dvb/siano/: cleanups
    - LP: #301204

  [Amit Kucheria]

  * Marvell 8686 driver update from moblin to fix suspend issues
    - LP: #291558
  * LPIA: Updated poulsbo driver to 2.2.0.32L.0020
    - LP: #291582

  [Colin Ian King]

  * Enable appleir driver for new MacBook Pro
    - LP: #157919

  [Mackenzie Morgan]

  * Add quirk for ASUS Z37E to make sound audible after resume
    - LP: #25896

  [Michael Krufky]

  * au0828: add new USB IDs for HVR950Q
    - LP: #299634
  * sms1xxx: fix product name for Hauppauge WinTV MiniStick
    - LP: #299640
  * sms1xxx: Add new USB product ID for Hauppauge WinTV MiniStick
    - LP: #299636
  * sms1xxx: support two new revisions of the Hauppauge WinTV MiniStick
    - LP: #299636
  * sms1xxx: use new firmware for Hauppauge WinTV MiniStick
    - LP: #299671
  * sms1xxx: add USB IDs for Hauppauge WinTV MiniCard DVB-T
    - LP: #299680
  * sms1xxx: add autodetection support for Hauppauge WinTV MiniCard
    2040:200a
    - LP: #299680
  * sms1xxx: add functions to configure and set gpio
    - LP: #301204
  * sms1xxx: turn off LEDs after initialization of Hauppauge WinTV
    MiniStick
    - LP: #301204
  * sms1xxx: enable power LED on Hauppauge WinTV MiniStick
    - LP: #301405
  * sms1xxx: enable LNA control on Hauppauge WinTV MiniCard
    - LP: #301204
  * sms1xxx: fix invalid unc readings
    - LP: #301204
  * sms1xxx: enable signal quality indicator LEDs on Hauppauge WinTV
    MiniStick
    - LP: #301405

  [Stefan Bader]

  * Import git-ubuntu-log from kernel repository
  * alsa: backport alc662 update to enable CMPC 1.5
    - LP: #301785

  [Tim Gardner]

  * Backoport iwlwifi 5000 (Shirley Peak) wireless driver
    - LP: #264063
  * Add microcode for iwlwifi 5000.
    - LP: #264063
  * iwl3945 - set disable_hw_scan=1
    - LP: #226410

linux-ubuntu-modules-2.6.24 (2.6.24-22.35) hardy-security; urgency=low

  ABI bump to -22

linux-ubuntu-modules-2.6.24 (2.6.24-22.34) hardy-proposed; urgency=low

  [Amit Kucheria]

  * Marvell 8686 driver update from moblin to fix suspend issues
    - LP: #291558
  * LPIA: Updated poulsbo driver to 2.2.0.32L.0020
    - LP: #291582

  [Colin Ian King]

  * Enable appleir driver for new MacBook Pro
    - LP: #157919

  [Mackenzie Morgan]

  * Add quirk for ASUS Z37E to make sound audible after resume
    - LP: #25896

  [Stefan Bader]

  * SAUCE: buildenv: Import git-ubuntu-log from kernel repository

  [Tim Gardner]

  * Backoport iwlwifi 5000 (Shirley Peak) wireless driver
    - LP: #264063
  * Add microcode for iwlwifi 5000.
    - LP: #264063
  * iwl3945 - set disable_hw_scan=1
    - LP: #226410

 -- Stefan Bader <email address hidden> Mon, 24 Nov 2008 17:01:59 +0100

Changed in linux-ubuntu-modules-2.6.24:
status: Fix Committed → Fix Released

Neil, since you are the original bug reporter, let us know if this is not resolved for you. Thanks.

It seems to be much better in Intrepid. I still get occasional issues
but I haven't been able to narrow them down to anything repeatable.
I'm happy for this to close and I'll open another one if and when I
get chance to work out what the issue is (if anything).

Thanks to all concerned. Nice work.

2009/1/8 Leann Ogasawara <email address hidden>:
> Neil, since you are the original bug reporter, let us know if this is
> not resolved for you. Thanks.
>
> --
> Intel 3945: please disable_hw_scan=1 by default --- struggling to connect to AP that worked fine in Gutsy
> https://bugs.launchpad.net/bugs/226410
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Neil Wilson

Hey Neil,

On Thu, Jan 08, 2009 at 09:45:56PM -0000, Neil Wilson wrote:
> It seems to be much better in Intrepid. I still get occasional issues
> but I haven't been able to narrow them down to anything repeatable.
> I'm happy for this to close and I'll open another one if and when I
> get chance to work out what the issue is (if anything).

Is there any chance you could retest under hardy with the kernel that
was just pushed to hardy-updates? Thanks!

--
Steve Beattie
<email address hidden>
http://NxNW.org/~steve/

Neil Wilson (neil-aldur) wrote :

I've upgraded to Intrepid now. Is there a way of doing that without mashing my disk?

Tim Gardner (timg-tpi) on 2009-04-14
Changed in linux-ubuntu-modules-2.6.24 (Ubuntu):
assignee: Tim Gardner (timg-tpi) → nobody
importance: Medium → Undecided
status: Fix Committed → Invalid
midenok (midenok) wrote :

Don't try to fix something that you don't understand fully. Please, revert to normal default!

http://ubuntuforums.org/showthread.php?t=1837729

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers