iwl3945 fails at connecting to unprotected AP

Bug #210005 reported by Forceflow
Affects Status Importance Assigned to Milestone
linux-ubuntu-modules-2.6.24 (Ubuntu)

Bug Description

Binary package hint: linux-ubuntu-modules-2.6.24-12-generic

This is my controller:

04:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)

iwconfig says:

wlan0 IEEE 802.11g ESSID:"" Nickname:""
          Mode:Managed Frequency:2.457 GHz Access Point: XX:XX:XX:XX:XX
          Tx-Power=27 dBm
          Retry min limit:7 RTS thr:off Fragment thr=2346 B
          Power Management:off
          Link Quality:0 Signal level:0 Noise level:0
          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
          Tx excessive retries:0 Invalid misc:0 Missed beacon:0

Worked fine in Gutsy (old kernel with ipw3945), has some quirks after I dist-upgraded to Hardy (new kernel with ilw3945). After fixing the wlan0/wlan0_rename bug described in #204709, the following still fails.

I'm running a freshly reset Siemens Gigaset SE105 router, which is configured to serve as an open connection point. I can see the AP in my network manager network list, at good signal strength, but when I try to connect, it can't get authenticated. I've attached my DMESG output, which indicates something goes wrong. I get the same behaviour when I turn on WEP encryption.

I tested the AP in windows and with the gutsy kernel version: all worked correctly and fast. Please note that this has nothing to do with the #185470 (iwl3945 microcode error) bug, my output is different. Also note that I can connect perfectly to my wireless router on campus, which also is an open AP.

Revision history for this message
Forceflow (baertman) wrote :
Revision history for this message
Jesus M. Gonzalez-Barahona (jgb-computer) wrote :

See http://wiki.debian.org/iwlwifi

It seems you need to run "ip link set wlan0 up" before setting the ESSID. From that url:

If the card accepts the essid, for example, by doing

iwconfig wlan0 essid YourESSID

but does not associate to the access point even when no encryption is
needed: The driver seems to need the interface to be in the up state
when it gets the essid. So first do

ip link set wlan0 up

then set the essid as before.

It is working for me with this.

Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

Hi Forceflow,

You may also want to try installing the 'linux-backports-modules' package as it has an updated version of the iwlwifi drivers (version 1.2.25). You can check the version of the driver you are using by running:

  modinfo iwl3945

Please let us know your results. Thanks.

Changed in linux-ubuntu-modules-2.6.24:
status: New → Incomplete
Revision history for this message
wolfger (wolfger) wrote :

6 months with no response: We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in linux-ubuntu-modules-2.6.24:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.