iwl3945 takes too much time to load at boot

Bug #177768 reported by Matteo Collina on 2007-12-20
6
Affects Status Importance Assigned to Milestone
linux-ubuntu-modules-2.6.24 (Ubuntu)
Medium
Unassigned

Bug Description

The boot process hangs for a while during the "loading drivers" step.
I'm quite sure the problems is related to this module, iwl3945 because even in gutsy after installing the latest version of this driver I experienced it.
I'm referring to Tim Gardner's PPA, as said in this comment: https://bugs.launchpad.net/ubuntu/+source/linux-ubuntu-modules-2.6.22/+bug/144621/comments/54

Matteo Collina (matteo-collina) wrote :

I fixed my problem added this line at the end of the /etc/modprobe.d/blacklist file:
blacklist iwl3945

Then I added in the /etc/modules file:
mac80211
iwl3495

Hi Matteo,

Seems like you've resolved this? Am closing this report. Thanks.

Changed in linux-ubuntu-modules-2.6.24:
status: New → Won't Fix
Matteo Collina (matteo-collina) wrote :

Well actually I did a workaround that stopped working after last kernel update. With my workaround the module stopped loading at all.
This is a very annoying bug that slow too much the boot process. It should be solved without any workaround because people aren't usually aware of it. It should work out of the box, remember that iwl3945 is the default driver for that hardware in hardy.

Changed in linux-ubuntu-modules-2.6.24:
status: Won't Fix → New

Thanks for the udpate Matteo. Per the kernel team's bug policy, can you please attach the following information. Please be sure to attach each file as a separate attachment.

* uname -a > uname-a.log
* cat /proc/version_signature > version.log
* dmesg > dmesg.log
* sudo lspci -vvnn > lspci-vvnn.log

For more information regarding the kernel team bug policy, please refer to https://wiki.ubuntu.com/KernelTeamBugPolicies . Thanks again and we appreciate your help and feedback.

Changed in linux-ubuntu-modules-2.6.24:
status: New → Incomplete
Matteo Collina (matteo-collina) wrote :
Matteo Collina (matteo-collina) wrote :
Matteo Collina (matteo-collina) wrote :
Matteo Collina (matteo-collina) wrote :

It looks like your dmesg cache filled up. Care to recapture your dmest output immediately after a fresh reboot. Also, can you comment how long the "delay" is that you are experiencing? Thanks.

it's about 30 seconds.

Changed in linux-ubuntu-modules-2.6.24:
status: Incomplete → New
Changed in linux-ubuntu-modules-2.6.24:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: New → Triaged
Erlenmayr (erlenmayr) wrote :

I am pretty sure that the iwl driver is the problem, because when the radio kill switch is active (and wireless lan disabled) booting up is much faster.

Benjamin Thyreau (benji2) wrote :

Hi,
I had the same symptom, ie. the boot sequence was a lot longer (as bootchart clearly confirmed) when the wireless switch of my laptop was ON during the boot sequence, until i tried the suggestion found on bug 204709 (
https://bugs.launchpad.net/ubuntu/+source/linux-ubuntu-modules-2.6.24/+bug/204709 ). Manual edition of /etc/udev/rules.d/70-persistent-net.rules to remove the "eth1" entry fixed my problems. Now the computer boots the same speed whichever position is the wireless switch, and going to hibernate mode and back doesn't confuse it either.
My laptop is Dell D430, with iwl3945 wireless driver, on up-to-date Hardy, kernel 2.6.24-12-generic

That solved my problem too!

This is a problem of the upgrade from gutsy to hardy: the ipw3945 driver leaves an udev rule that must be deleted to make the new iwl3945 working properly.

Benjamin Thyreau (benji2) wrote :

Considering the previous comments, i think this bug can safely marked as duplicate of bug #183968

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers