RAM upgrade (2x2GB RAM) on Kubuntu Gutsy Gibbon -> Not able to connect by IPW3945 WiFi

Bug #183859 reported by Armando Beneduce on 2008-01-17
6
Affects Status Importance Assigned to Milestone
linux-ubuntu-modules-2.6.22 (Ubuntu)
Undecided
Unassigned

Bug Description

After RAM upgrade (2x2GB RAM) on Kubuntu Gutsy Gibbon I'm not able to connect by WiFi IPW3945.
If in place of 2x2GB I prefer 2GB+512MB memory or the original setup (512MB+512MB) the wireless card properly works.
On different OS I found no problems.

description: updated

By adding kernel option mem=3G, the Wifi card properly works but obviously only 3GB RAM are available.
I'm using kernel 2.6.22-14-generic (the default Kubuntu Gutsy Gibbon 64bit edition kernel).

Hi Armando,

Thank you for taking the time to report this bug and helping to make Ubuntu better. First, this bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in "linux-ubuntu-modules-2.6.22" .

The Hardy Heron Alpha series was recently released. Alpha2 and subsequent releases contain an updated version of the kernel. You can download and try the new Hardy Heron Alpha release from http://cdimage.ubuntu.com/releases/hardy/ . You should be able to then test the new kernel via the LiveCD. If you can, please verify if this bug still exists or not and report back your results. General information regarding the release can also be found here: http://www.ubuntu.com/testing/ .

Also with Hardy, I'd suggest using the iwlwifi drivers (iwl3945) as it appears development efforts have shifted to the iwlwifi project. Refer to http://ipw3945.sourceforge.net/ for more information. Hope that helps. Thanks!

madgunnar (madgunnar) wrote :

I can confirm this bug on a Toshiba A200 with Ubuntu 7.10 amd64.

The ipw3945 works with both 2x512MB and 1x2GB. With 2x2GB it isn't able to get an IP via DHCP. In roaming mode you can see networks, and my router indicates that the ipw3945 gets associated with it even though it doesn't get an IP.

uname -r
Linux barbar 2.6.22-14-generic #1 SMP Tue Feb 12 02:46:46 UTC 2008 x86_64 GNU/Linux

madgunnar (madgunnar) wrote :

Hi madgunnar,

Care to actually test the latest Hardy Heron 8.04 Beta release - http://www.ubuntu.com/testing. You should be able to test via the LiveCD. If you still experience this issue, the linux-backports-modules-2.6.24 package has an updated version of iwlwifi (version 1.2.25) which you should also test if you can. Please let us know your results. Thanks.

madgunnar (madgunnar) wrote :

Hi,

Tested the 8.04 amd64 beta on my Toshiba A200-1A5 now. The problem I had with the ipw3945 is solved. Everything works from scratch when booting the live-cd with all 4GB, network, bluetooth, and even the hda-intel sound card seems to work as it should. I must say that I'm really impressed with this release.

I'm attaching a dmesg log from a working scenario for good measures.

/Anders

Thanks Anders. I'm marking this "Fix Released". Armando, if this is still an issue for you please feel free to reopen (ie set status from "Fix Released" to "New"). Thanks.

Changed in linux-ubuntu-modules-2.6.22:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers