[gutsy] 2.6.22-12 breaks rt2x00 driver with rt2500 based card

Bug #144079 reported by Richie Ward on 2007-09-22
24
Affects Status Importance Assigned to Milestone
linux-source-2.6.22 (Ubuntu)
Undecided
Unassigned
linux-ubuntu-modules-2.6.22 (Ubuntu)
High
Unassigned

Bug Description

In a recent Gutsy update, my rt2500 card has vanished from network manager and I can no longer connect to my wireless. I have had to resort to using wired networking. If there's any debugging output needed I will reply as soon as possible.

Patrick Regan (patrick-regan) wrote :

I am having the same problem.

booted back into 2.6.22-11 to get wireless back.

Patrick Regan (patrick-regan) wrote :

PS.

If you need output, I also will respond promptly.

Patrick Regan (patrick-regan) wrote :

I have been able to reproduce this multiple times.

Changed in linux-source-2.6.22:
status: New → Confirmed
gerard67 (mathieu-petit) wrote :

I also have this problem on a Dell M70 .. again, if commands outputs are needed, i'll be glad to help ...

Mathieu

gletob (gletob) wrote :

me too my card is a rt2571/rt73usb

gletob (gletob) wrote :

and going back a kernel fixed it

MCpaul34 (mcpaul34) wrote :

same for me.
i think that the maintener forget to build the kernel with the rt2500 module :)

Jasper Groenewegen (colbrac) wrote :

Same problem,

on 'sudo modprobe rt2500pci' syslog says that the module failed to load with error -2

DFreeze (dfreeze) wrote :

I have the same problem with a Ralink rt2600 MIMO card (PCMCIA). Not listed in the network menuitem, or in ifconfig / iwconfig since last kernelupdate. It did show up with the previous kernel.

Gareth Williams (gareththered) wrote :

I thought I'd join the club too! I've a boot option of 2.6.22-12-386 and 2.6.22-12-generic. Under the 'generic' kernel in '/lib/modules/2.6.22-12-generic' I have an 'ubuntu' directory with many drivers including the 'rt2500pci', but under the '386' gernel in 'lib/modules/2.6.22-12-386' I do not have an 'ubuntu' directory.
I'm now typing this after successfully booting with the 'generic' kernel.

Richie Ward (richies) wrote :

Assigned to ubuntu kernel team

Changed in linux-source-2.6.22:
assignee: nobody → ubuntu-kernel-team
Tim Gardner (timg-tpi) wrote :

There have no changes to the rt2x00 driver since 2.6.22-11. Make sure you have linux-ubuntu-modules-2.6.22-12 installed.

rkelly (rkelly) wrote :

RaLink RT2500 does not work for me either with kernel 2.6.22-12.
Rebooting with version 2.6.22-11 fixes the problem as a workaround..
Installed versions:
linux-ubuntu-modules-2.6.22-12 version 2.6.22-12.31
linux-image-2.6.22-12-generic version 2.6.22-12.39

I noticed the following in dmesg when booting 2.6.22-12:

[ 50.726234] ACPI: PCI Interrupt 0000:01:09.0[A] -> Link [APC2] -> GSI 17 (level, high) -> IRQ 21
[ 50.810886] ieee80211_init: failed to initialize WME (err=-17)
[ 50.826261] rc80211_simple: Unknown symbol iwlwifi_ieee80211_rate_control_unregister
[ 50.826305] rc80211_simple: Unknown symbol iwlwifi_sta_info_put
[ 50.826342] rc80211_simple: Unknown symbol iwlwifi_sta_info_get
[ 50.826399] rc80211_simple: Unknown symbol iwlwifi_ieee80211_rate_control_register
[ 50.827116] wmaster0: Failed to select rate control algorithm
[ 50.827119] wmaster0: Failed to initialize rate control algorithm
[ 50.853360] phy0 -> rt2x00lib_probe_dev: Error - Failed to initialize hw.
[ 50.853439] ACPI: PCI interrupt for device 0000:01:09.0 disabled
[ 50.853448] rt2500pci: probe of 0000:01:09.0 failed with error -2

Seems to me something somewhere must have changed due to the mentioned missing symbols...

This is the output for the same card when booting 2.6.22-11:

[ 37.916214] ACPI: PCI Interrupt 0000:01:09.0[A] -> Link [APC2] -> GSI 17 (level, high) -> IRQ 21
[ 37.965828] wmaster0: Selected rate control algorithm 'simple'

Tim Gardner (timg-tpi) wrote :

Whoops. Looks like the iwlwifi import whomped on a common header file that it shouldn't have.

Changed in linux-source-2.6.22:
assignee: ubuntu-kernel-team → timg-tpi
importance: Undecided → High
status: Confirmed → In Progress
Gareth Williams (gareththered) wrote :

I have linux-ubuntu-modules-2.6.22-12-generic but not linux-ubuntu-modules-2.6.22-12-386, which maybe explains why my modules aren't present. However, I do have both 386 and generic versions of the restricted modules. But it also begs the question, why have two versions of the same kernel installed? This was all done automatically by the update that my system picked up late last night (23rd Sept UK time). Maybe it shouldn't be a kernel team bug but a synaptics one?

Tim Gardner (timg-tpi) wrote :

Gutsy lum commit 2c1050ed40aa8b62b87e16ab03937edac2dc0f17 renames the iwlwifi version of rc80211_simple to iwlwifirc80211_simple in order to avoid a module namespace clash.

Changed in linux-source-2.6.22:
status: In Progress → Fix Committed
Tim Gardner (timg-tpi) on 2007-09-25
Changed in linux-source-2.6.22:
assignee: timg-tpi → nobody
status: Fix Committed → Fix Released
Changed in linux-source-2.6.22:
status: New → Invalid
Andriy Tymchenko (silpol) wrote :

I still see same messages about unknown symbols iwlwifi_ yadayadayada, and wifi doesn't work. I have 2.6.22-14.smthng kernel (apt-get upgrade done tonight). What shall i do to help fix it!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers