gspca module is not available for powerpc anymore

Bug #140954 reported by fuoco on 2007-09-19
2
Affects Status Importance Assigned to Milestone
linux-ubuntu-modules-2.6.22 (Ubuntu)
Undecided
Unassigned
linux-ubuntu-modules-2.6.24 (Ubuntu)
Medium
Colin Ian King

Bug Description

It seems the gspca.ko module driver for many webcams is no longer available in the kernel/module packages for powerpc of version 2.6.22 (aka gutsy kernel). This is a regression as it was there in feisty and maybe before, and it is still there for other architectures.

any news about this problem, so that we can have it before gutsy?

This has been completely ignored so far. I'm still not seeing that even in hardy - even though it is built for other architectures. Is there a reason for that?
It would be good to deal with it before the coming Feature Freeze I suppose...

Hi fuoca,

Sorry for the delayed response. This does appear to be disabled for powerpc in Hardy. I'll have the kernel team take a look. Thanks.

~/ubuntu-hardy-lum/debian/config$ grep -rn "CONFIG_GSPCA" *
0list:32:CONFIG_GSPCA=m
amd64:38:CONFIG_GSPCA=m
hppa:31:#CONFIG_GSPCA=m
i386:39:CONFIG_GSPCA=m
ia64:31:#CONFIG_GSPCA=m
lpia:33:CONFIG_GSPCA=m
powerpc:32:#CONFIG_GSPCA=m
sparc:31:#CONFIG_GSPCA=m

Changed in linux-ubuntu-modules-2.6.24:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: New → Triaged
Changed in linux-ubuntu-modules-2.6.22:
status: New → Won't Fix
Ben Collins (ben-collins) wrote :

Colin, please test build this on a powerpc machine before committing. There may be some long forgotten reason that this isn't enabled anywhere except on x86 architectures.

Changed in linux-ubuntu-modules-2.6.24:
assignee: ubuntu-kernel-team → colin-king
milestone: none → hardy-alpha-6
Changed in linux-ubuntu-modules-2.6.24:
status: Triaged → In Progress
Colin Ian King (colin-king) wrote :

Builds OK on powerpc, cannot see any reason (build wise) why this was originally omitted for powerpc.

Changed in linux-ubuntu-modules-2.6.24:
status: In Progress → Fix Committed

it works for me well in cheese, thanks a lot!

Steve Langasek (vorlon) wrote :

No mention of this in the changelog, but the module is there in 2.6.24-11.15:

$ dpkg -c main/l/linux-ubuntu-modules-2.6.24/linux-ubuntu-modules-2.6.24-11-powerpc_2.6.24-11.15_powerpc.deb |grep -i gspca
drwxr-xr-x root/root 0 2008-03-01 16:27:28 ./lib/modules/2.6.24-11-powerpc/ubuntu/media/gspcav1/
-rw-r--r-- root/root 332848 2008-03-01 16:27:28 ./lib/modules/2.6.24-11-powerpc/ubuntu/media/gspcav1/gspca.ko
$

Changed in linux-ubuntu-modules-2.6.24:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers