wifi needs to be switched off then back on again in order for network-manager to use it.

Bug #119563 reported by Dave Morley on 2007-06-09
16
Affects Status Importance Assigned to Milestone
linux-ubuntu-modules-2.6.22 (Ubuntu)
Medium
Unassigned

Bug Description

I have a compaq c300. It has an intel 3945 chipset in feisty everything works fine. However in gutsy everytime I switch the machine on I have to switch the wifi off then back on in order to get a connection. I don't think it is an issue with n-m as once I switch it back on everything works as it should. dbmurray has had a thought that it maybe the kernel due to the killswitch registering as off (i think).

Przemysław Kulczycki (azrael) wrote :

I have the same bug on Feisty. My laptop is HP Compaq nx6325, my wifi card is Broadcom 4310, I use ndiswrapper.

Brian Murray (brian-murray) wrote :

Thanks for taking the time to report this bug and helping to make Ubuntu better. Unfortunately we can't fix it, because your description doesn't yet have enough information.
Please include as attachments the following additional information, if you have not already done so (please pay attention to lspci's additional options), as required by the Ubuntu Kernel Team:
1. Please include the output of the command 'uname -a' in your next response. It should be one, long line of text which includes the exact kernel version you're running, as well as the CPU architecture.
2. Please run the command 'dmesg > dmesg.log' and attach the resulting file 'dmesg.log' to this bug report.
3. Please run the command 'sudo lspci -vvnn > lspci-vvnn.log' and attach the resulting file 'lspci-vvnn.log' to this bug report.
For your reference, the full description of procedures for kernel-related bug reports is available at https://wiki.ubuntu.com/KernelTeamBugPolicies . Thanks in advance!

Ok, it looks like have the same problem with a X61s. Here are attached the info you requested:

$ uname- a
Linux carbon 2.6.22-9-generic #1 SMP Fri Aug 3 00:50:37 GMT 2007 i686 GNU/Linux

I must add that this is the procedure I am using to be able to get a wifi connection:

- Enable wifi in the network manager applet
- Select the network I want to connect
- Switch on the kill switch
- Switch off the kill switch to get again the wifi.
- Then it works

So I always need this switching wifi off/on just after I selected the network I want to access.

Brian Murray (brian-murray) wrote :

Network manager logs information in '/var/log/daemon.log'. It would also be helpful to see that file after you have experienced the issue. Thanks again!

Tim Gardner (timg-tpi) on 2007-08-08
Changed in linux-source-2.6.22:
assignee: brian-murray → timg-tpi
importance: Undecided → Medium
status: Incomplete → Confirmed

Ok here is what I did and you have the daemon.log attached.

At about 20:25 I put the computer out of sleep.
At 20:25 I had to activate the kill switch and then I activated the wifi again at 20:26.
At 20:27 I was connected on the HELIUM network.

You know most likely better than me how to read the daemon.log, so here you have it starting with the time when the computer went out of sleep.

Thanks,
loïc

As this morning I got an update of the network manager, here is a new dmesg and daemon.log

After restarting my system (X61s) this morning, it is now working. I have a pack of 42 updates to install now, I will install them and do some further testing.

Yeah! It now works for me! Even after a suspend!

Przemysław Kulczycki (azrael) wrote :

I don't have this bug on Gutsy. Seems fixed to me.

Tim Gardner (timg-tpi) wrote :

Seems like updates fixed this problem.

Changed in linux-ubuntu-modules-2.6.22:
assignee: timg-tpi → nobody
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers