[gutsy] no LFE in hda-intel + sigmatel stac9200

Bug #119457 reported by Juan Pablo Salazar Bertín on 2007-06-09
20
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ALSA driver
In Progress
Unknown
linux-ubuntu-modules-2.6.22 (Ubuntu)
Medium
Ben Collins

Bug Description

Binary package hint: linux-source-2.6.22

I'm testing Gutsy Tribe 1 in a Dell Inspiron 9400 (card: HDA Intel; chip: SigmaTel STAC9200).
LFE is not being detected, or at least there's no volume control and I don't hear any sound through it.
LFE was working in Feisty.

yostral (y-o) wrote :

Same computer, same audio chip, same problem.
No sound from LFE and no volume control for it.

Changed in linux-source-2.6.22:
status: Unconfirmed → Confirmed
Brian Murray (brian-murray) wrote :

Thanks for taking the time to report this bug and helping to make Ubuntu better. Could you please add the output requested at https://help.ubuntu.com/community/DebuggingSoundProblems as attachments? Thanks in advance.

Changed in linux-source-2.6.22:
assignee: nobody → brian-murray
status: Confirmed → Needs Info
Download full text (36.4 KiB)

Output files added.
_________________________________________________________________
Descubre Live.com - tu mundo en línea reunido: noticias, deportes, el tiempo, y mucho más.
http://www.live.com/getstarted

Simple mixer control 'Master',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 2 [6%] [-43.50dB] [on]
  Front Right: Playback 2 [6%] [-43.50dB] [on]
Simple mixer control 'PCM',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Mono:
  Front Left: Playback 255 [100%] [0.00dB]
  Front Right: Playback 255 [100%] [0.00dB]
Simple mixer control 'IEC958',0
  Capabilities: pswitch pswitch-joined cswitch cswitch-joined
  Playback channels: Mono
  Capture channels: Mono
  Mono: Playback [off] Capture [off]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 15
  Front Left: Capture 0 [0%] [0.00dB] [off]
  Front Right: Capture 0 [0%] [0.00dB] [off]
Simple mixer control 'Capture Mux',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 4
  Front Left: 0 [0%] [0.00dB]
  Front Right: 0 [0%] [0.00dB]
Simple mixer control 'Input Source',0
  Capabilities: enum
  Items: 'Mic' 'Front Mic' 'Line'
  Item0: 'Mic'

Names of available sound cards:
Intel

[ 0.000000] Linux version 2.6.22-6-generic (buildd@rothera) (gcc version 4.1.3 20070528 (prerelease) (Ubuntu 4.1.2-9ubuntu2)) #1 SMP Fri Jun 1 19:24:12 GMT 2007
[ 0.000000] BIOS-provided physical RAM map:
[ 0.000000] BIOS-e820: 0000000000000000 - 000000000009f000 (usable)
[ 0.000000] BIOS-e820: 000000000009f000 - 00000000000a0000 (reserved)
[ 0.000000] BIOS-e820: 0000000000100000 - 000000003f6d3400 (usable)
[ 0.000000] BIOS-e820: 000000003f6d3400 - 0000000040000000 (reserved)
[ 0.000000] BIOS-e820: 00000000f0000000 - 00000000f4007000 (reserved)
[ 0.000000] BIOS-e820: 00000000f4008000 - 00000000f400c000 (reserved)
[ 0.000000] BIOS-e820: 00000000fec00000 - 00000000fec10000 (reserved)
[ 0.000000] BIOS-e820: 00000000fed20000 - 00000000feda0000 (reserved)
[ 0.000000] BIOS-e820: 00000000fee00000 - 00000000fee10000 (reserved)
[ 0.000000] BIOS-e820: 00000000ffb00000 - 0000000100000000 (reserved)
[ 0.000000] 118MB HIGHMEM available.
[ 0.000000] 896MB LOWMEM available.
[ 0.000000] Entering add_active_range(0, 0, 259795) 0 entries of 256 used
[ 0.000000] Zone PFN ranges:
[ 0.000000] DMA 0 -> 4096
[ 0.000000] Normal 4096 -> 229376
[ 0.000000] HighMem 229376 -> 259795
[ 0.000000] early_node_map[1] active PFN ranges
[ 0.000000] 0: 0 -> 259795
[ 0.000000] On node 0 totalpages: 259795
[ 0.000000] DMA zone: 32 pages used for memmap
[ 0.000000] DMA zone: 0 pages reserved
[ 0.000000] DMA zone: 4064 pages, LIFO batch:0
[ 0.000000] Normal zone: 1760 pages used for memmap
[ 0.000000] Normal zone: 223520 pages, LIFO batch:31
[ 0.000000] HighMem zone: 237 pages used for memmap
[ 0.000000]...

Changed in linux-source-2.6.20:
assignee: brian-murray → ubuntu-audio
importance: Undecided → Medium
status: Needs Info → Confirmed

it should be 2.6.22 (gutsy)

Andrea Caminiti (nrayever) wrote :

hi everyone!

i got the same problem here with my laptop. it is a dell inspiron 9400 with soundcard: HDA Intel; chip: SigmaTel STAC9200. the lfe volume bar corresponds to the bass speaker volume. hope that this get fixed soon. because right now music sounds awful!

on previous version of ubuntu (7.04, 6.10 and 6.06) i founded a method to make it work. and it was this one:

-------------------------------------------------------------------------------
Manually tell the driver which flavor you are using

Edit the file /etc/modprobe.d/alsa-base

Code:
sudo nano /etc/modprobe.d/alsa-base
Add the line "options snd-hda-intel model=ref"

Reboot
------------------------------------------------------------------------------

and seem not to work with gutsy. thanks a lot guys.

nrayever

David Gerber (zapek) wrote :

This is similar as bug #80199. Fix used to be in GIT. Why was it removed?

Andrea Caminiti (nrayever) wrote :

David:

that's a mystery that only kernel developers may answer. i always have had this problem. and i had to set it up manually, because it never worked out of the box. hope that this problems get solved some day.

nrayever

Andrea Caminiti (nrayever) wrote :

new update to alsa-mixer today july 31, but this problem still there! do anyone have a alternate way to fix this??

Please at least set a milestone for this bug.
There are other things not working, like audio input, but I'm not sure if I should file new audio related bugs before this one gets fixed.
Thanks.

David Gerber (zapek) wrote :

Patch attached and tested.
Apply against 2.6.22-9.25.

Mikael Nilsson (mini) wrote :

The same applies to both the M1710 and the M90 (more or less identical machines), (see patch context, they have the model=ref hack too).

See this bug:

https://bugtrack.alsa-project.org/alsa-bug/view.php?id=2092

Please modify the patch to add support for them too

Andrea Caminiti (nrayever) wrote :

it may sound stupid, but may i ask how to apply the patch?? or should i wait until it is added to the mainstream??

nrayever

Mikael Nilsson (mini) wrote :

Has been reported as a new bug.

mån 2007-08-20 klockan 08:50 +0000 skrev Mikael Nilsson:
> Has been reported as a new bug.
>
> ** Changed in: alsa-driver (upstream)
> Bugwatch: ALSA Bug Tracker #2092 => ALSA Bug Tracker #3319

The above bug also has a more complete patch:

https://bugtrack.alsa-project.org/alsa-bug/file_download.php?file_id=2158&type=bug

>
--
<email address hidden>

Plus ça change, plus c'est la même chose

Ben Collins (ben-collins) wrote :

Gutsy lum commit c12dbfdf0f428f697bd3be960879c31c3396b28d

Changed in linux-source-2.6.22:
assignee: ubuntu-audio → ben-collins
status: Confirmed → Fix Committed

What is the status on this bug, also have the same issue on my Dell 9400, worked fine in Feisty.

Mikael Nilsson (mini) wrote :

The latest ALSA driver does fix the issue (compiled from their
repository). It's a question of whether this will be included in the
Gutsy kernel.

lör 2007-09-15 klockan 00:52 +0000 skrev snowpunk98:
> What is the status on this bug, also have the same issue on my Dell
> 9400, worked fine in Feisty.
>
--
<email address hidden>

Plus ça change, plus c'est la même chose

Changed in alsa-driver:
status: Unknown → In Progress
Joel Oliver (joelol75) wrote :

As an update this trick... Adding "options snd-hda-intel model=ref"... DID NOT work for me anymore with Gutsy or the latest Linux Mint based on Gutsy even after using the restricted modules backports...

What did work for my Inspiron 9400 is "options snd-hda-intel model=5stack"

Just a note for those pulling their hair out to give this a try.

Looks like the commit Ben made was released and should be available in the linux-ubuntu-modules-2.6.22-14 package. Marking status from "Fix Committed" to "Fix Released". Thanks.

Changed in linux-ubuntu-modules-2.6.22:
status: Fix Committed → Fix Released

The bug is back with Ubuntu 14.04 (Ubuntu Trusty ). I'm running a DELL Inspiron 9400 (since 2007).

I had to manually `sudo nano /etc/modprobe.d/alsa-base.conf` then add `options snd-hda-intel model=ref` at the end.

It was a long time I was suspecting an issue, as “Clavinova Grand” and “Clavinova Bright” was surprisingly sounding the same.

By the way, adding `options snd-hda-intel model=ref` at the end of `sudo nano /etc/modprobe.d/alsa-base.conf`, I now have “Bass Speaker” instead of “LFE” in ALSA mixer.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.