et131x driver for Agere ET131x gigabit ethernet cards

Bug #102291 reported by Bernhard Gehl on 2007-04-03
12
Affects Status Importance Assigned to Milestone
linux-ubuntu-modules-2.6.22 (Ubuntu)
Low
Unassigned

Bug Description

The driver is maintained at http://sourceforge.net/projects/et131x/ under a BSD license.

Additional information can be found at http://dadams1969.googlepages.com/et131xkernelmodule . Sorry if I did something wrong - I haven't filed a "bug"/packaging request before.

Daniel Holbach (dholbach) wrote :

Thanks for your bug report.

Yotam Benshalom (benshalom) wrote :

I join that request. This ethernet card is the standard in many LG laptop models.

Bernhard Gehl (bernhard-gehl) wrote :

Update: the website I mentioned earlier is no longer updated (it wasn't even when I opened this thread - oops).

A current version of the driver (including patches for stable MAC addresses, kernel 2.6.20 and stuff) can be found at http://sourceforge.net/projects/et131x .

Any chance to see this in Gutsy-restricted?

WillSmith (undertakingyou) wrote :

I join that request. This I think is becoming more popular in several laptop brands.

Tal Shachar (shachtal) wrote :

it is a very popular module for the network card of more than just a few LG laptops (many lenovo use it as well)
its not clear to me why it is not an "out of the box support" in a distribution like ubuntu that marked on its flag the simpleness of installation.

furthermore, even if you are a linux geek, you are stuck in some sort of a catch 22. in order to have internet--> you need the driver || in order to get the driver --> you need the internet..... :)
and then starts the trouble of defining usb disk on keys and tons of hell

i don't understand why they just won't put it as an out of the box thingy.
i mean, even if its license is a bit problematic from what i understand it is possible to put it as a restricted driver which only those who are interested will install, much like they do with ati drivers. (which is yet another tidiouse problem for those of you with readon xxxxx cards)

Tim Gardner (timg-tpi) wrote :

The source code license for this driver needs license clarification.

Tim Gardner (timg-tpi) wrote :

Never mind, I was wrong about the licensing. Its a 3 part BSD license. Gutsy lum commit 07071c7300036d886049d6c5c117056d49b5462b

Changed in linux-ubuntu-modules-2.6.22:
importance: Undecided → Low
status: Won't Fix → Fix Committed
Daniel Holbach (dholbach) wrote :

'needs-packaging' tag removed. This is a bug about an existing package; needs-packaging is about packages that are not in Ubuntu yet.

Kyle McMartin (kyle) wrote :

linux-ubuntu-modules-2.6.22 (2.6.22-13.33) gutsy; urgency=low

  [Ben Collins]

  * ubuntu/d-i: Add atl2 module to udeb
    - LP: #148532

  [Matthew Garrett]

  * Work around uvc suspend issues
    - LP: #147757
  * Force-enable speakers on recent Thinkpads
    - LP: #140609

  [Tim Gardner]

  * Added et131x Gigabit ethernet driver support.
    - LP: #102291
  * AppArmor patch for disconnected path reporting
  * prism javelin/xbow works out-of-box, but the module is not loaded by
    default
    - LP: #133823
  * System freeze when bringing up rt2500pci interface
    - LP: #129183
  * [xps1330] microphone built-in doesn't work
    - LP: #147682
  * FUJITSU SIEMENS XTB70 snd-hda-intel fix
    - LP: #147827
  * Add ivtv-fb and saa717x support
    - LP: #147886

 -- Kyle McMartin <email address hidden> Thu, 04 Oct 2007 16:09:03 +0000

Changed in linux-ubuntu-modules-2.6.22:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers