ext2 module missing from fs-core-modules udeb.

Bug #984180 reported by Tobin Davis on 2012-04-17
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
The Eilt project
High
Unassigned
debian-installer (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned
linux-ti-omap4 (Ubuntu)
High
Paolo Pisati
Precise
High
Paolo Pisati

Bug Description

SRU:

BUG:

missing ext2 module from fs-core-modules

IMPACT:

partition fails during installation

FIX:

add ext2 kernel module to fs-core-modules

------

The ext2 module is missing from the fs-core-modules udeb package used by netboot to run guided partitioning during installation on both omap4 and armadaxp kernels. This causes the installer to fail when trying to mount /boot as ext2.

diff -u debian.master/d-i/modules/fs-core-modules debian.ti-omap4/d-i/modules/fs-core-modules
--- debian.master/d-i/modules/fs-core-modules 2012-01-13 10:30:32.000000000 +0000
+++ debian.ti-omap4/d-i/modules/fs-core-modules 2012-04-11 21:52:55.000000000 +0000
@@ -1,4 +1,3 @@
-ext2
 jfs
reiserfs
xfs

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-omap4 3.2.0.1412.12
ProcVersionSignature: User Name 3.2.0-1412.15-omap4 3.2.14
Uname: Linux 3.2.0-1412-omap4 armv7l
ApportVersion: 2.0.1-0ubuntu4
Architecture: armhf
Date: Tue Apr 17 10:05:23 2012
ProcEnviron:
 SHELL=/bin/bash
 TERM=vt102
 LANG=en_US.UTF-8
 LANGUAGE=en_US:
SourcePackage: linux-meta-ti-omap4
UpgradeStatus: No upgrade log present (probably fresh install)

Tobin Davis (gruemaster) wrote :
Changed in linux-armadaxp (Ubuntu):
importance: Undecided → High
Changed in linux-meta-ti-omap4 (Ubuntu):
importance: Undecided → High
affects: linux-meta-ti-omap4 (Ubuntu) → linux-ti-omap4 (Ubuntu)
Colin Watson (cjwatson) wrote :

I can confirm this on linux-ti-omap4, but whatever problem linux-armadaxp has is something different, since ext2 is built-in in the armadaxp config.

no longer affects: linux-armadaxp (Ubuntu)
Changed in linux-ti-omap4 (Ubuntu):
status: New → Triaged
Tobin Davis (gruemaster) wrote :

My bad on the armadaxp inclusion. Multiple issues going on, got caught in the crossfire (and I assumed the config was the same as omap4, as it was copied from there initially).

tags: added: bot-stop-nagging
Paolo Pisati (p-pisati) on 2012-04-17
description: updated
Changed in linux-ti-omap4 (Ubuntu Precise):
assignee: nobody → Paolo Pisati (p-pisati)
status: Triaged → Fix Committed
mahmoh (mahmoh) on 2012-04-17
Changed in eilt:
status: New → Fix Committed
importance: Undecided → High
Adam Conrad (adconrad) on 2012-04-18
Changed in debian-installer (Ubuntu Precise):
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-ti-omap4 - 3.2.0-1412.16

---------------
linux-ti-omap4 (3.2.0-1412.16) precise-proposed; urgency=low

  [ Paolo Pisati ]

  * add ext2 module to fs-core-modules udeb
    - LP: #984180
 -- Paolo Pisati <email address hidden> Tue, 17 Apr 2012 19:28:43 +0200

Changed in linux-ti-omap4 (Ubuntu Precise):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package debian-installer - 20101020ubuntu134

---------------
debian-installer (20101020ubuntu134) precise; urgency=low

  * Call mklibs with a hardcoded --ldlib in armhf.cfg, so we get a
    deterministic result in our linker search, and then add the
    symlink from the old linker path in build/Makefile (LP: #984007)
  * Rebuild with latest omap4 kernels for ext2 support (LP: #984180)
 -- Adam Conrad <email address hidden> Tue, 17 Apr 2012 23:20:29 -0600

Changed in debian-installer (Ubuntu Precise):
status: In Progress → Fix Released
Adam Conrad (adconrad) on 2012-04-18
Changed in eilt:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers