No analog audio on omap4 panda

Bug #925069 reported by Tobin Davis on 2012-02-01
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux-ti-omap4 (Ubuntu)
Undecided
Unassigned

Bug Description

Kernel warning in dmesg when trying to enable audio:
[ 427.277282] ------------[ cut here ]------------
[ 427.277313] WARNING: at /build/buildd/linux-ti-omap4-3.2.0/arch/arm/mach-omap2/omap_l3_noc.c:113 l3_interrupt_handler+0x100/0x170()
[ 427.277313] SDP4430 Media: unmute_fe_port: MultiMedia1 0
[ 427.277343] L3 custom error: MASTER:SDMA_Wr TARGET:ABE
[ 427.277343] Modules linked in: cpufreq_ondemand
[ 427.277343] SDP4430 Media: mute_fe_port_playback: unmute FE SDP4430 Media BE PDM-DL1
[ 427.277374] SDP4430 Media: mute_fe_port_playback: unmute FE SDP4430 Media BE PDM-DL2
[ 427.277374] ppdev lp parport rfcomm bnep bluetooth joydev wl12xx_sdio wl12xx dm_multipath mac80211 cfg80211 leds_gpio usbhid dm_raid45 xor dm_mirror dm_region_hash dm_log btrfs zlib_deflate libcrc32c
[ 427.277496] [<c0015cf0>] (unwind_backtrace+0x0/0xec) from [<c05e42b0>] (dump_stack+0x20/0x24)
[ 427.277526] [<c05e42b0>] (dump_stack+0x20/0x24) from [<c004fcf0>] (warn_slowpath_common+0x5c/0x74)
[ 427.277557] [<c004fcf0>] (warn_slowpath_common+0x5c/0x74) from [<c004fdc4>] (warn_slowpath_fmt+0x40/0x48)
[ 427.277557] [<c004fdc4>] (warn_slowpath_fmt+0x40/0x48) from [<c002e224>] (l3_interrupt_handler+0x100/0x170)
[ 427.277587] [<c002e224>] (l3_interrupt_handler+0x100/0x170) from [<c00ac058>] (handle_irq_event_percpu+0xc4/0x298)
[ 427.277618] [<c00ac058>] (handle_irq_event_percpu+0xc4/0x298) from [<c00ac278>] (handle_irq_event+0x4c/0x6c)
[ 427.277648] [<c00ac278>] (handle_irq_event+0x4c/0x6c) from [<c00aeefc>] (handle_fasteoi_irq+0xd8/0x110)
[ 427.277648] [<c00aeefc>] (handle_fasteoi_irq+0xd8/0x110) from [<c00ab9c0>] (generic_handle_irq+0x30/0x40)
[ 427.277679] [<c00ab9c0>] (generic_handle_irq+0x30/0x40) from [<c000ec84>] (handle_IRQ+0x88/0xc8)
[ 427.277709] [<c000ec84>] (handle_IRQ+0x88/0xc8) from [<c0008638>] (asm_do_IRQ+0x18/0x1c)
[ 427.277740] [<c0008638>] (asm_do_IRQ+0x18/0x1c) from [<c05fa574>] (__irq_usr+0x34/0xa0)
[ 427.277740] Exception stack(0xecae9fb0 to 0xecae9ff8)
[ 427.277770] 9fa0: b281e9a0 00000000 00000010 00000000
[ 427.277770] 9fc0: b281e9a0 b281e9a0 00000002 b6ccb761 b281e9d0 026011b0 00000000 b6cdf544
[ 427.277801] 9fe0: b6ca400c beadcea0 b6cc9ad5 b6ccb560 400f0130 ffffffff
[ 427.277801] ---[ end trace da227214a82491c2 ]---
[ 427.277832] DMA transaction error with device 101

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-omap4 3.2.0.1405.5
ProcVersionSignature: User Name 3.2.0-1405.7-omap4 3.2.1
Uname: Linux 3.2.0-1405-omap4 armv7l
ApportVersion: 1.91-0ubuntu1
Architecture: armel
Date: Tue Jan 31 18:24:33 2012
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: linux-meta-ti-omap4
UpgradeStatus: No upgrade log present (probably fresh install)

Tobin Davis (gruemaster) wrote :
tags: added: bot-stop-nagging
Tobin Davis (gruemaster) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux-ti-omap4 (Ubuntu):
status: New → Confirmed
Sebastien JAN (sebjan) wrote :

That maybe linked to a bug we had in this audio driver branch (the same audio branch was used for Linaro kernel branches tilt-3.1 and tilt-3.2).
The 2 patches (here applied on our 3.1 based kernel) fixing the remaining audio issues are the following:
http://dev.omapzoom.org/?p=integration/kernel-ubuntu.git;a=commitdiff;h=6606b5441992564bb69ac4c7a850643bd6e13bab
http://dev.omapzoom.org/?p=integration/kernel-ubuntu.git;a=commitdiff;h=8b5836d9539d23c4876a68e155a967a0b8a98c7e

These patches shall be applied on current 3.2 based Precise kernel (ti-omap4 branch).

Patrick Buckley (buckleypm) wrote :

After applying those two patches to 3.2.0-1405.7 source and installing the resulting kernel I am seeing no change in behavior from the original bug.

Patrick Buckley (buckleypm) wrote :

pbuckley@panda:/usr/src$ alsaucm set _verb HiFi
Im setting defaults
ALSA lib main.c:270:(execute_sequence) unable to open ctl device 'hw:Panda'
ALSA lib main.c:1460:(set_verb_user) error: failed to initialize new use case: HiFi
alsaucm: error failed to set _verb=HiFi: No such device

Sebastien JAN (sebjan) wrote :

These errors are not expected.

On what HW are you testing? PandaES?

To check, run:
cat /proc/asound/cards

If testing on Panda, please run:
alsaucm -c Panda set _verb HiFi

If testing on PandaES, I believe the UCM files for PandaES are not delivered yet (they shall be in /usr/share/alsa/ucm/PandaES). You can set the mixers manually running the following commands (that will also set the record path btw):

amixer cset name='DL1 Mixer Multimedia' 1
amixer cset name='Sidetone Mixer Playback' 1
amixer cset name='DL1 PDM Switch' 1
amixer cset name='DL1 Media Playback Volume' 90,90
amixer cset name='SDT DL Volume' 120

amixer cset name='MUX_UL00' 11
amixer cset name='MUX_UL01' 12

amixer cset name='Headset Left Playback' 1
amixer cset name='Headset Right Playback' 1
amixer cset name='Headset Playback Volume' 13

amixer cset name='Analog Left Capture Route' 2
amixer cset name='Analog Right Capture Route' 2
amixer cset name='Capture Preamplifier Volume' 2
amixer cset name='Capture Volume' 4

Tobin Davis (gruemaster) wrote :

Actually, the problem with the ucm config files is that the control names have changed (yet again). Need to edit /usr/share/alsa/ucm/Panda/* and change "HS" to "Headset", run "alsaucm set _verb HiFi" and reboot. I got it working here and Patrick verified on his.

So this bug has two issues; The kernel patches are needed, and the ucm config files need updating.

Tobin Davis (gruemaster) wrote :

This is fixed in the Ubuntu Desktop beta 1 release.

Changed in linux-ti-omap4 (Ubuntu):
status: Confirmed → Fix Released
milestone: none → ubuntu-12.04-beta-1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers