excessive messaging in dmesg by kernel on omap4

Bug #855969 reported by Tobin Davis on 2011-09-21
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux-ti-omap4 (Ubuntu)
Undecided
vishal upadhye
Oneiric
Undecided
Unassigned
pulseaudio (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned

Bug Description

SRU Justification:

Impact: repetitive log messages spam the console

How to reproduce: boot the board and watch the console being spammed every
2secs by these messages:

[ 2435.003417] ieee80211 phy0: device no longer idle - scanning
[ 2436.672180] ieee80211 phy0: device now idle
...

Fix: for the wifi part, turn off CONFIG_MAC80211_VERBOSE_DEBUG

=====

Wifi driver appears to leave a:message every time it wakes up and then sleeps:

[ 2435.003417] ieee80211 phy0: device no longer idle - scanning
[ 2436.672180] ieee80211 phy0: device now idle

Appears every few seconds.

Also, sound configuration is leaving a lot of error messages as well:
[ 542.305511] SDP4430 Media: asoc: SDP4430 Media no valid playback route from source to sink
[ 542.305511] omap-abe-dai omap-abe-dai: omap_abe_dai_startup: MultiMedia1
[ 542.306213] omap-abe-dai omap-abe-dai: omap_abe_dai_hw_params: MultiMedia1
[ 542.306365] omap-abe-dai omap-abe-dai: omap_abe_dai_hw_free: MultiMedia1
[ 542.306365] omap-abe-dai omap-abe-dai: omap_abe_dai_hw_params: MultiMedia1
[ 542.306488] omap-abe-dai omap-abe-dai: omap_abe_dai_hw_free: MultiMedia1
[ 542.306579] omap-abe-dai omap-abe-dai: omap_abe_dai_hw_params: MultiMedia1
[ 542.306701] omap-abe-dai omap-abe-dai: omap_abe_dai_hw_free: MultiMedia1
[ 542.306762] omap-abe-dai omap-abe-dai: omap_abe_dai_hw_params: MultiMedia1
[ 542.306854] omap-abe-dai omap-abe-dai: omap_abe_dai_hw_free: MultiMedia1
[ 542.306976] omap-abe-dai omap-abe-dai: omap_abe_dai_hw_params: MultiMedia1
[ 542.307067] omap-abe-dai omap-abe-dai: omap_abe_dai_hw_free: MultiMedia1
[ 542.307250] omap-abe-dai omap-abe-dai: omap_abe_dai_hw_free: MultiMedia1
[ 542.307250] omap-abe-dai omap-abe-dai: omap_abe_dai_shutdown: MultiMedia1

See attached logs for more details.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: linux-image-3.0.0-1204-omap4 3.0.0-1204.9
ProcVersionSignature: User Name 3.0.0-1204.9-omap4 3.0.3
Uname: Linux 3.0.0-1204-omap4 armv7l
ApportVersion: 1.23-0ubuntu1
Architecture: armel
Date: Wed Sep 21 15:37:33 2011
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: linux-ti-omap4
UpgradeStatus: No upgrade log present (probably fresh install)

Tobin Davis (gruemaster) wrote :
Tobin Davis (gruemaster) wrote :
tags: added: iso-testing
Paolo Pisati (p-pisati) wrote :

the wifi debugging can be turned off commenting:

CONFIG_MAC80211_VERBOSE_DEBUG

while the audio part seems a pulseaudio problem.

Paolo Pisati (p-pisati) on 2011-09-27
description: updated
Paolo Pisati (p-pisati) wrote :
description: updated

The attachment "0001-UBUNTU-Config-Quiet-ieee80211-debugging.patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Tim Gardner (timg-tpi) wrote :

Start a new bug against pulseaudio for log noise caused by that package.

Changed in linux-ti-omap4 (Ubuntu Oneiric):
status: New → Fix Committed
Changed in pulseaudio (Ubuntu Oneiric):
status: New → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-ti-omap4 - 3.0.0-1205.10

---------------
linux-ti-omap4 (3.0.0-1205.10) oneiric; urgency=low

  [ Paolo Pisati ]

  * [Config] Quiet ieee80211 debugging
    - LP: #855969
  * Rebased against Ubuntu-3.0.0-12.19
  * TI BSP update: kernel-tilt/tilt-3.0-nodspvideo1 @ d2fe6284bb37abd542524b17f17cf9208db767c2

  [ Upstream Kernel Changes ]

  * Revert "Staging: OMAPDRM: Changing driver's name to be compatible with
    userspace"
  * Revert "DRM: OMAP: Fixing PVR kernel module name"
  * KBuild: Allow scripts/* to be cross compiled
  * LINARO: Use KBUILD_SCRIPTROOT to cross build scripts
 -- Paolo Pisati <email address hidden> Tue, 27 Sep 2011 17:52:08 +0200

Changed in linux-ti-omap4 (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Changed in linux-ti-omap4 (Ubuntu):
assignee: nobody → vishal upadhye (upadhye-vishalk)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers