[maverick] panda omap4 does not suspend

Bug #628029 reported by Oliver Grawert on 2010-09-01
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Oliver Grawert
linux-ti-omap4 (Ubuntu)
High
Lee Jones
Maverick
High
Lee Jones

Bug Description

clicking the suspend menu item in the panel does only result in a locked screen. there seem to be no traces of what failed in any logs, only the screensaver unlock dialog coming up is mentioned directly after the boot messages

Oliver Grawert (ogra) wrote :

this might not be a kernel bug, researching pm-utils is required

Changed in linux-ti-omap4 (Ubuntu Maverick):
importance: Undecided → High
milestone: none → ubuntu-10.10
tags: added: armel
Changed in linux-ti-omap4 (Ubuntu Maverick):
status: New → Incomplete
tags: added: iso-testing
Lee Jones (lag) wrote :

This one shouldn't be too difficult to fix.

It appears that the config option isn't set:

debian.ti-omap4/config/config.common.ubuntu:# CONFIG_PM is not set

Changed in linux-ti-omap4 (Ubuntu Maverick):
status: Incomplete → Confirmed
assignee: nobody → Lee Jones (lag)
Bryan Wu (cooloney) wrote :

Yeah, I agree. How about setting this issue as 'Won't fix"?

Oliver Grawert (ogra) wrote :

well, we'd like to be able to suspend so we'd like to have this fixed ;)

Lee Jones (lag) wrote :

Even better, why don't we just fix it?

I'll do it on Monday.

Am Mittwoch, den 08.09.2010, 23:08 +0000 schrieb Lee Jones:
> Even better, why don't we just fix it?
>
> I'll do it on Monday.
>
because the hardware is not ready for it yet as far as i understand

ciao
 oli

Changed in linux-ti-omap4 (Ubuntu Maverick):
milestone: ubuntu-10.10 → maverick-updates
tags: added: omap4 panda
Oliver Grawert (ogra) on 2010-09-23
summary: - [maverick] panda ES1.0 does not suspend on beta image
+ [maverick] panda omap4 does not suspend
Changed in ubuntu-release-notes:
assignee: nobody → Oliver Grawert (ogra)
Oliver Grawert (ogra) wrote :

Release Note:

"Due to current hardware limitations (Bug: 628029) it is not possible to use suspend on the Ubuntu ARM images for pandaboards (OMAP4) even though the suspend option is shown in the logout menu."

Changed in ubuntu-release-notes:
status: New → Fix Committed
Lee Jones (lag) wrote :

Oliver,

Does this mean I can put my part of the bug to sleep also?

Lee Jones (lag) wrote :

This functionality is not provided yet, but it will be in the future.

Therefore it's not a bug - closing.

Changed in linux-ti-omap4 (Ubuntu Maverick):
status: Confirmed → Invalid
Changed in ubuntu-release-notes:
status: Fix Committed → Fix Released
AmiG (ami-geva) wrote :

Don't know if this is related but not being able to suspend is not restricted to panda. Check #604252 (https://bugs.launchpad.net/ubuntu/+source/linux/+bug/604252) and see that lots of other hardwares cannot suspend with 10.10 Maverick

Lee Jones (lag) wrote :

It's not related.

There are many unrelated Suspend/Resume issues with all flavours of Linux.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers