Boot stalls after Ubuntu Raring desktop ARM (Panda board) install

Bug #1161981 reported by Carla Sella on 2013-03-29
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux-ti-omap4 (Ubuntu)
Medium
Unassigned
xorg-server (Ubuntu)
High
Maarten Lankhorst

Bug Description

I have installed this image: http://cdimage.ubuntu.com/daily-live/20130328/raring-desktop-armhf+omap4.img twice, doing an entire disk install. I selected Italian language, left Rome timezone and Italian keyboard as suggested by Ubiquity (standard entire disk install over Wireless network) but when I reboot after the installation ends boot stalls.
I am attaching two screenshots, the boot process stalls after "CPU interrupts balancing daemon".

Related branches

Carla Sella (carla-sella) wrote :
Carla Sella (carla-sella) wrote :

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1161981

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: raring
summary: - Boot stalls after entire disk install on Raring ARM (Panda board)
+ Boot stalls after entire disk install on Ubuntu Raring desktop ARM
+ (Panda board)
Changed in linux (Ubuntu):
importance: Undecided → Medium
affects: linux (Ubuntu) → linux-ti-omap4 (Ubuntu)

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1161981

tags: added: iso-testing
Carla Sella (carla-sella) wrote :

@ Brad:
Could not do anything, the keyboard did not work after reboot so I was unable to go to terminal for adding log files.

summary: - Boot stalls after entire disk install on Ubuntu Raring desktop ARM
- (Panda board)
+ Boot stalls after Ubuntu Raring desktop ARM (Panda board) install
Carla Sella (carla-sella) wrote :

I now tried installing the same image but instead of selecting an entire disk install I selected manual partitioning.
Booting stalled on the same place.
Unfortunatly I cannot use the keyboard so I cannot attach logs.
If there is another way to do it please let me know.
Ssh port is not open so I cannot ssh onto the machine.

Carla Sella (carla-sella) wrote :

Same happened with image: http://cdimage.ubuntu.com/daily-live/20130402.1/raring-desktop-armhf+omap4.img.
I am attaching some files from the /var/log directory un the USB key on wich I installed.

Carla Sella (carla-sella) wrote :
Changed in linux-ti-omap4 (Ubuntu):
status: Incomplete → Confirmed
Carla Sella (carla-sella) wrote :
Carla Sella (carla-sella) wrote :
Carla Sella (carla-sella) wrote :
Carla Sella (carla-sella) wrote :
Carla Sella (carla-sella) wrote :
Carla Sella (carla-sella) wrote :
Carla Sella (carla-sella) wrote :
Carla Sella (carla-sella) wrote :
Carla Sella (carla-sella) wrote :
Carla Sella (carla-sella) wrote :
Paul Larson (pwlars) wrote :

I can confirm this as well with a netboot install of ubuntu-desktop on panda. I'm seeing it stop at the exact same place, except that mine is also trying to check the drive for errors now since I pulled the power on it. After waiting long enough for the screen to blank, I'm also seeing the message:
omapdss DPI error: failed to enable display: no manager

I'm connected via hdmi, to the hdmi port on a tv. I've also tried the dvi-d plug with no success.

Dimitri John Ledkov (xnox) wrote :

<ogra_>21 xnox, ogra@chromebook:~/xf86-video-omap-0.4.0$ grep 24 src/*
<ogra_> src/omap_driver.c: default_depth = 24; /* TODO: get from kernel */

Changing that to 32, recompiling, in-place replacing allows me to boot and be presented with the "you are running in a low graphics mode" and allows me to attempt reconfiguring my X11.

But ubiquity-dm did manage to boot fine to do the install...

Ricardo Salveti (rsalveti) wrote :

The problem here is that the BUSID support for platform devices got broken after patch drm_device_keep_trying.patch was added to xorg-server (bug 982889).

As the BUSID is empty when initializing the omap x11 driver, it fails and move back to the old probing method, which allows more than one driver to be up at the same time (fixed previously by bug 1015292).

Changed in xf86-video-omap (Ubuntu):
status: New → Confirmed
affects: xf86-video-omap (Ubuntu) → xorg-server (Ubuntu)
Changed in xorg-server (Ubuntu):
importance: Undecided → High
assignee: nobody → Maarten Lankhorst (mlankhorst)
Ricardo Salveti (rsalveti) wrote :

Expected values at panda:
syspath: /sys/devices/platform/omapdrm/drm/card0
busid: platform:omapdrm:0

Ricardo Salveti (rsalveti) wrote :

I can confirm it works fine again after removing drm_device_keep_trying.patch.

Maarten Lankhorst (mlankhorst) wrote :

Does this patch fix things?

Maarten Lankhorst (mlankhorst) wrote :

I tested it on my main system by stuffing the logic in a separate function..

tags: added: patch
Maarten Lankhorst (mlankhorst) wrote :

Some notes on the final patch (not attached here, but in ubuntu5 upload):
- tested on panda, confirmed to work
- tested on a normal (hybrid) laptop, previous versions had a bug which triggered ssp due to an incorrect offset, confirmed to work with the incorrect offset removed.
- tegra, was found to work by marvin24 in #ubuntu-x, using the set_drm_info fallback path.
- usb (udl) completely untested, I did an educated guess based on the kernel source. usb drivers do not have a busid, cf linux/drivers/gpu/drm/drm_usb.c drm_usb_set_busid, so busid is set to an empty string, rather than null. Looking at drmGetBusid in libdrm/xf86drm.c this would be the expected return value. xxv-modesetting works with path, rather than busid, so it would still work correctly.

Changed in linux-ti-omap4 (Ubuntu):
status: Confirmed → Invalid
Changed in xorg-server (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xorg-server - 2:1.13.3-0ubuntu5

---------------
xorg-server (2:1.13.3-0ubuntu5) raring; urgency=low

  [ Bryce Harrington ]
  * Add no-nv.patch: Don't autoprobe -nv on linux.
  * Refresh drm_device_keep_trying.patch (LP: #1161981)
    - Set empty busid for usb devices
    - Parse pci path more strictly.
    - Make platform devices work correctly, try to obtain busid from
      path if possible.
    - Fallback if not possible (tegra).
 -- Maarten Lankhorst <email address hidden> Mon, 08 Apr 2013 11:40:26 +0200

Changed in xorg-server (Ubuntu):
status: In Progress → Fix Released
Carla Sella (carla-sella) wrote :

I tried image: http://cdimage.ubuntu.com/daily-live/20130409/raring-desktop-armhf+omap4.img and the bug is gone, everything's fine now.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers