USB and Ethernet are broken on the Beagle XM

Bug #608095 reported by Lee Jones on 2010-07-21
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux-ti-omap (Ubuntu)
Critical
Lee Jones

Bug Description

When any device is plugged into the Beagleboard XM, it is ignored.

Ethernet does not work and no device is displayed in ifconfig.

Lee Jones (lag) on 2010-07-21
Changed in linux-ti-omap (Ubuntu):
assignee: nobody → Lee Jones (lag)
status: New → In Progress
importance: Undecided → High
importance: High → Critical
Lee Jones (lag) wrote :

This issue is fixed.

I'm just waiting for the patches to be applied to our kernel.

The patches are also being sent upstream by a third party.

Changed in linux-ti-omap (Ubuntu):
status: In Progress → Fix Committed
Ricardo Salveti (rsalveti) wrote :
Changed in linux-ti-omap (Ubuntu):
status: Fix Committed → Fix Released
Lee Jones (lag) wrote :

> This is released already.

Normally bugs are moved from "Fix Committed" -> "Fixed Released" by the Launchpad Janitor. This is a bit of an odd case whereby the bug report was raised after the patches were sent for review. As there was no bug report open, the "BugLink: http://bugs.launchpad.net/bugs/<bug#>" was omitted from the commit message.

> Lee, it would also help if you could point the address of the
> patches, or saying where they were sent (with the hash), this
> can help tracking the issue. Just saying the issue is fixed
> means nothing from the test perspective.

There is no more testing to be completed. I sent out the test kernels prior to releasing the patches, which were subsequently tested thoroughly by the individuals I selected. All patches due to be applied to our kernel are invariably sent to the same place, the Kernel Team mailing list. If you're not subscribed already, it might be a good idea for future scenarios similar to this one. It is most uncommon and peculiar to provide URLs to patches within bug reports.

In future, if you'd like more information regarding submitted patches, I would suggest that you check the Kernel Team mailing list. If that failed for any reason you are always free to ask me in person. My email address can be found on my Launchpad page and I am on IRC all day (UTC) Monday->Friday.

Ricardo Salveti (rsalveti) wrote :

I understand that it's easier just to follow the kernel mailing list to find out what the patches are and track if they are merged or not (what I did), but my concern was more how could an external person (not from ubuntu kernel team) could find and test/grab the fixes?

Happens a lot that people searches about the problem at google, and then it points bugs at launchpad with a similar problem. In this case it'd be hard to find the fixes, as the person would need to dig it at the kernel mailing list and/or the ubuntu kernel tree.

Another missing information for me is regarding the upstream submission. You say that they were been sent by a third party, but no more than that. Giving more info about it would for sure help, like who, what was the target mailing list (lkml, linux-omap) or even a link.

Lee Jones (lag) wrote :

The Kernel Team mailing list is open to the public. If anyone is interested in our patches/fixes/misc kernel ramblings, they are more than welcome to sign up. The mailing list is also Googleable: http://tinyurl.com/2vh6thw. I believe the first link are our ramblings and the second is relevant to this bug. Here is a link to my first post: http://tinyurl.com/usb-beagle, which is also relevant and Googleable.

The guy who was going to upstream them is Steve Sakoman. I have no idea if he's done so yet, or where he would attempt to upstream them to, but he's easily contactable via IRC as sakoman if you care to ask. :)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.