console colormap is wrong when using 32bit framebuffer

Bug #588638 reported by Zygmunt Krynicki on 2010-06-02
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Linaro Ubuntu
Low
John Rigby
linux-linaro-omap (Ubuntu)
Undecided
Unassigned
linux-ti-omap (Ubuntu)
Medium
Bryan Wu

Bug Description

My kernel cmdline has the following fb setting: omapfb.mode=dvi:1280x720MR-32@60. Reverting to MR-16@60 fixes this (but looks worse in X due to 16bit color)

This setting works in X (all is fine) but in the console colors are wrong, see the attached photo for details.

Zygmunt Krynicki (zyga) wrote :
Zygmunt Krynicki (zyga) on 2010-06-02
tags: added: armel
Robert Nelson (robertcnelson) wrote :

Off hand, i don't remember if this is a limitation of the Omap3, but the blue terminal background has always existed with dss2 since the 2.6.28ish days for me. (Most people run 16bit mode for faster drawing, it takes more bandwidth for 32bit mode)

Give 24 bit mode a try: omapfb.mode=dvi:1280x720MR-24@60

Bryan Wu (cooloney) wrote :

Zygmunt,

Is there any update about this issue?

-Bryan

Changed in linux-ti-omap (Ubuntu):
importance: Undecided → Medium
status: New → Incomplete
assignee: nobody → Bryan Wu (cooloney)
Zygmunt Krynicki (zyga) wrote :

AFAIR 24bit mode worked correctly.

I didn't test this for some time as I'm running headless but if you want I can have a look early next week (absent tomorrow, sorry)

tags: added: omap3
Lee Jones (lag) wrote :

Are there any more updates on this issue?

Steve Langasek (vorlon) wrote :

duplicate filed 2010-11-25 reports the same issue; marking as confirmed again.

Changed in linux-ti-omap (Ubuntu):
status: Incomplete → Confirmed
John Rigby (jcrigby) wrote :

Now that we have graphics with omap4 we have blue text just like the ubuntu ti-omap4 kernel.

Changed in linux-linaro-omap (Ubuntu):
status: New → Confirmed
Marcin Juszkiewicz (hrw) wrote :

with linux-image-2.6.38-1003-linaro-omap_2.6.38-1003.4~ppa2_armel.deb kernel I have proper colours on framebuffer

Ricardo Salveti (rsalveti) wrote :

With linux-image-3.0.0-1401-linaro-lt-omap 3.0.0-1401.2~natty the console is bluish again.

Changed in linaro-ubuntu:
assignee: nobody → John Rigby (jcrigby)
importance: Undecided → Low
status: New → Confirmed
Changed in linaro-ubuntu:
milestone: none → 11.07
Changed in linaro-ubuntu:
milestone: 11.07 → 11.08
Ricardo Salveti (rsalveti) wrote :

Still an issue with linux-image-3.0.0-1402-linaro-lt-omap 3.0.0-1402.3~ppa~natty.

Ricardo Salveti (rsalveti) wrote :

But can also confirm that this is not an issue when using the DVI driver with the same kernel posted at #10.

Changed in linaro-ubuntu:
milestone: 11.08 → 11.09
warmcat (andy-warmcat) wrote :

This is solved as far as my colour-blind eyes can tell on today's tilt-linux-linaro-3.0 on both HDMI and DVI.

Paolo Pisati (p-pisati) wrote :

flag@omap:~$ uname -a
Linux omap 3.0.0-1203-omap4 #8 SMP PREEMPT Sun Aug 28 14:26:24 CEST 2011 armv7l armv7l armv7l GNU/Linux
flag@omap:~$ cat /proc/cmdline
console=ttyO2,115200n8 root=/dev/sda1 rootwait ro vram=32 elevator=noop earlyprintk

and i still have a blue-text console.

warmcat (andy-warmcat) wrote :

Paolo it's solved on yesterday's (Aug 31) tilt-linux-linaro-3.0... your package seems to have come from several days before?

Paolo Pisati (p-pisati) wrote :

yep, actually i looked at your tree but since the tilt-3.0 brnahc didn't have any update i thought we were in sync...

warmcat (andy-warmcat) wrote :

tilt-3,0 is staying pretty much where it is, it's working with the current arrangements for Android branch.

tilt-3.0-nodspvideo1 is getting new work from TI for various things and is used to generate tilt-linux-linaro-3.0 now.

If you just want the vanilla branch the tilt-3.0-nodspvideo1 is the best idea at the moment.

Paolo Pisati (p-pisati) wrote :

uhm... i still get a blue background:

1) what's your /proc/cmdline?
2) what's your kernel config? omap4_defconfig?

Paolo Pisati (p-pisati) wrote :

flag@omap:~$ uname -a
Linux omap 3.0.0-1204-omap4 #9-Ubuntu SMP PREEMPT Mon Sep 5 19:29:18 UTC 2011 armv7l armv7l armv7l GNU/Linux

flag@omap:~$ cat /proc/cmdline
console=ttyO2,115200n8 root=/dev/sda1 rootwait ro vram=12MB omapfb.mode=dvi:1280x720MR-32@60

everything is fine here

Changed in linux-ti-omap (Ubuntu):
status: Confirmed → Fix Released
Changed in linaro-ubuntu:
status: Confirmed → Fix Released
Chase Qi (chase-qi) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.