OTG configuration is broken on omap kernel

Bug #566645 reported by Oliver Grawert on 2010-04-19
30
This bug affects 4 people
Affects Status Importance Assigned to Milestone
linux-ti-omap (Ubuntu)
High
Bryan Wu
Lucid
High
Bryan Wu
Maverick
High
Bryan Wu

Bug Description

after first boot after doing a netinstall to SD card (with powered hub, keyboard and asix USB->ETH adapter attached to the board) the kernel spills an OOPS message on first boot, apparently related to OTG.

Oliver Grawert (ogra) wrote :
tags: added: armel
Oliver Grawert (ogra) on 2010-04-20
Changed in linux-ti-omap (Ubuntu):
assignee: nobody → Amit Kucheria (amitk)
importance: Undecided → High
Changed in linux-ti-omap (Ubuntu Lucid):
milestone: none → lucid-updates
Amit Kucheria (amitk) on 2010-04-23
Changed in linux-ti-omap (Ubuntu Lucid):
status: New → Confirmed
Amit Kucheria (amitk) on 2010-05-25
Changed in linux-ti-omap (Ubuntu Lucid):
assignee: Amit Kucheria (amitk) → Mathieu Poirier (mathieu.poirier)
Changed in linux-ti-omap (Ubuntu):
assignee: Amit Kucheria (amitk) → Mathieu Poirier (mathieu.poirier)
Oliver Grawert (ogra) on 2010-05-27
Changed in linux-ti-omap (Ubuntu Lucid):
status: Confirmed → Won't Fix
Changed in linux-ti-omap (Ubuntu Maverick):
milestone: lucid-updates → none
Amit Kucheria (amitk) wrote :

We should try to fix this for Lucid if possible. We were just not able to get the right config working in time for Lucid.

Changed in linux-ti-omap (Ubuntu Lucid):
status: Won't Fix → Confirmed
summary: - doing a netinstall to SD card results in OTG related oops on first boot
+ OTG configuration is broken on omap kernel
Bryan Wu (cooloney) wrote :

From the dmesg.txt from Oliver, I think we missed compile in the OTG transceiver driver into the kernel. So I prepared a kernel including that:
http://kernel.ubuntu.com/git?p=roc/ubuntu-lucid.git;a=shortlog;h=refs/heads/lp566645_otg

And the kernel package here:
http://people.canonical.com/~roc/kernel/lp566645_otg/

Please help me to test that.
Thanks,
-Bryan

Bryan,

To get the OTG port in host mode one needs to ground the ID pin,
something that requires a soldering iron. Unless I find a way to do it
without the modification it will take me a couple of days to test your
image.

I will also get in touch with Oliver - after all he reported the problem
so I assume his board already has OTG enabled.

Cheers, Mathieu.

On Tue, 2010-06-15 at 10:35 +0000, Bryan Wu wrote:
> >From the dmesg.txt from Oliver, I think we missed compile in the OTG transceiver driver into the kernel. So I prepared a kernel including that:
> http://kernel.ubuntu.com/git?p=roc/ubuntu-lucid.git;a=shortlog;h=refs/heads/lp566645_otg
>
> And the kernel package here:
> http://people.canonical.com/~roc/kernel/lp566645_otg/
>
> Please help me to test that.
> Thanks,
> -Bryan
>

Tobin Davis (gruemaster) wrote :

A simple way to do this is to use a USB Mini A cable. USB Mini B cables are the more common type found, usually with cell phones and mp3 players. The Mini A cable will have a mini plug on one end and a USB Host plug for plugging in a keyboard or other device. See http://www.electronicproductonline.com/catalog/product_info.php?products_id=2043

Bryan Wu (cooloney) wrote :

Mathieu,

As Tobin said, you can just buy a USB OTG cable which provide Mini A and Mini B connectors. And insert the Mini A to the Beagle board OTG Mini AB port. When kernel boots, the USB OTG will be set as host. The Mini A connector contains such ID pin connection.

I will find my USB OTG cable provider and tell you later.
-Bryan

Ricardo Salveti (rsalveti) wrote :

I also got this issue with Lucid 2.6.33-502-omap, but this is not something that you can reproduce on every boot, as some times it does works correctly.

Still going to try with latest Maverick and upstream kernel to see if it's already fixed.

Ricardo Salveti (rsalveti) wrote :

For Maverick's kernel the OTG doesn't even work as Lucid's kernel.

Before plugging in the cable:
root@ubuntu-desktop:~# cat /sys/devices/platform/musb_hdrc/mode
b_idle

After plugging the cable:
root@ubuntu-desktop:~# cat /sys/devices/platform/musb_hdrc/mode
a_idle

echo host > /sys/devices/platform/musb_hdrc/mode also doesn't make any difference.

I'm now trying upstream kernel to see if works.

Ricardo Salveti (rsalveti) wrote :

With Maverick it does work if I compile the kernel with the following config file:
 * http://bazaar.launchpad.net/~beagleboard-kernel/+junk/2.6.35-devel/annotate/head:/patches/defconfig

It's quite different from Maverick's one, so still need to compare most of the changes related with usb and see what we should change to have the OTG behavior working again.

Brian, you can easily build and test with your board, to see how it should behave.

Bryan Wu (cooloney) on 2010-07-21
Changed in linux-ti-omap (Ubuntu Lucid):
assignee: Mathieu Poirier (mathieu.poirier) → Bryan Wu (cooloney)
Changed in linux-ti-omap (Ubuntu Maverick):
assignee: Mathieu Poirier (mathieu.poirier) → Bryan Wu (cooloney)
Ricardo Salveti (rsalveti) wrote :

For Maverick I opened bug 608312, because the basic functionality is not working yet.

Bryan Wu (cooloney) wrote :

When we built-in twl4030_usb module, this OOPS will be gone.

Please find the patches here:
http://kernel.ubuntu.com/git?p=roc/ubuntu-lucid.git;a=commitdiff;h=fc58ea3748869d2fa811dff26aa0fa07490b22b2

And kernel package here:
http://people.canonical.com/~roc/kernel/lp566645_otg/

These are for lucid, Maverick version will come soon

Thanks

Changed in linux-ti-omap (Ubuntu Lucid):
status: Confirmed → In Progress
Changed in linux-ti-omap (Ubuntu Maverick):
status: Confirmed → In Progress
Ricardo Salveti (rsalveti) wrote :

Tobin, can you please test this kernel and see if this bug is actually gone? Also make sure that the OTG works as expected.

Thanks in advance.

Bryan Wu (cooloney) wrote :

Please find the Maverick kernel here:
http://people.canonical.com/~roc/kernel/lp566645_otg/

I tested it on Gumstix board as well as Beagle board, it works.

Git patches:
http://kernel.ubuntu.com/git?p=roc/ubuntu-maverick.git;a=shortlog;h=refs/heads/otg

Changed in linux-ti-omap (Ubuntu Maverick):
status: In Progress → Fix Committed

This should be Fixed in Maverick with the recent 2.6.35-16.22 kernel. This still appears to be open and under consideration for Lucid.

Changed in linux-ti-omap (Ubuntu Maverick):
status: Fix Committed → Fix Released
Ricardo Salveti (rsalveti) wrote :

Tobin, any chance to test the possible fixes?

tags: added: verification-needed
Tobin Davis (gruemaster) wrote :

Tested in Maverick. No more errors. Also tested in Lucid. No errors.

Changed in linux-ti-omap (Ubuntu Lucid):
status: In Progress → Fix Released
tags: added: verification-done
removed: verification-needed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments