Ubuntu

rtl8187 module has no ad-hoc support

Reported by Casandro on 2007-03-28
78
This bug affects 12 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
linux-source-2.6.22 (Ubuntu)
Undecided
Unassigned

Bug Description

The rt8187 module doesn't seem to support ad-hoc mode.

root@hp:~# iwconfig wlan0 essid "haidhaeuser.freifunk.net" mode ad-hoc channel 1 commit
Error for wireless request "Set Mode" (8B06) :
    SET failed on device wlan0 ; Device or resource busy.

I'm using 7.04 in the newest version.

it hasn't monitor (promiscuous) mode support either. In edgy monitor mode worked.

Alan Jenkins (aj504) wrote :

I believe you may have to shut down (ifconfig down) the interface before you can switch modes, which is why you get the "busy" message. I have (apparently) the same hardware, I think I have to do this and I've seen it elsewhere.

Although In the case of ad-hoc mode, I then get a "Operation not permitted" when I try to bring the interface back up again.

But then the native rtl8187 driver doesn't pick up the AP on my hardware at all, where Windows does, so somethings very wrong with my setup.

Thank you for taking the time to report this bug and helping to make Ubuntu better. Now that the 7.10 Gutsy Gibbon release of Ubuntu is out, we were wondering if you can still reproduce this issue. Could you please download and try the new version of Ubuntu from http://www.ubuntu.com/getubuntu/download and report back your results. If the issue is still present in the new release, please attach the following information:

* uname -a > uname-a.log
* cat /proc/version_signature > version.log
* dmesg > dmesg.log
* sudo lspci -vvnn > lspci-vvnn.log

Please be sure to attach each file as a separate attachment. For more information regarding the kernel team bug policy, please refer to https://wiki.ubuntu.com/KernelTeamBugPolicies . Thanks again and we appreciate your help and feedback.

Changed in linux-source-2.6.20:
status: New → Incomplete
wolfger (wolfger) wrote :

5 months with no reply. We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in linux-source-2.6.20:
status: Incomplete → Invalid
rihasant (riku.hs) wrote :

This problem still exists, so I'm going to reopen it. Hopefully someone has time to fix it. I'll provide more information if needed.

Changed in linux-source-2.6.20:
status: Invalid → New
rihasant (riku.hs) wrote :
rihasant (riku.hs) wrote :
rihasant (riku.hs) wrote :
wolfger (wolfger) on 2008-04-26
Changed in linux-source-2.6.22:
status: New → Confirmed

Hi Guys,

The 8.04 Hardy Heron release of Ubuntu is out currently. Could you please test with this latest release and verify if you can still reproduce this issue. You can download and try the new version of Ubuntu from http://www.ubuntu.com/getubuntu/download. Please report back your results. We'll keep this open against the actively developed kernel but against 2.6.22 this will be closed as it does not qualify for a Stable Release Update - https://wiki.ubuntu.com/StableReleaseUpdates. Thanks.

Changed in linux:
status: New → Incomplete
Changed in linux-source-2.6.22:
status: Confirmed → Won't Fix

Hi everybody,

I have the same problem on 8.04 Hardy Heron.
My card is a Asus wifi-ap solo on P5W DH Deluxe which uses rtl8187, and I get the "Operation not permitted" messages when I try to set it on ad-hoc mode.

wolfger (wolfger) on 2008-08-17
Changed in linux:
status: Incomplete → Confirmed

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

okias (d-okias) wrote :

In Kubuntu 8.10 and 9.04 bug still remaining. No ad-hoc mode is avaliable.

HW: Toshiba Satelite a210-15j.
Bus 002 Device 003: ID 0bda:8197 Realtek Semiconductor Corp. RTL8187B Wireless Adapter

Christoffer Lilja (c-hellbom) wrote :

I use a Toshiba Equium A200-1V0 PSAF5V, I can't also not anable Ad-Hoc mode.
It would be plesant to be able to...

I use Ubuntu 9.04 kernel 2.6.28

Style the same result with Ubuntu Karmic 2.6.31-11-generic.

koba (claudio-s-martinez) wrote :

Ad-Hoc is still not working on Karmic RC.

Bus 001 Device 003: ID 0bda:8187 Realtek Semiconductor Corp. RTL8187 Wireless Adapter

It didn't work on Jaunty either. The difference is that on Jaunty I could use these http://www.aircrack-ng.org/doku.php?id=r8187 drivers to make it work. The new kernel on Karmic dropped some old network driver support so this driver cannot be used anymore.

Ivan Jekic (the-edge) wrote :

It doesn't work for me either. I have Realtek rtl8185, driver rtl8185, Karmic, newest kernel 2.6.31-16-generic.

Daniel Sandman (almehdi) wrote :

I am using P5W DH Delux motherboard with the RTL8187 and still i am not able to use ad-hoc or master mode. I am using Ubuntu 10.04 Alpha 3.

michi6278 (michi6278) wrote :

I can't also not enable Ad-Hoc mode.
It would be plesant to be able to...

I use Ubuntu 10.04 kernel 2.6.32-22 Realtek Semiconductor Corp. RTL8187 Wireless Adapter

Thomas (tux12345) wrote :

im using ubuntu 10.04 (2.6.32-22-generic) with an asus p5k premium board and can't use the ad-hoc mode
lsusb says
ID 0bda:8187 Realtek Semiconductor Corp. RTL8187 Wireless Adapter
when trying to enable ad-hoc mode with iwconfig it says
Error for wireless request "Set Mode" (8B06) :
SET failed on device wlan0 ; Operation not supported.

Lew Palm (lew) wrote :

For me it is the same.
I can not switch to Ad-Hoc mode with the driver rtl8187 in Ubuntu 10.04 on an amd64-platform.
It does not work using iwconfig and the network-manager is unable to do it, too.
Like koba said: it works with the driver r8187 from http://www.aircrack-ng.org/doku.php?id=r8187.
As a workaround I will use r8187.
Maybe a developer should have a look at the source from the aircrack page and see what they do differently.

For me the same..
I had netgear wg111v2 which had rtl8187 drivers..and using karmic. i tried to bring adapter in ad hoc mode which failed interface to bring up

Iuri Diniz (iuridiniz) wrote :

With a little investigation, I confirmed that rtl8187 (which is based on mac80211 stack) has no support to adhoc (IBSS)[1] and r8187(which is based on ieee80211 stack) has (according to you)

the problem is that rtl8187 is now the focus of implementation because ieee80211 drivers are considered legacy, the ieee80211 was removed from the mainline and so r8187 is NOT SHIPPED with ubuntu kernel. But the STAGING module rtl8192su continues to use ieee80211 stack while is not converted [./Sources/linux-wireless-testing/drivers/staging/rtl8192su/ieee80211]

2 choices:
1) we could ship the r8187 driver too (packing it with ieee80211 stack) and using jockey to select the correct driver (but jocker is for proprietary drivers)
2) Wait for rtl8187 implementation

[1] http://linuxwireless.org/en/users/Drivers

knorr (a-sokolov) wrote :

i've found patch in web

http://eeek.borgchat.net/lists/linux-wireless/msg53731.html
maybe it helps someone

blue balls (blueballs5432) wrote :

  This bug is still present in Ubuntu 10.04.
  When trying to set the mode to ad-hoc with this command

         iwconfig wlan0 mode ad-hoc

I get an error message:

Error for wireless request "Set Mode" (8B06) :
    SET failed on device wlan0 ; Operation not supported.

  Is someone looking into making the ad-hoc mode available on rtl8187 ?

It's still not working, niether in Linux Mint, nor Ubuntu.

I also tryed with the aircrack-ng drivers, but they won't detect my card.

tags: added: rtl8187

Still no donut in Oneiric

Casandro, thank you for reporting this and helping make Ubuntu better. This bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux <replace-with-bug-number>

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

tags: added: feisty needs-upstream-testing
Changed in linux (Ubuntu):
status: Confirmed → Incomplete

This problem has been fixed in mainline Linux kernel 3.4: http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=41b58f189ada1a12d3c9417c3eedd5b910d8d09f

As my rtl8187 device (Asus P5B Deluxe) has broken down in the meantime, I am not able to test it. Probably it is sufficient to use http://linuxwireless.org/en/users/Download instead of a completely new kernel (which would be 3.4-rc5 at the moment).

Richard

Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers