Ubuntu

driver for OTI 006858 USB-to-serial IC has errors

Reported by PowerUser on 2007-01-03
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Linux
Invalid
Medium
linux (Ubuntu)
Medium
Unassigned
Nominated for Karmic by Marco Costantini
Jaunty
Medium
Unassigned
linux-source-2.6.22 (Ubuntu)
Undecided
Unassigned
Nominated for Karmic by Marco Costantini
Jaunty
Undecided
Unassigned

Bug Description

I own USB to serial cable (for cell phone) based on OTI 006858 IC.It not seems to work.No ttyUSB? device created when I attach this cable and it not seems to operate properly.

Tested undeer Ubuntu Fiesty 7.0.4 x64 (both Alpha and daily build from 3.1.2007).Both have same behavior.

When attaching device:
[ 2246.275535] usb 1-6: new full speed USB device using ohci_hcd and address 4
[ 2246.377827] usb 1-6: configuration #1 chosen from 1 choice

root@ubuntu:/home/ubuntu# lsusb
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 004: ID 0ea0:6858 Ours Technology, Inc.
Bus 001 Device 003: ID 1310:0001 Roper Class 1 Bluetooth Dongle
Bus 001 Device 001: ID 0000:0000

USB-UART Tx Line

Manufacturer: OTi

Class
0
Subclass
0
Protocol
0
USB Version
1.10

Vendor ID
0xea0
Product ID
0x6858
Revision
1.00

Speed
12 Mbit/s
Channels
0
Max. Packet Size
0

Brian Murray (brian-murray) wrote :

Thanks for your bug report. Is there a kernel module loaded for this device when you insert it? You could run 'lsmod' before and after inserting the device and checking to see if there is a difference between the two outputs. The command 'dmesg' after inserting the device could be also informative.

Brian Murray (brian-murray) wrote :

We are closing this bug report as it lacks the information, described in the previous comments, we need to investigate the problem further. However, please reopen it if you can give us the missing information and feel free to submit bug reports in the future.

gnejusz pompejusz (pawciu1) wrote :

theri is no mathing module. but it works adter addin patch to kernel. this path is located http://www.gnokii.org/download/gnokii/patches/

Changed in linux-source-2.6.22:
status: Confirmed → Triaged

I have this cable, and I had the same problem with the old kernels. It seems that it requires kernel 2.6.24 (as in Ubuntu 8.04). With this kernel, the /dev/ttyUSB0 device is created. However, the connection to the mobile phone still doesn't work. I get a lot of the dmesg message
[ 6264.856587] oti6858_read_int_callback(port = 0, status = 0)

Bug confirmed on released Hardy 8.04 with kernel 2.6.24-16-generic.
oti6858 module loads successfully but trying to access the device gives a bunch of :
"oti6858_read_int_callback(port = 0, status = 0)"
messages and some :
"oti6858_chars_in_buffer(port = 0)
 oti6858_write_room(port = 0)"
until you kill the application accessing it which gives :
"oti6858_close(port = 0)
 oti6858_close(): entering wait loop
 oti6858_close(): after wait loop
 oti6858_read_int_callback(port = 0, status = 0)
 oti6858_close(): after schedule_timeout_interruptible()
 oti6858_close(): shutting down urbs
 oti6858_read_int_callback(port = 0, status = -2)
 oti6858_read_int_callback(): urb shutting down with status: -2"

Changed in linux-source-2.6.22:
status: Triaged → Confirmed
Changed in linux:
status: Confirmed → Triaged
Changed in linux:
status: Unknown → Confirmed
Brian Murray (brian-murray) wrote :

This bug does not meet the criteria for a stable release update and is being marked as Won't Fix for kernel version 2.6.22. You can learn more about the stable release update process at https://wiki.ubuntu.com/StableReleaseUpdates .

Changed in linux-source-2.6.22:
status: New → Won't Fix

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Marco Costantini (costanti) wrote :

This bug is still present in Alpha5 for Intrepid Ibex 8.10, kernel 2.6.27.2.

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

Tim Gardner (timg-tpi) wrote :

There has been no upstream activity in this driver since Oct 2008. Closing for Jaunty.

Changed in linux (Ubuntu Jaunty):
status: Triaged → Won't Fix
Marco Costantini (costanti) wrote :

This bug is still present in jaunty with kernel 2.6.28. Here is more information.

Linux ubuntu 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:57:59 UTC 2009 i686 GNU/Linux
With Kubuntu live Cd:
Description: Ubuntu 9.04
Release: 9.04
Codename: jaunty

dmesg after inserting
[33189.204020] usb 3-3: new full speed USB device using ohci_hcd and address 2
[33189.478564] usb 3-3: configuration #1 chosen from 1 choice
[33191.974828] USB Serial support registered for oti6858
[33191.974876] oti6858 3-3:1.0: oti6858 converter detected
[33191.975083] usb 3-3: oti6858 converter now attached to ttyUSB0
[33191.975112] usbcore: registered new interface driver oti6858

dmesg after removing
[33248.141858] usb 3-3: USB disconnect, address 2
[33248.145143] oti6858 ttyUSB0: oti6858 converter now disconnected from ttyUSB0
[33248.145170] oti6858 3-3:1.0: device disconnected

lsmod after inserting
oti6858 21892 0

lsusb
Bus 003 Device 004: ID 0ea0:6858 Ours Technology, Inc.

$ modinfo oti6858
filename: /lib/modules/2.6.28-11-generic/kernel/drivers/usb/serial/oti6858.ko
license: GPL
version: 0.1
author: Tomasz Michal Lukaszewski <FIXME@FIXME>
description: Ours Technology Inc. OTi-6858 USB to serial adapter driver
srcversion: 528224004E0C2E4A0A60E63
alias: usb:v0EA0p6858d*dc*dsc*dp*ic*isc*ip*
depends:
vermagic: 2.6.28-11-generic SMP mod_unload modversions 586
parm: debug:enable debug output (bool)

Here this cable is reported to work
http://wiki.gnokii.org/index.php/Cables#DKU-5_and_CA-42

Cable data sheet and specifications
http://www.stkaiser.de/anleitung/files/OTi6858.pdf

Marco Costantini (costanti) wrote :

With the kernel 2.6.28 and everything else as in my previous comment, all the programs (wammu, xgnokii, kppp, minicom, kmobiletools, scmxx) trying to access /dev/ttyUSB0 report timeout.

The various dmesg messages, such as
[ 6264.856587] oti6858_read_int_callback(port = 0, status = 0)
reported with previous kernels are no more present: the dmesg message are only when inserting the cable, as in my previous comment.

Andy Whitcroft (apw) wrote :

Could you include an strace of one application trying to open this device and timing out. Thanks!

Changed in linux (Ubuntu):
assignee: nobody → Andy Whitcroft (apw)
status: Triaged → Incomplete
Marco Costantini (costanti) wrote :

This bug also happens with Kubuntu Karmic 9.10 alpha 2 live cd

ubuntu@ubuntu:~$ uname -a
Linux ubuntu 2.6.30-8-generic #9-Ubuntu SMP Wed Jun 3 15:23:55 UTC 2009 i686 GNU/Linux
ubuntu@ubuntu:~$ sudo chmod a+rw /dev/ttyUSB0
ubuntu@ubuntu:~$ scmxx --device /dev/ttyUSB0 --verbose --reset
Using "UTF-8" as system character set.
Accessing device /dev/ttyUSB0...done
Sending reset frame...done

Error: Cannot read from device: Connection timed out
ubuntu@ubuntu:~$ strace scmxx --device /dev/ttyUSB0 --verbose --reset 2> strace_scmxx.txt
ubuntu@ubuntu:~$ strace minicom 2> strace_minicom.txt

Marco Costantini (costanti) wrote :
Changed in linux (Ubuntu):
status: Incomplete → New
Jeremy Foshee (jeremyfoshee) wrote :

Marco,
     This bug does not meet the criteria for a stable release update and is being marked as Won't Fix for kernel version 2.6.22. You can learn more about the stable release update process at https://wiki.ubuntu.com/StableReleaseUpdates .

Can you confirm this issue exists with the most recent Karmic Koala 9.10 Alpha release? ISO CD images are available at http://cdimage.ubuntu.com/releases/karmic/ . If the issue remains with Karmic it would be great to then also test the latest upstream mainline kernel available. This will allow additional upstream developers to examine this issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds .

Thanks in advance.

-JFo

Changed in linux (Ubuntu):
status: New → Incomplete
Andy Whitcroft (apw) on 2010-06-18
Changed in linux (Ubuntu):
assignee: Andy Whitcroft (apw) → nobody

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in linux (Ubuntu):
status: Incomplete → Invalid

Thank you for taking the time to report this bug and helping to make Ubuntu better. My apologies as I should not have marked this Invalid. The issue that you reported is one that should be reproducible with the live environment of the Desktop CD of the development release - Maverick Meerkat. It would help us greatly if you could test with it so we can work on getting it fixed in the next release of Ubuntu. You can find out more about the development release at http://www.ubuntu.com/testing/ . Thanks again and we appreciate your help.

Changed in linux (Ubuntu):
status: Invalid → Incomplete
Gursimran singh (simar) wrote :

Hi there

We'd like to figure out what's causing this bug for you, but we haven't heard back from you in a while. Could you please provide the requested information? Thanks!

Gursimran singh (simar) on 2010-11-21
Changed in linux (Ubuntu):
status: Incomplete → New
status: New → Incomplete
Changed in linux:
importance: Unknown → Medium
Changed in linux:
status: Confirmed → Invalid
PowerUser (i-am-sergey) wrote :

This bug has been about completely missing OTI 6858 device driver. Right now this driver presents in supplied kernel:
[ 2337.360240] oti6858 4-2:1.0: oti6858 converter detected
[ 2337.360327] usb 4-2: oti6858 converter now attached to ttyUSB0
[ 2337.360342] usbcore: registered new interface driver oti6858

So I'm about to close this bug. If someone encounters some other issues with this driver, I believe they should create separate bug since this bug had nothing to do with other issues.

Marking it as "fix released" because driver in question presents in current kernels.

Changed in linux (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.