Ubuntu

keyboard strokes registered repeatedly or not registered at all

Reported by Rostislav Raykov on 2006-10-11
10
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
linux-source-2.6.22 (Ubuntu)
Undecided
Unassigned

Bug Description

Hello,
This bug is posted as a dapper bug and is reported to have been fixed. However I have made a fresh install of Edgy Beta 1 on an Acer Aspire 3620 and the bug is there. I have tried to do all of the proposed from the comments of bug #39315, but to no avail.
Without any systematic behaviour, totally on random time, my laptop keyboard starts to behave oddly. The keypresses never get registered by the system or some key is registered as continuously pressed and starts without control to repeat itself like crazy. Like the key is stuck, and it can't be stopped by pressing it.
I have noticed that the continuous press or the lack or response from the keys can be ignored somehow if i move the cursor through the touchpad of the laptop. While I use the touchpad with one hand I can use the keyboard normally with the other.
This behaviour of the keyboard will somehow stop after a few minutes (not a specific time interval, everytime it's different) and then I can use it normally again.

Rostislav Raykov (zbrox) on 2006-10-11
description: updated
Wousser (wousser) wrote :

Thanks for your bug report and sorry for not getting in contact with you earlier.
Does your bug still exists? And does it in development versions?
Will you please check this, if your bug exist please tell here, otherwise you can set the bug status to invalid to close this bug.
Thanks in advance.

Rostislav Raykov (zbrox) wrote :

I'm having the exact same issues from Edgy to Feisty and even now to Gutsy. The bug was never fixed even though reported so.

trollord (trollenlord) wrote :

I am sorry to hear that. Could you produce using the most recent Ubuntu possible the following as attachments:
- Output of 'uname -a'
- Output of 'sudo lspci -vv'
- Output of 'sudo lspci -vvn'
- Output of 'dmesg'
- Output of 'xprop -root | grep XKB'
- Output of gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
- /var/log/Xorg.0.log

Rostislav Raykov (zbrox) wrote :

sorry for the delay in my answer. right now i've no upper case letters, cause my laptop thinks that the shift button is constantly pressed. also if i don't hold my finger on the touchpad there are random constant key presses or unregistering key presses. all in all the same behaviour as before. it can be very frustrating, because it's longer that a year like that... sometimes i can't exit from the virtual console on ctrl alt f1,f2,etc because of a 'pressed' alt or ctrl or shift...
i'm attaching an archive with the output you needed uname -a, sudo lspci -vv, and etc.

thanks for your help in advance1

TJ (tj) wrote :

I don't wish to infer that there is no software problem at the root of this, but I did wonder (because you seem to be seeing this on all kernel versions), after doing some research on this model if you've tried inspecting/cleaning/removing/repositioning the keyboard?

I found some references to the poor build quality and experience of the keyboard, and having had similar strange issues with notebook keyboards in the past that were solved by removing the keyboard and blowing it clean with an air-compressor, I thought it is worth asking the question.

Here's one quote:

"What concerns the tactile feedback, it's a catastrophe. The entire keyboard moves. Besides, the keyboard seems to be installed with a hump. The central sag is approximately 3 mm. Each time you press a button, the keyboard jumps up and hits your fingers. The keys are too soft, accidental key presses are quite possible (you may weigh down a button accidentally, when your hand just lies on the keyboard). But the soft keyboard is good for typing – it's less tiring for your hands. Only the right side is more or less firmly fixed. So it's unpleasant to type, the keyboard strikes your fingers back. As far as I understand, it's a common situation among such models. It's actually typical of blind typing only. For example, my relatives, who type with two fingers only, feel no difference between various types of keyboards. They are all the same to them."

From: http://www.digit-life.com/articles2/portopc/acer-3628.html

Rostislav Raykov (zbrox) wrote :

Yes, I've also thought if there might be a hardware issue here. I'm not excluding this as a possibility, it's just that more events are hinting toward the opposite. If I suspend the PC and then awaken it the problem may be gone. Sometimes keys that I haven't even touched start making the problem. I know, because at that time I have been using an external keyboard and tried to press only one key on the laptop's keyboard. Stuff like that...
But it's always a good idea to try to clean it up. I just haven't had the courage to do it. I'm afraid after that I won't be able to put it back together.

TJ (tj) wrote :

A couple of observations:

1) On my Sony Vaios at least, they plan for the keyboard to be removed for access and cleaning. 3-5 screws on the base are removed with a Jeweller's screwdriver and then the keyboard lifts up at the back. The clip holding the flat plastic cable into the connector on the circuit-board can be flipped up with a thumb-nail and the keyboard removes.

2) I had a recent weird experience that was keyboard-related in an oblique way. I usually alter the BIOS typematic rate settings so the repeat-rate is as high as possible. This usually means it goes from 4/second to 30/second. On one system it took me over 6 months to discover it was the reason that the Grub countdown timer ran about 8 times too fast - I'd had to increase the timeout to 200 to have 5 real seconds to press Escape!

So, with that in mind is there anything in the BIOS settings that isn't default, or could conceivably relate to keyboard, including interrupt settings?

Rostislav Raykov (zbrox) wrote :

I've tried to look for something in the BIOS that could be related to the problem, but to no avail. The BIOS settings are pretty scarce. I can change the device boot order, switch on/off some on board devices and etc.
I can't find any screws on the base of the laptop, that can be for removing the keyboard. I guess its because of the low-endness of the model. Next time I'm investing into something not so low-budget, but for now I'm stuck with this.

Henrik Nilsen Omma (henrik) wrote :

Could you try with a non-Ubuntu Live CD? Preferably non-Linux. That should tell us whether it's a hardware issue. There are BSD and Solaris Live CDs around.

Changed in linux-source-2.6.22:
status: Confirmed → Incomplete
Silvio Sisto (sistoviejo) wrote :

I have the same issue. Sometimes the system will freeze for a split second (keys typed don't echo on screen immediately) and afterwards all keys that were pressed during the freeze are echoed simultaneously with one of them repeating several times like this: hellooooooo
This will happen randomly over time. On some login sessions the issue is not present.
I have dual boot with Windows vista and the issue is not present in Vista hence I can confirm it's not a hardware issue in my case.
Please ask me anything else you need to know.

Here's some more information about my computer:
It's an HP tx1215nr laptop with an AMD Turion x64 dual core CPU.
I have a broadcomm wireless and I had to install it using ndiswrapper with the windows XP driver to make it work.
I'm using the International US English keyboard layout.
Compiz-fusion is enabled with wobbly windows and desktop cube and other eye candy. I also use gdesklets.
My Ubuntu version is Gutsy x86_64. My laptop will only boot using the options noapic and irqpoll.

I also have this problem on Gutsy.
Please fix this problem becouse I've just destroyed my old good keboard in a fume

legolas558 (legolas558) wrote :

Beginning with the Hardy Heron 8.04 development cycle, all open Ubuntu kernel bugs need to be reported against the "linux" kernel package. We are automatically migrating this bug to the new "linux" package. However, development has already began for the upcoming Intrepid Ibex 8.10 release. It would be helpful if you could test the upcoming release and verify if this is still an issue - http://www.ubuntu.com/testing . If the issue still exists, please update this report by changing the Status of the "linux" task from "Incomplete" to "New". We appreciate your patience and understanding as we make this transition. Thanks!

Silvio Sisto (sistoviejo) wrote :

I don't have this problem anymore.

Silvio Sisto (sistoviejo) wrote :

Just want to extend my previous message.
For me the problem was fixed when I updated from Gutsy to Hardy.
It hasn't reappeared ever since.

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Ralph Janke (txwikinger) wrote :

Unfortunately this bug report is being closed because we received no response to the last inquiry for information. However, the Intrepid Ibex 8.10 Beta release was most recently announced - http://www.ubuntu.com/testing/intrepid/beta . If you are able to confirm this is still an issue with this most recent release please feel free to reopen this report. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks.

Changed in linux:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.