e1000 driver on thinkpad X60/T60 produces latency

Bug #42572 reported by Scott Norris on 2006-05-02
32
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
linux (Ubuntu)
Medium
Unassigned
linux-source-2.6.15 (Ubuntu)
Undecided
Unassigned
linux-source-2.6.22 (Ubuntu)
Medium
Unassigned

Bug Description

The thinkpad X60 uses the Intel 82573L Gigabit ethernet chipset, which uses the e1000 driver. It was not noticed at all when I installed, and I had to unload/reload the driver module using modprobe as described here:

http://www.ubuntuforums.org/showthread.php?t=149941&highlight=e1000

Unlike in that thread, it seems to work fine for me on subsequent reboots. But the strange behavior is that, if I "ping" any test site, the response times alternate between a normal time of around 50ms, and a long time of exactly one second. On the thinkpad testing team page,

https://wiki.ubuntu.com/LaptopTestingTeam/ThinkpadX60s

Florg reports that this behavior is present in other kinds of network connections as well. However, both Florg and myself find that large files appear to be transferred at full speed.

Jeff Johnson (jeff-comfrey) wrote :

this is resolved in current kernel

Scott Norris (scottie-z) wrote :

Jeff,

I just upgraded the kernel this morning, and the alternating ping latency is still present. Do I need to upgrade anything else? Also, this NIC/driver/laptop combination breaks after a hibernate/thaw cycle -- see bug #44036.

florg (ubuntu-florg) wrote :

Hello,

as Scott said I've got the same problem and it is not solved with the new kernel. (Actually the detection problem might be solved, but the latency problem persists.)

A dmesg and sample ping can be found at the German forum http://www.ubuntu-forum.de/thread.php?threadid=10140

Currently I'm running 2.6.17rc4-git2 without any change in the latency :-/

I've also tried the kernel settings mentioned in the "[Update 20060415]" at the bottom of http://www.prolixium.com/linux-t60/

Another thing I tried that didn't work out is OpenSUSE 10.1 -- same latency.

Does anyone have an idea where to ask about this or how to get closer to resolving this issue?

Florian/florg

Jeff Johnson (jeff-comfrey) wrote :

driver does auto load, however ping latency is still present.

Stefan Wehr (mail-stefanwehr) wrote :

I can confirm the latency problem. Here is a sample ping:

PING web.de (217.72.195.42) 56(84) bytes of data.
64 bytes from ha-42.web.de (217.72.195.42): icmp_seq=1 ttl=248 time=1006 ms
64 bytes from ha-42.web.de (217.72.195.42): icmp_seq=2 ttl=248 time=81.1 ms
64 bytes from ha-42.web.de (217.72.195.42): icmp_seq=3 ttl=248 time=1010 ms
64 bytes from ha-42.web.de (217.72.195.42): icmp_seq=4 ttl=248 time=82.9 ms
64 bytes from ha-42.web.de (217.72.195.42): icmp_seq=5 ttl=248 time=1008 ms
64 bytes from ha-42.web.de (217.72.195.42): icmp_seq=6 ttl=248 time=82.3 ms
64 bytes from ha-42.web.de (217.72.195.42): icmp_seq=7 ttl=248 time=1006 ms
64 bytes from ha-42.web.de (217.72.195.42): icmp_seq=8 ttl=248 time=81.1 ms

--- web.de ping statistics ---
8 packets transmitted, 8 received, 0% packet loss, time 7068ms
rtt min/avg/max/mdev = 81.143/544.866/1010.397/462.961 ms, pipe 2

I'm running 2.6.15-23-686.

Why is the status of the bug still "unconfirmed"?

Daniel T Chen (crimsun) on 2006-07-17
Changed in linux-source-2.6.15:
status: Unconfirmed → Confirmed
florg (ubuntu-florg) wrote :

The latency problem still exists for me; also in 2.6.15-26 and 2.6.17-6.

Has anybody reliably solved this?

Auto-load is not a problem here.

Mattias Holmlund (u219) wrote :

I have the same alternating latency problem on my Thinkpad T60. It uses the e1000 driver as well. When I ping the Thinkpad from another host on my local network, the ping-times alternate between one second and a few milliseconds, almost always in the sequence long, short, long, short etc. I have tested this with both 6.06.1 and Edgy Eft Knot 3 with the same result.

The long latency makes remote X and ssh very painful to use, since the network seems to freeze one second at a time.

This problem has been reported in the Kernel bugzilla: http://bugme.osdl.org/show_bug.cgi?id=6929

Changed in linux:
status: Unknown → Confirmed
Changed in linux:
status: Confirmed → In Progress
Kent (kcanderson) wrote :

I am having the same latency problem with OpenSuSE 10.1 using the default kernel of 2.6.16.13-4-smp on the lenovo T60. I have tried loading the e1000-7.3.15.tar.gz package from intel with no change in outcome. I have also tried configuring a cisco vpn client using this interface with no success which is to be expected.

gagarine (gagarine) wrote :

I have the same problem withe my t60p on 6.06 Dapper Drake.

My network controler:
Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)

I test with 7.04 Feisty Fawn (kernel 2.6.20-8-generic) and the problem is still here.

a capture withe system monitor and with wireshark

gagarine (gagarine) wrote :
Changed in linux:
status: In Progress → Rejected
gagarine (gagarine) wrote :

always the same problem with feisty kernel 2.6.20-15-generic :(

Changed in linux:
status: Rejected → Confirmed
Changed in linux:
status: Confirmed → In Progress
Ali Sheikh (asheikh) wrote :

Googling for this problem I found http://www.thinkwiki.org/wiki/Ethernet_Controllers and tried the work-around suggested there. I was able to work-around the latency problem by adding the following to /etc/modprobe.d/options

options e1000 RxIntDelay=5

gagarine (gagarine) wrote :

Same problem with gusty!

gagarine (gagarine) wrote :

The work-around do nothing for me ping still very low. On 1000 Mbit/s network this is like a 50 Mbit/s :(.

gagarine (gagarine) wrote :

The bug is present with 2.6.22

gagarine (gagarine) on 2007-10-12
Changed in linux-source-2.6.15:
status: New → Confirmed
Changed in linux:
status: In Progress → Fix Released
gagarine (gagarine) wrote :

ok nice the fix is released upstream... possible to integrate in gusty backport? (i don't know if this is possible....)

Brian Murray (brian-murray) wrote :

I am assigning this bug to the 'ubuntu-kernel-team' per their bug policy. For future reference you can learn more about their bug policy at https://wiki.ubuntu.com/KernelTeamBugPolicies .

Changed in linux-source-2.6.22:
assignee: nobody → ubuntu-kernel-team
Oliver Fritz (oliver-o-fritz) wrote :

The problem was solved, after installing the following BIOSUpdate for my T60:
http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-63027
Update for BIOS Version 2.20 was published 2007/12/07.

Hi Everyone,

This bug was reported a while ago and there hasn't been any recent activity. The Hardy Heron Alpha series is currently under development and contains an updated version of the kernel. It would be helpful if you could test the latest Hardy Alpha release: http://www.ubuntu.com/testing . You should be able to then test the new kernel via the LiveCD. If you can, please verify if this bug still exists or not and report back your results. We'll keep this open against the actively developed kernel but against 2.6.15 and 2.6.22 this will be closed. Thanks.

Changed in linux:
status: New → Incomplete
Changed in linux-source-2.6.15:
status: Confirmed → Won't Fix
Changed in linux-source-2.6.22:
status: Confirmed → Won't Fix
mistergue (fritz-guenzler) wrote :

Sorry, but this bug isn´t fixed in Ubuntu 8.04 Alpha6.

Per the kernel team's bug policy, can you please attach the following information. Please be sure to attach each file as a separate attachment.

* uname -a > uname-a.log
* cat /proc/version_signature > version.log
* dmesg > dmesg.log
* sudo lspci -vvnn > lspci-vvnn.log

For more information regarding the kernel team bug policy, please refer to https://wiki.ubuntu.com/KernelTeamBugPolicies . Thanks again.

benaboo (lists1-tiserves) wrote :

Updating my T60's BIOS did nothing for this issue (I'm running Debian, 2.6.18-6). The only thing that fixed it was to update the e1000 driver. I had the same alternating latency, and transferring files over Samba was deathly slow.

The driver updates are at SourceForge: http://sourceforge.net/project/showfiles.php?group_id=42302

Note that the LATEST STABLE, 8.0.1, DID NOT FIX the issue. I went back two versions just to try it out, to 7.6.15.4.

I don't know what changed in the driver -- some default setting? Something else?

Hope this helps track down the issue.

benaboo (lists1-tiserves) wrote :

Sorry, just wanted to clarify that I didn't "update" the driver, I actually rolled back to 7.6.15.4. I don't know what e1000 build ships with Ubuntu, but you might try an earlier driver if it's past this build #.

wfaust (junk-coloraid) wrote :

Yes, similar problems here with various Suse/Debian kernels and the recommendations found on the net did not work 100%. In the end,
a patch posted from Auke Kok did show the solution: disable ASPM for the network device.

See my other postings:

https://bugs.launchpad.net/ubuntu/+bug/230847/comments/4

and

http://forums.suselinuxsupport.de/index.php?showtopic=66152&mode=threaded&pid=270086

Feel free to change/repost the description to make it work on Ubuntu with kernel <2.6.25 (most likely you only need to add at least a "sudo" before "make install").

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Andreas Oberritter (mtdcr) wrote :

The problem still occurs with 2.6.27 (Ubuntu 2.6.27-2.3-generic).

Andreas Oberritter (mtdcr) wrote :

I can confirm that the problem can be fixed by disabling ASPM. I downloaded e1000e-0.4.1.7.tar.gz from sourceforge, modified it to build with kernel 2.6.27, and verified that the latency problem still occurs. Then I disabled ASPM for my chipset (Intel 82573L) and since then I've got stable ping results.

benaboo (lists1-tiserves) wrote :

I just installed Ubuntu Alpha 5 with the 2.6.27-2-generic kernel, and this works fine now. This was the default install. No options selected while installing.

Andreas Oberritter (mtdcr) wrote :

@benaboo

Which chipset are you using?

I can still reproduce and fix this bug with 2.6.27-3-generic by using the way described above.

Hi All,

There is a serious bug which may affect some people subscribed to this report so I wanted to pass along the information. Due to an unresolved bug in the e1000e driver in the 2.6.27 Linux kernel, this driver/kernel should not be used on Intel ethernet hardware supported by the e1000e driver (Intel GigE). Doing so may render your network hardware permanently inoperable.

Older Intel ethernet hardware which uses the e1000 driver is not affected by this; however, some hardware which used the e1000 driver in previous Ubuntu releases, such as hardware that uses a PCI Express bus, has been moved from e1000 to e1000e in the latest kernel releases. If in doubt, do not use this driver/kernel and subscribe to https://bugs.launchpad.net/ubuntu/+source/linux/+bug/263555 to be notified when the bug is fixed.

Thanks.

Andreas Oberritter (mtdcr) wrote :

Leann, thanks for your warning, but the chipset affected by this bug (82573) seems not to be affected by the bug which corrupts the EEPROM.

Citing Ben Collins from #256555:
"The 2.6.26 kernel and 2.6.27 kernel have the exact same e1000e driver (one which we downloaded from Intel's e1000 sf.net project)."

So, although this problem has been fixed since months (patch posted by an Intel employee in Oct 07, patch applied upstream Jan 08, released with Linux 2.6.25), it obviously hasn't been incorporated into the version of e1000e which was downloaded from sf.net and integrated into Ubuntu.

Why is Ubuntu not using the upstream version at all?

According to http://kernel.ubuntu.com/git?p=ubuntu/ubuntu-next.git;a=history;f=ubuntu/e1000e;hb=HEAD the version used is 0.4.1.7. The patch I posted for this version before works like a charm. Please apply it. It is quite annoying to rebuild the driver every time a new kernel package gets uploaded.

If you don't trust my patch, you might want to ask Auke Kok <email address hidden>, who contributed http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=1eae4eb2a1c784bf35ee4f8f158cd21cf8c387c1 , to review it.

Thanks,
Andreas

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: Incomplete → Triaged

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

Brad Figg (brad-figg) wrote :

This bug was reported a while ago but there hasn't been any recent comments or updates. Is this still an issue with the latest pre-release of Jaunty 9.04? Refer to http://www.ubuntu.com/testing/jaunty/beta . Please let us know.

Jim Lieb (lieb) wrote :

This bug report is being closed because we received no response to the previous inquiry for information. Please reopen if this is still an issue in the current Ubuntu release, Jaunty Jackalope 9.04. To reopen the bug, click on the current status, under the Status column, and change the status back to "New". Thanks.

Changed in linux (Ubuntu):
status: Triaged → Won't Fix
Changed in linux:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.