Fails to logon (freezes) and cannot use terminal as it freezes as well if i try running any commands.

Bug #177820 reported by krutoileshii
4
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Won't Fix
Undecided
Unassigned
linux-source-2.6.22 (Ubuntu)
Won't Fix
Undecided
Unassigned

Bug Description

Here is the problem:

I have started with a fresh install of XUbuntu gutsy (also tried Ubuntu an Kubuntu) . The installation process works fine and everything is working correctly.
After that i ran an update and it updated to the kernel 2.6.22-14-generic.
After restarting it freezes up after i enter the password and hit enter at the login window.
If i switch in the text mode i can login but as soon as i try to run any commands to try to diagnose any problems it freezes as well and becomes non-responsive.

I am running Pentum 3.0GHz
1GB Ram

Any help would be helpfull.

I thing it might be caused by avahi-deamon .

Any instructions on how to diagnose this one would help. Kernel 2.6.22-10 worked just fine.

description: updated
Revision history for this message
krutoileshii (krutoileshii) wrote :

Attached is a syslog file

Revision history for this message
krutoileshii (krutoileshii) wrote :
Revision history for this message
krutoileshii (krutoileshii) wrote :
Revision history for this message
krutoileshii (krutoileshii) wrote :
Revision history for this message
krutoileshii (krutoileshii) wrote :
Revision history for this message
krutoileshii (krutoileshii) wrote :
Revision history for this message
Paul Dufresne (paulduf) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.

It may be quite hard to get this. You should try to Ctrl-Alt-F1 (the first one is the console and should receive kernel errors), and try
to log on it. If a kernel crash (oops) happen, then it will give full info on the screen.
You could take a picture with a digital camera and upload it.
Other option is to plug to other computer with null-modem serial cable.
There is a third option with kdump, but no one seems to suggest it.

That said, what would be best for us to know for now is if this happen also with Hardy.
The Hardy Heron Alpha series was recently released. Alpha2 and subsequent releases contain an updated version of the kernel. You can download and try the new Hardy Heron Alpha release from http://cdimage.ubuntu.com/releases/hardy/ . You should be able to then test the new kernel via the LiveCD. If you can, please verify if this bug still exists or not and report back your results. General information regarding the release can also be found here: http://www.ubuntu.com/testing/ . Thanks!
Alpha 3 is due for tomorrow, probably best to wait friday to be sure it is there.

Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

The Hardy Heron Alpha series was recently released. Alpha2 and subsequent releases contain an updated version of the kernel. You can download and try the new Hardy Heron Alpha release from http://cdimage.ubuntu.com/releases/hardy/ . Please note that Alpha3 will be released within the next day or two so you many want to wait. You should be able to then test the new kernel via the LiveCD. If you can, please verify if this bug still exists or not and report back your results. General information regarding the release can also be found here: http://www.ubuntu.com/testing/ . Thanks!

Changed in linux:
status: New → Incomplete
Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

I've opened a new task against the actively developed kernel and am closing the report against linux-source-2.6.22. Thanks!

Changed in linux-source-2.6.22:
status: New → Won't Fix
Paul Dufresne (paulduf)
Changed in linux-source-2.6.22:
status: Won't Fix → Incomplete
Revision history for this message
Paul Dufresne (paulduf) wrote :

Sorry Leann, we edited this bug status on 2.6.22 at the same time, and your won't fix status have disappear.
And I can't set to "won't fix" so you will have to reedit yourself.

Revision history for this message
krutoileshii (krutoileshii) wrote :

Ok,
 Ctrl-Alt-F1 won't work as the kernel would just freeze at login attempt.
I will try Hardy Heron Alpha3 and let you know if it work just have to finish downloading it

Thank you for taking the time to report this bug and helping to make Ubuntu better.

It may be quite hard to get this. You should try to Ctrl-Alt-F1 (the first one is the console and should receive kernel errors), and try
to log on it. If a kernel crash (oops) happen, then it will give full info on the screen.
You could take a picture with a digital camera and upload it.
Other option is to plug to other computer with null-modem serial cable.
There is a third option with kdump, but no one seems to suggest it.

That said, what would be best for us to know for now is if this happen also with Hardy.
The Hardy Heron Alpha series was recently released. Alpha2 and subsequent releases contain an updated version of the kernel. You can download and try the new Hardy Heron Alpha release from http://cdimage.ubuntu.com/releases/hardy/ . You should be able to then test the new kernel via the LiveCD. If you can, please verify if this bug still exists or not and report back your results. General information regarding the release can also be found here: http://www.ubuntu.com/testing/ . Thanks!
Alpha 3 is due for tomorrow, probably best to wait friday to be sure it is there.

Revision history for this message
krutoileshii (krutoileshii) wrote :

Ok, guys got the Hardy Heron Alpha3 burned it to a cd and tried to do a boot of it.
Live cd starts booting and failed when tries to load avahi-deamon after that it still loaded into gnome (LiveCD in use)
here is a system log file from the failure.

Let me know if you need me to try something to diagnose this.

Revision history for this message
krutoileshii (krutoileshii) wrote :

Gave a shot with Alpha3 and problem still exists.

Changed in linux:
status: Incomplete → New
Revision history for this message
krutoileshii (krutoileshii) wrote :

Gave a shot with Alpha3 and the problem still exists.

Changed in linux-source-2.6.22:
status: Incomplete → New
Revision history for this message
krutoileshii (krutoileshii) wrote :

Also tried installing it and got the same problem.

Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

Thanks for testing and giving us an update. The issue regarding the avahi-daemon has been reported at bug 181822. You mentioned "Live cd starts booting and failed when tries to load avahi-deamon after that it still loaded into gnome (LiveCD in use)" . . . so I just want to clarify that the issue regarding your system freezing after login is not longer present? Please confirm. Thanks!

Changed in linux:
status: New → Incomplete
Changed in linux-source-2.6.22:
status: New → Won't Fix
Revision history for this message
krutoileshii (krutoileshii) wrote : Re: [Bug 177820] Re: Fails to logon (freezes) and cannot use terminal as it freezes as well if i try running any commands.

It was there (i just upgraded my hardware so i can't test it again)
what happens is live CD boots into gnome and you can work from there the
install howewer doesn't and would fail out and freeze when you try to boot
it and console is non-responsive.

(Unfortinuatly i won't be able to help you guys test it on that hardware
untill i find a new case for it as i have done an upgrade to a dual core AMD
64 so it is a little different.
i wll however try the 64 bit version and let you know if it works.)

2008/1/18, Leann Ogasawara <email address hidden>:
>
> Thanks for testing and giving us an update. The issue regarding the
> avahi-daemon has been reported at bug 181822. You mentioned "Live cd
> starts booting and failed when tries to load avahi-deamon after that it
> still loaded into gnome (LiveCD in use)" . . . so I just want to clarify
> that the issue regarding your system freezing after login is not longer
> present? Please confirm. Thanks!
>
> ** Changed in: linux (Ubuntu)
> Status: New => Incomplete
>
> ** Changed in: linux-source-2.6.22 (Ubuntu)
> Status: New => Won't Fix
>
> --
> Fails to logon (freezes) and cannot use terminal as it freezes as well if
> i try running any commands.
> https://bugs.launchpad.net/bugs/177820
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

Thanks for the update. Unfortunately since you no longer have the hardware it makes it difficult to verify a fix. I'm going to close this report for now. If you experience any issues with your new system, please feel free to open a new bug report for each issue you see. Thanks!

Changed in linux:
status: Incomplete → Won't Fix
Revision history for this message
krutoileshii (krutoileshii) wrote :

Thank for the help, quick question though. i have an nvidia geforce8 8600 gt
video card i'm running AMD 64 dual core 5600 on a 64 bit version of gutsy.
Everything works fine except when it boots there is no vidoe signal untill
GDM is loaded. any ideas what could cause this. there are no errors and once
GDM is loaded it works just fine.

2008/1/25, Leann Ogasawara <email address hidden>:
>
> Thanks for the update. Unfortunately since you no longer have the
> hardware it makes it difficult to verify a fix. I'm going to close this
> report for now. If you experience any issues with your new system,
> please feel free to open a new bug report for each issue you see.
> Thanks!
>
> ** Changed in: linux (Ubuntu)
> Status: Incomplete => Won't Fix
>
> --
> Fails to logon (freezes) and cannot use terminal as it freezes as well if
> i try running any commands.
> https://bugs.launchpad.net/bugs/177820
> You received this bug notification because you are a direct subscriber
> of the bug.
>

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers