No Wi-Fi / Wifi / WLAN on different MacBook Pros (different Atheros Wi-Fi chips)

Bug #172705 reported by Jean-Philippe Dionne on 2007-11-29
6
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
linux-source-2.6.22 (Ubuntu)
Medium
Unassigned

Bug Description

On a Macbook Pro, frequent wireless problems occurs. The problem is triggered after having set the parameters to access a WPA2 PSK network . It can be complete system freeze or the following module crash:

[ 369.184000] <NULL>: ieee80211_unref_node_debug (ath_tx_draintxq:7683) f488a000<00:02:72:4d:7d:2d> refcnt -1
[ 369.216000] ADDRCONF(NETDEV_UP): ath0: link is not ready
[ 374.288000] sky2 eth0: Link is down.
[ 440.588000] ADDRCONF(NETDEV_CHANGE): ath0: link becomes ready
[ 451.408000] ath0: no IPv6 routers present
[ 490.724000] BUG: unable to handle kernel NULL pointer dereference at virtual address 000000bb
[ 490.724000] printing eip:
[ 490.724000] f8a55701
[ 490.724000] *pde = 00000000
[ 490.724000] Oops: 0000 [#1]
[ 490.724000] SMP
[ 490.724000] Modules linked in: aes wlan_ccmp ipv6 fglrx(P) coretemp eeprom i2c_i801 i2c_core uinput ppdev video ac container dock sbs button battery acpi_cpufreq cpufreq_userspace cpufreq_conservative cpufreq_powersave cpufreq_ondemand cpufreq_stats freq_table applesmc led_class sbp2 parport_pc lp parport af_packet snd_hda_intel snd_pcm_oss snd_mixer_oss snd_pcm snd_seq_dummy appleir isight_usb wlan_scan_sta snd_seq_oss joydev iTCO_wdt iTCO_vendor_support ath_rate_sample compat_ioctl32 xpad appletouch snd_seq_midi snd_rawmidi videodev ath_pci wlan ath_hal(P) snd_seq_midi_event v4l1_compat v4l2_common sky2 snd_seq snd_timer snd_seq_device snd soundcore snd_page_alloc tpm_infineon tpm tpm_bios intel_agp agpgart shpchp pci_hotplug evdev ext3 jbd mbcache sg sr_mod cdrom sd_mod ata_generic usbhid hid ohci1394 ieee1394 ehci_hcd ata_piix libata scsi_mod uhci_hcd usbcore thermal processor fan fuse apparmor commoncap
[ 490.724000] CPU: 1
[ 490.724000] EIP: 0060:[<f8a55701>] Tainted: P VLI
[ 490.724000] EFLAGS: 00010286 (2.6.22-14-generic #1)
[ 490.724000] EIP is at ath_tx_draintxq+0x91/0x1c0 [ath_pci]
[ 490.724000] eax: 00000000 ebx: dff53964 ecx: f48a26c0 edx: f48a2e40
[ 490.724000] esi: f488b000 edi: f7ec8834 ebp: dff539a4 esp: f5ec9dc4
[ 490.724000] ds: 007b es: 007b fs: 00d8 gs: 0033 ss: 0068
[ 490.724000] Process ifconfig (pid: 7104, ti=f5ec8000 task=f635cf90 task.ti=f5ec8000)
[ 490.724000] Stack: f5ec9e34 00000082 00000002 00000008 c1ce8000 f8a8bcbd c1ce8000 00000008
[ 490.724000] dff539b4 dff52500 c1ce8000 dff539d8 00000002 c1ce8000 dff52500 f8a5589b
[ 490.724000] c1ce8000 00000008 f4872c40 0000ba3e 00004d66 dff53b78 c1ce8000 0000000a
[ 490.724000] Call Trace:
[ 490.724000] [<f8a8bcbd>] zz002dca0b+0x4d/0x168 [ath_hal]
[ 490.724000] [<f8a5589b>] ath_draintxq+0x6b/0x200 [ath_pci]
[ 490.724000] [<f8a55dfe>] ath_stop_locked+0x5e/0x2c0 [ath_pci]
[ 490.724000] [<f8a875aa>] zz016e1251+0x32/0x68 [ath_hal]
[ 490.724000] [<f8a560e1>] ath_stop+0x81/0xb0 [ath_pci]
[ 490.724000] [<c0284b24>] dev_close+0x54/0x70
[ 490.724000] [<f8a30ac2>] ieee80211_stop+0xd2/0x100 [wlan]
[ 490.724000] [<c0284b24>] dev_close+0x54/0x70
[ 490.724000] [<c0283d49>] dev_change_flags+0x59/0x150
[ 490.724000] [<c02cd5ae>] devinet_ioctl+0x56e/0x6d0
[ 490.724000] [<c028529b>] dev_ifsioc+0xeb/0x370
[ 490.724000] [<c01fefa0>] copy_to_user+0x30/0x60
[ 490.724000] [<c02784cf>] sock_ioctl+0xbf/0x210
[ 490.724000] [<c0278410>] sock_ioctl+0x0/0x210
[ 490.724000] [<c018ca1b>] do_ioctl+0x2b/0xc0
[ 490.724000] [<c02f5d99>] do_page_fault+0x389/0x690
[ 490.724000] [<c02799c9>] sys_socket+0x29/0x50
[ 490.724000] [<c018cb0c>] vfs_ioctl+0x5c/0x290
[ 490.724000] [<c018cdb2>] sys_ioctl+0x72/0x90
[ 490.724000] [<c01041d2>] sysenter_past_esp+0x6b/0xa9
[ 490.724000] [<c02f0000>] clip_ioctl+0x500/0x510
[ 490.724000] =======================
[ 490.724000] Code: e8 75 e2 82 c7 c7 47 3c 00 00 00 00 85 f6 74 0f 8b 1e 89 f0 e8 61 e2 82 c7 85 db 89 de 75 f1 8b 77 44 85 f6 74 28 8b 77 44 8b 06 <f6> 80 bb 00 00 00 01 0f 85 af 00 00 00 f0 ff 4e 1c 0f 94 c0 84
[ 490.724000] EIP: [<f8a55701>] ath_tx_draintxq+0x91/0x1c0 [ath_pci] SS:ESP 0068:f5ec9dc4

Output from lspci -v :

03:00.0 Ethernet controller: Atheros Communications, Inc. AR5006EG 802.11 b/g Wireless PCI Express Adapter (rev 01)
        Subsystem: Apple Computer Inc. Unknown device 0086
        Flags: bus master, fast devsel, latency 0, IRQ 17
        Memory at 90100000 (64-bit, non-prefetchable) [size=64K]
        Capabilities: [40] Power Management version 2
        Capabilities: [50] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable-
        Capabilities: [60] Express Legacy Endpoint IRQ 0
        Capabilities: [90] MSI-X: Enable- Mask- TabSize=1

Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. With which version of Ubuntu and the kernel did you notice this issue? Thanks in advance.

Gutsy , kernel : 2.6.22-14-generic from linux-image-2.6.22-14-generic 2.6.22-14.46

Brian Murray (brian-murray) wrote :

I am assigning this bug to the 'ubuntu-kernel-team' per their bug policy. For future reference you can learn more about their bug policy at https://wiki.ubuntu.com/KernelTeamBugPolicies .

Changed in linux-source-2.6.22:
assignee: nobody → ubuntu-kernel-team

Beginning with the Hardy Heron 8.04 development cycle, all open Ubuntu kernel bugs need to be reported against the "linux" kernel package. We are automatically migrating this bug to the new "linux" package. However, development has already began for the upcoming Intrepid Ibex 8.10 release. It would be helpful if you could test the upcoming release and verify if this is still an issue - http://www.ubuntu.com/testing . If the issue still exists, please update this report by changing the Status of the "linux" task from "Incomplete" to "New". We appreciate your patience and understanding as we make this transition. Thanks!

Testing on a MacBook Pro which apparently has a Atheros Communications Inc. AR5418 802.11abgn Wireless PCI Express Adapter (rev 01) in it, you cannot use Wi-Fi. Actually, you can tell the network manager which Wi-Fi net net to choose, but then there happens nothing. There is not even the usual "attempting to connect" symbol with the green LED lights and the circle.

Changed in linux:
status: Incomplete → New
Changed in linux-source-2.6.22:
status: Won't Fix → New

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Trying to establish a PEAP connection with the 2.6.27 kernel, networkmanager closes without an error message and does not recover. Since I do not know how to restart it, I cannot test it. Maybe you could add a networkmanager icon to System -> Preferences so that the average user knows how to restart it.

Simple WiFi now works. However, notebook takes significantly longer to connect than under Mac OSX. Also, seems that signal strength is a little lower (I'm not quite sure).

Jean-Philippe,

Since you are the original bug reporter, care to comment if this is resolved for you? Also, we'll keep this open against the actively developed kernel bug against 2.6.22 this will be closed - see http://wiki.ubuntu.com/StableReleaseUpdates for more info. Thanks.

Changed in linux:
status: New → Incomplete
Changed in linux-source-2.6.22:
status: New → Won't Fix

Hi, sorry for the delay.

It works fine with the Intrepid beta livecd. I'll make a fresh
install in the next days and see if it's stable between reboots and
suspends.

Thanks!

On Mon, Oct 6, 2008 at 8:41 PM, Leann Ogasawara <email address hidden> wrote:
> Jean-Philippe,
>
> Since you are the original bug reporter, care to comment if this is
> resolved for you? Also, we'll keep this open against the actively
> developed kernel bug against 2.6.22 this will be closed - see
> http://wiki.ubuntu.com/StableReleaseUpdates for more info. Thanks.
>
> ** Changed in: linux (Ubuntu)
> Status: New => Incomplete
>
> ** Changed in: linux-source-2.6.22 (Ubuntu)
> Status: New => Won't Fix
>
> --
> No Wi-Fi / Wifi / WLAN on different MacBook Pros (different Atheros Wi-Fi chips)
> https://bugs.launchpad.net/bugs/172705
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Hi Jean-Philippe,

Based on your last comment I'm going to mark this "Fix Released" for Intrepid for now. If this is not the case feel free to reopen by setting the status back to "New". Thanks.

Changed in linux:
status: Incomplete → Fix Released

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers