Sony Vaio VGN-FZ* Motion Eye Camera (Ricoh firmware)

Bug #172372 reported by Michael Lustfield on 2007-11-27
6
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Low
Unassigned
Declined for Gutsy by Pedro Villavicencio
linux-source-2.6.22 (Ubuntu)
Medium
Unassigned
Declined for Gutsy by Pedro Villavicencio

Bug Description

Manufacturer : Sony Corporation
Product Name : VGN-FZ240E
Version : C6001VST

Installed camorama.

Get the following error:
"Could not connect to video device (/dev/video0).
Please check connection."

ls /dev | grep video
Returns Nothing

I'll post more as I find it out.

Pedro Villavicencio (pedro) wrote :

This bug was nominated for Gutsy but does currently not qualify for a 7.10 stable release update (SRU) and the nomination is therefore declined.

According the the SRU policy, the fix should already be deployed and tested in the current development version before an update to the stable releases will be considered. With 7.10 now released, that policy applies to this bug. See: https://wiki.ubuntu.com/StableReleaseUpdates

The bug is not being closed as work will continue on fixing it for the next release, Hardy Heron (8.04). If the state of this bug should change such that it qualifies for the SRU process, please contact the person who originally declined it and ask them to re-evaluate it. To help improve the state of this bug see: https://wiki.ubuntu.com/Bugs/HowToTriage

Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Unfortunately we can't fix it, because your description doesn't yet have enough information.
Please include as attachments the following additional information, if you have not already done so (please pay attention to lspci's additional options), as required by the Ubuntu Kernel Team:
1. Please include the output of the command 'uname -a' in your next response. It should be one, long line of text which includes the exact kernel version you're running, as well as the CPU architecture.
2. Please run the command 'dmesg > dmesg.log' and attach the resulting file 'dmesg.log' to this bug report.
3. Please run the command 'sudo lspci -vvnn > lspci-vvnn.log' and attach the resulting file 'lspci-vvnn.log' to this bug report.
For your reference, the full description of procedures for kernel-related bug reports is available at https://wiki.ubuntu.com/KernelTeamBugPolicies . Thanks in advance!

uname -a
Linux eaglei 2.6.22-14-generic #1 SMP Sun Oct 14 21:45:15 GMT 2007 x86_64 GNU/Linux
 - I've also tried on 32bit

Probably need this too...

I am changing status from Incomplete to New. If more information is needed, please let me know. I would rather not leave as incomplete now that I have added a lot of information to this bug.

Changed in linux-source-2.6.22:
status: Incomplete → New
Changed in linux-source-2.6.22:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: New → Triaged

The Hardy Heron kernel was recently uploaded for testing. We'd really appreciate it if you could try testing with this newer kernel and verify if this issue still exists. Unfortunately, the Hardy Heron Alpha1 LiveCD was released with the older 2.6.22 kernel. You'll have to manually install the newer Hardy Heron kernel in order to test. This should not be the case for Alpha2. However, here are the instructions to install (if you choose to do so):

1) edit the file /etc/apt/sources.list and add the following line:

deb http://archive.ubuntu.com/ubuntu hardy main restricted

2) sudo apt-get update
3) sudo apt-get install linux-image-2.6.24-1-generic
4) reboot and select the new kernel from the grub menu

After you've tested, please feel free to revert back - ie boot into the old kernel, sudo apt-get remove linux-image-2.6.24-1-generic, and remove the line from /etc/apt/sources.list . Please update this report with your results. Thanks in advance!

Changed in linux:
status: New → Incomplete

The Hardy Heron Alpha2 release will be coming out soon (around Dec 20). You'll be able to test the new kernel via the LiveCD for this release. I'll be sure to update this report when Alpha2 is available. Thanks!

Against linux-source-2.6.22 this bug does not meet the criteria for a stable release update and is being marked as Won't Fix. You can learn more about the stable release update process at https://wiki.ubuntu.com/StableReleaseUpdates . Thanks!

Changed in linux-source-2.6.22:
status: Triaged → Won't Fix

Leann... I'm not too up on what packages to mark things for. I'll download the new cd in about 1 1/2 weeks. After I play with it, I'll post everything I know.

Hardy Heron Alpha2 was recently released. It contains an updated version of the kernel. You can download and try the new Hardy Heron Alpha2 release from http://cdimage.ubuntu.com/releases/hardy/alpha-2/ . You should be able to then test the new kernel via the LiveCD. If you can, please verify if this bug still exists or not and report back your results. General information regarding the release can also be found here: http://www.ubuntu.com/testing/hardy/alpha2 . Thanks!

Running zsane failed because "No devices were found."
Then I installed kamera which doesn't seem like it will be any help until I find out what model of camera this actually is.

Anyway - away with the attachments.

I was just thinking. If somebody decided that this was Medium priority for a specific kernel version, should that priority now be applied to 'linux' ?

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: Incomplete → Triaged

What does triaged mean. Is this bug merged with my other bug? I'll post the same files here anyway.

Hi Michael,

"Triaged" means that a member of Ubuntu Bug Control believes that the report describes a genuine bug in enough detail that a developer could start working on a fix. For a full list of possible bug statuses and their meanins, please refer to: https://wiki.ubuntu.com/Bugs/Status . Thanks.

Pihhan (pihhan) wrote :

If that camera is same as mine, you need r5u870 driver. I read somewhere you can install it as package ricoh-webcam-r5u870. At least that package is in hardy.

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

This is the latest alpha release. I did an update on it after booting but that didn't really have anything.

This is xawtv-3.95.dfsg.1, running on Linux/x86_64 (2.6.27-3-generic)
xinerama 0: 1280x800+0+0
can't open /dev/video0: No such file or directory
v4l-conf had some trouble, trying to continue anyway
v4l2: open /dev/video0: No such file or directory
v4l2: open /dev/video0: No such file or directory
v4l: open /dev/video0: No such file or directory
no video grabber device available

I used xawtv to test because I know it works when the r5u870 is enabled. Tried a modprobe but it wasn't found.

Pihhan (pihhan) wrote :

Hello,

what are you looking for is propable here:
http://wiki.mediati.org/R5u870

I have vaio VGN-FZ210CE, and it does support my camera. It has some problems with loading driver firmware after suspend, but it does work anyway. Unfortunately, it has not widely supported pixel format, which camorama does not support in hardy. At least my version. I have not yet tried it with intrepid.

Ya, that driver was mentioned earlier. In fact, if the driver were in the repositories that would probably constitute a fix.

The package you mentioned earlier is not in the repositories.

I realize nothing seems to be getting done about this anyway, but I would suggest changing the Importance to Low because it affects a small range of users and can be easily worked around.

Setting to Low per Michael's previous comment.

Changed in linux:
importance: Medium → Low

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

Changed in linux:
assignee: nobody → ubuntu-kernel-team

Could you confirm that the problem is missing firmware and fw-loading tools in Ubuntu?

That is what it looks like from downloading the code from http://bitbucket.org/ahixon/r5u87x/

Changed in linux (Ubuntu):
assignee: Ubuntu Kernel Team (ubuntu-kernel-team) → nobody
status: Triaged → Incomplete

After I download the code and enable the module I can run xawtv and everything works perfect. Granted this version of the driver I installed runs like utter crap (it used to work right).

I'm not sure if this answers your question or not.

I'm not sure Triaged -> Incomplete is the right process for a bug though...

Amit Kucheria (amitk) wrote :

'Incomplete' status is being used here to denote that I am waiting for a response from the reporter. Given our bug volumes we need some way to not trip over the same bugs over and over again. I do agree that 'Incomplete' is a bit of a misnomer but I digress.

This bug can only be fixed by somehow automatically installing the firmware. Bug 120434 seems to be on its way to doing that for Jaunty. Given that the firmware is extracted from Windows files, I don't see any way to integrated this into the kernel firmware w/o explicit approval from Ricoh.

Marking the bug as Won't Fix for this reason. I urge everyone to track Bug 120434 to track progress of packaging the firmware for Ubuntu.

Changed in linux (Ubuntu):
status: Incomplete → Won't Fix
summary: - [gutsy] Sony Vaio VGN-FZ* Motion Eye Camera
+ Sony Vaio VGN-FZ* Motion Eye Camera (Ricoh firmware)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers