pcie mem resource kernel conflict

Bug #172312 reported by j4ck on 2007-11-27
6
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
linux-source-2.6.22 (Ubuntu)
Medium
Unassigned

Bug Description

System works fine untill its boot with nvidia video drivers.
When X starts with "nvidia" driver, system got freeze.
Dead black screen and no message, errors or speaker beeps..

Found this in dmesg

# dmesg
[ 20.393275] PCI: Cannot allocate resource region 3 of device 0000:05:00.0
[ 20.480120] PCI: Failed to allocate mem resource #3:2000000@fe000000 for 0000:05:00.0
[ 20.480120] PCI: got res [9010000:9017fff] bus [9010000:9017fff] flags 2200 for BAR 6
[ 21.108511] Boot video device is 0000:05:00.0
[ 39.067285] ACPI: PCI Interrupt 0000:05:00.0[A] -> Link [APC3] -> GSI 18 (level, low) -> IRQ 20
[ 39.067387] PCI: Setting latency timer of device 0000:05:00.0 to 64

I also try:
- enabling restricted drivers.
- install nvidia 100.14.23 driver thru nvidia-installer
- install drivers thru Envy script
- compile latest kernel
- play with apic,lapic,noapic,acpi=off and other kernel options

And what is the region 3 of device? Sure my prob here..
>> PCI: Cannot allocate resource region 3 of device 0000:05:00.0 (video card)

Probably this is bios or kernel bug...

Btw video works greet on winxp sp2 on this machine.
If there are io/memory conflicts in linux kernel, how to pass right parameters (from windows sysinfo) for kernel (reserve=, pci=) for videocard gets work?

Oleksij Rempel (olerem) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Unfortunately we can't fix it, because your description does not yet have enough information.

Please include the following additional information, if you have not already done so (pay attention to lspci's additional options), as required by the Ubuntu Kernel Team:
1. Please include the output of the command "uname -a" in your next response. It should be one, long line of text which includes the exact kernel version you're running, as well as the CPU architecture.
2. Please run the command "dmesg > dmesg.log" after a fresh boot and attach the resulting file "dmesg.log" to this bug report.
3. Please run the command "sudo lspci -vvnn > lspci-vvnn.log" and attach the resulting file "lspci-vvnn.log" to this bug report.

j4ck (vladimir-4style) wrote :

#uname -a
Linux j4ck-penguinux 2.6.24-rc3j4ck #1 SMP Sun Nov 25 14:26:20 MSK 2007 i686 GNU/Linux
(also try this on default ubntu 7.10 kernel 2.6.22-14)

j4ck (vladimir-4style) wrote :
homophoni (davidkirby) wrote :

Greetings,

I am having the exact same bug. I fairly certain that this an issue with nForce4 chipsets and nvidia 8xxx series video cards.

Things I have tried to fix the issue ->

* 7.04, and 7.10
* install latest nvidia drivers via nvidia installer
* Use Envy to install the latest nvidia drivers
* Compile latest kernel(s)
* Played around with every kernel option I could think of
* Checked for new updates for the past 4 months, hoping something would work

System info below ->

Linux dsk-ubuntu 2.6.20-16-generic #2 SMP Tue Dec 18 05:45:12 UTC 2007 i686 GNU/Linux

homophoni (davidkirby) wrote :
homophoni (davidkirby) wrote :

Update: same issue in Fedora 8 (PCI: Cannot allocate resource region 3 of device 0000:05:00.0 (video card)), Nvidia drivers fail to load.

I also get the same memory error in openSUSE 10.3 *BUT* the proprietary Nvidia drivers load regardless.

One thing I noticed different with openSUSE, is that after the memory error, AGP is disabled ->

<6>PCI-DMA: Disabling AGP.
<4>PCI-DMA: aperture base @ 4000000 size 65536 KB
<6>PCI-DMA: using GART IOMMU.
<6>PCI-DMA: Reserving 64MB of IOMMU area in the AGP aperture

My boot log is attached if that helps.

Beginning with the Hardy Heron 8.04 development cycle, all open Ubuntu kernel bugs need to be reported against the "linux" kernel package. We are automatically migrating this bug to the new "linux" package. However, development has already began for the upcoming Intrepid Ibex 8.10 release. It would be helpful if you could test the upcoming release and verify if this is still an issue - http://www.ubuntu.com/testing . If the issue still exists, please update this report by changing the Status of the "linux" task from "Incomplete" to "New". We appreciate your patience and understanding as we make this transition. Thanks!

j4ck (vladimir-4style) wrote :

Hello. I found lame solution for this issure.
Its work for me:

Add kernel option

reserve=0xCE000000,0x1FFFFFF

Then system boots fine and

glxinfo | grep direc
direct rendering: Yes

Extra post in my blog (in russian)
http://www.skillz.ru/dev/m1sc/article-Ubuntu_7_10_linux_kernel_2_6_22_vs_NVIDIA_8600_GT.html

j4ck (vladimir-4style) wrote :

Ubuntu 8.04

Changed in linux:
status: Incomplete → New

Hi j4ck,

Thanks for the update. I'm curious if you'd be willing to confirm if this is still an issue with the latest Alpha for the upcoming Intrepid Ibex 8.10. You should be able to test via a LiveCD - http://www.ubuntu.com/testing. Do you still have to use the kernel option workaround? Please let us know your results. Thanks.

Changed in linux:
status: New → Incomplete

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

homophoni (davidkirby) wrote :

downloading new kernels now, will report back...

homophoni (davidkirby) wrote :

problem resolved in ubuntu intrepid ibex 8.10 alpha 6 (linux-2.6.27).

YES!!!!!!!!!!

j4ck (vladimir-4style) wrote :

confirm this. solved

Per the last few comments, I'm marking this "Fix Released" for Intrepid. Thanks.

Changed in linux:
status: Incomplete → Fix Released

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers