sleep sometimes causes log-outs or reboots

Bug #172302 reported by Bogdan Butnaru on 2007-11-27
6
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
linux-source-2.6.22 (Ubuntu)
Medium
Unassigned

Bug Description

Hello! I'm using Ubuntu Hardy on a Dell Latitude D620 laptop.

Usually sleep works very well: there's a special "Fn" key on the keyboard that can turn on some special effects, for instance it turns Esc into "sleep". This is correctly detected by Ubuntu, and it enters sleep mode immediately. If I close the cover and re-open it, Ubuntu usually resumes from sleep correctly.

However, sometimes I get different behaviors. For instance, several times I get the login screen instead. I checked the process list, and it appears that the old session went away. Much less often the computer simply reboots, but that might be related to automatic hibernating, so it can probably be disregarded for this bug report.

Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Unfortunately we can't fix it, because your description doesn't yet have enough information.
Please include as attachments the following additional information, if you have not already done so (please pay attention to lspci's additional options), as required by the Ubuntu Kernel Team:
1. Please include the output of the command 'uname -a' in your next response. It should be one, long line of text which includes the exact kernel version you're running, as well as the CPU architecture.
2. Please run the command 'dmesg > dmesg.log' and attach the resulting file 'dmesg.log' to this bug report.
3. Please run the command 'sudo lspci -vvnn > lspci-vvnn.log' and attach the resulting file 'lspci-vvnn.log' to this bug report.
For your reference, the full description of procedures for kernel-related bug reports is available at https://wiki.ubuntu.com/KernelTeamBugPolicies . Thanks in advance!

Changed in linux-source-2.6.22:
assignee: ubuntu-kernel-acpi → nobody
Bogdan Butnaru (bogdanb) wrote :

$ uname -a
Linux arioch 2.6.22-14-generic #1 SMP Sun Oct 14 23:05:12 GMT 2007 i686 GNU/Linux

Bogdan Butnaru (bogdanb) wrote :
Changed in linux-source-2.6.22:
assignee: nobody → ubuntu-kernel-acpi
importance: Undecided → Medium
status: Incomplete → Triaged
Paul Dufresne (paulduf) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The Hardy Heron Alpha series was recently released. Alpha2 and subsequent releases contain an updated version of the kernel. You can download and try the new Hardy Heron Alpha release from http://cdimage.ubuntu.com/releases/hardy/ . Please note that Alpha3 will be released within the next day or two so you many want to wait. You should be able to then test the new kernel via the LiveCD. If you can, please verify if this bug still exists or not and report back your results. General information regarding the release can also be found here: http://www.ubuntu.com/testing/ .
Please note that you can test Sleeping (Suspend to ram) on the LiveCD, but not Hibernating (Suspend to disk).
Thanks!

Bogdan Butnaru (bogdanb) wrote :

Thanks for the update, but I'm always up-to-date via normal internet updates, which I assume are in sync with the alpha releases. (I realize it was a canned message, but I'm writing this for anyone else who might read the report.)

The problem is that the "bad" behavior doesn't happen all the time; it'll randomly happen maybe once a week or so.

It also tends to occur in the morning; I wasn't clear before, the crashes occur on resume, not on sleep. I usually resume in the morning, when I'm kind of sleepy. So I'd need some sort of checklist of what to do when it happens, so I can do it even half asleep. (E.g., what look for, what logs to record, etc.)

I looked at the link you gave above; I found a list of what to test, but not how to diagnose when things happen, especially if they're rare.

Brian Murray (brian-murray) wrote :

Normal internet updates will not provide you an upgrade to the Alpha release of the distribution. Only when the final release is out would you be prompted to upgrade to Hardy.

You refer to sleep in your bug report which is a bit vague. Do you mean "suspend" or "hibernate"? Suspend puts your computer in a low power state and stores information in RAM while hibernate writes your session to the swap partition and turns your system off. Thanks.

Bogdan Butnaru (bogdanb) wrote :

Oops, sorry! I just noticed that I had just mentioned Gutsy in the original report, but I am on Hardy ever since the first alpha was released.

Also, I meant "suspend" when I said sleep. Hibernate used to work around Feisty, but it also started doing funny things (occasional clean reboots instead of resuming), so I haven't tried it in a long time.

Ever since the first triage I went through some updates, now "uname -a" gives:
Linux arioch 2.6.24-2-generic #1 SMP Thu Dec 20 17:36:12 GMT 2007 i686 GNU/Linux

Is the new lspci needed?

description: updated

Beginning with the Hardy Heron 8.04 development cycle, all open Ubuntu kernel bugs need to be reported against the "linux" kernel package. We are automatically migrating this bug to the new "linux" package. However, development has already began for the upcoming Intrepid Ibex 8.10 release. It would be helpful if you could test the upcoming release and verify if this is still an issue - http://www.ubuntu.com/testing . If the issue still exists, please update this report by changing the Status of the "linux" task from "Incomplete" to "New". We appreciate your patience and understanding as we make this transition. Thanks!

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Bogdan Butnaru (bogdanb) wrote :

I haven't encountered this for a while on Intrepid, so I consider it fixed on Intrepid. I don't have Hardy anymore, so I've no idea if it works there.

Brian Murray (brian-murray) wrote :

This bug report is being closed due to your last comment regarding this being fixed with an update. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the drop down box. You can learn more about bug statuses at http://wiki.ubuntu.com/Bugs/Status . Thank you again for taking the time to report this bug and helping to make Ubuntu better. Feel free to submit any future bugs you may find.

Changed in linux:
status: Incomplete → Fix Released
Curtis Hovey (sinzui) on 2012-04-09
Changed in linux-source-2.6.22 (Ubuntu):
assignee: Registry Administrators (registry) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers