Upgraded to 7.10 and sound has disappeared

Bug #164598 reported by Gobbie on 2007-11-22
4
Affects Status Importance Assigned to Milestone
linux-source-2.6.22 (Ubuntu)
Undecided
Unassigned

Bug Description

After upgrading to 7.10, my sound has disappeared. I don't think it see's a sound card anymore.

ProblemType: Bug
Architecture: i386
Date: Thu Nov 22 23:16:24 2007
DistroRelease: Ubuntu 7.10
NonfreeKernelModules: nvidia ath_hal
Package: hal 0.5.9.1-6ubuntu5
PackageArchitecture: i386
SourcePackage: hal
Uname: Linux owens-desktop 2.6.22-14-386 #1 Sun Oct 14 22:36:54 GMT 2007 i686 GNU/Linux

Gobbie (owen-schtum) wrote :
nowshining (nowshining) wrote :

if u have the sound /speaker icon on the taskbar right-click and open volume control and make sure ALL is unmuted...

IF not it would be nice for others to know the exact brand and model of ur sound card if the above does not help.

Gobbie (owen-schtum) wrote :

This is the error I get when I try to open the volume controls...........No volume control GStreamer plugins and/or devices found.

It's built around an Asus Pundit A1 which I believe has sound onboard the mother board

Gobbie (owen-schtum) wrote :

Thanks for the help guys. I followed the link above and found what looked like good info in the last post. It linked to this site........ http://linux.dsplabs.com.au/?p=31
I started following the instructions but my 'users' and groups' and more have disappeared from my 'System -> Administration' list! I've got no idea why. I don't think I've done anything I shouldn't but I'm guessing my admin rights have gone for some reason! There's only one logon to the pc which always had full rights. Any help here would be gratefully accepted because I'm getting very stuck here! I really don't want to go back to Windows because Ubuntu seems to do the job well but some of it is a bit complex for a Newbie.

HELP!!!

nowshining (nowshining) wrote :

well, right-click system and click edit menus ( u can click anywhere such as places, applications) find on the side the administration folder and is users and groups listed on the right - u may need to scroll down or not, if so, it may be unchecked if not, open up a terminal and type gksu users-admin and then run it from there - don't close the terminal why the gui app is open otherwise the program will also exit, do what u need to do click close and then u can edit the terminal, if not then maybe something happened with the package/program, remember everything in GUI can basically be done in CLI or command line style or by editing certain files...

Gobbie (owen-schtum) wrote :
Download full text (6.4 KiB)

Right, I've got admin rights back but haven't got any further. This is doing my head in! Having friends over tonight & no sounds from my 'great new pc'! Please help!

I don't think the sound card is recognised & I've got no idea how to resolve it. Here are my outputs from 'lsmod' and 'lspci' which I saw requested in another similar thread. Maybe they'll tell you something.....they mean nothing to me!

owen@owens-desktop:~$ lsmod
Module Size Used by
af_packet 21896 4
nls_iso8859_1 4224 2
nls_cp437 5888 2
vfat 12800 2
fat 52636 1 vfat
binfmt_misc 11400 1
ipv6 257700 14
rfcomm 38684 2
l2cap 22788 11 rfcomm
bluetooth 52324 4 rfcomm,l2cap
capability 5000 0
ppdev 9348 0
powernow_k8 11916 0
cpufreq_stats 5508 0
cpufreq_ondemand 8084 1
cpufreq_powersave 1792 0
cpufreq_conservative 6560 0
cpufreq_userspace 4116 0
freq_table 4740 3 powernow_k8,cpufreq_stats,cpufreq_ondemand
container 4608 0
ac 5252 0
video 17164 0
sbs 18568 0
button 8080 0
dock 9476 0
battery 10116 0
sbp2 23304 0
lp 11460 0
joydev 10432 0
wlan_scan_sta 13696 1
ath_rate_sample 13184 1
cx22702 6404 1
cx88_dvb 15876 0
cx88_vp3054_i2c 3712 1 cx88_dvb
dvb_pll 14596 2 cx88_dvb
video_buf_dvb 6916 1 cx88_dvb
dvb_core 80168 1 video_buf_dvb
ath_pci 96288 0
usbhid 28384 0
cx8802 18436 1 cx88_dvb
hid 27008 1 usbhid
cx8800 33784 0
cx88xx 66980 3 cx88_dvb,cx8802,cx8800
compat_ioctl32 1408 1 cx8800
serio_raw 7044 0
parport_pc 36132 1
parport 35656 3 ppdev,lp,parport_pc
pcspkr 3072 0
ir_common 34436 1 cx88xx
i2c_algo_bit 6532 2 cx88_vp3054_i2c,cx88xx
tveeprom 15888 1 cx88xx
videodev 28288 2 cx8800,cx88xx
v4l2_common 17536 3 cx8800,cx88xx,videodev
v4l1_compat 14468 1 videodev
btcx_risc 5000 3 cx8802,cx8800,cx88xx
video_buf 25604 5 cx88_dvb,video_buf_dvb,cx8802,cx8800,cx88xx
rtc 13208 0
wlan 205636 4 wlan_scan_sta,ath_rate_sample,ath_pci
psmouse 38672 0
ath_hal 191696 3 ath_rate_sample,ath_pci
k8temp 5760 0
i2c_nforce2 6144 0
nvidia 6218832 34
agpgart 33584 1 nvidia
i2c_core 25104 9 cx22702,cx88_dvb,cx88_vp3054_i2c,dvb_pll,cx88xx,i2c_algo_bit,tveeprom,i2c_nforce2,nvidia
evdev 10240 5
ext3 129928 1
jbd 53416 1 ext3
mbcache ...

Read more...

Gobbie (owen-schtum) wrote :

I forgot to mention......once I had my admin rights back, I went back to http://linux.dsplabs.com.au/?p=31 to try again. It says near the start to type ls -la /dev/snd which doesn't work for me (No such file or directory). Any ideas?

Albert Damen (albrt) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.

bug 156771 describes a similar problem with a MCP51 High Definition sound card. In that case the missing package linux-ubuntu-modules seemed to be the cause. Please install the package linux-ubuntu-modules-2.6.22-14-386 and try if that solves the problem. You can install this package using synaptic (System menu --> Administration --> Synaptic Package Manager). Please let us know if this solves the problem.

If that does not help, please attach (not paste) the information requested in the "Reporting Sound Bugs" section of https://help.ubuntu.com/community/DebuggingSoundProblems as separate attachments to this bug report.

Gobbie (owen-schtum) wrote :

IT WORKED!!!

Excellent! I've got no idea what the module is or how I would ever have found it but the problem is fixed. Hopefully these things will be ironed out in Ubuntu and possibly automated a bit more. Yes, I've come from a windows background where I could have fixed this in minutes without having to find any long-named modules. I've seen comments like 'If you want an OS that runs like Windows, get Windows' but they are really unhelpful. Let's face it Linux/Ubuntu have to convert the Windows community which means making some of these things easier but without all the rubbish of Windows. I have no idea how to use the terminals or what a kernel is, and frankly, it's not what I want to know either. I'd like to see Ubuntu's phrase "just works" become a reality. It's an excellent OS that has to appeal to the general public.

Thanks for all the assistance............we've got music again!

Albert Damen (albrt) wrote :

Glad to hear your sound is working again.

Regarding the installation of the modules, that should normally be done automatically, if you have the package linux-386 installed. For some reason it seems you didn't have that installed in feisty, so the upgrade didn't know it should also install the new modules.
To prevent later problems I recommend you install linux-386 now.
As your sound is now working, I will close this bug.

Changed in linux-source-2.6.22:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers