Ubuntu 7.10 cannot mount iPod Shuffle

Bug #164238 reported by Clare So on 2007-11-21
4
Affects Status Importance Assigned to Milestone
linux-source-2.6.22 (Ubuntu)
Undecided
Unassigned

Bug Description

I have just upgraded to Ubuntu 7.10 from 7.04. My iPod Shuffle 2G was recognized without any problems by 7.04. Now 7.10 does not work with the same iPod. Upon connecting my iPod to my computer via USB, I pop up windows says, "Cannot mount volume". The details has

"mount::wrong fs type, bad option, bad superblock on /deb/sdb, missing codepage or helper program, or other error. In some cases useful info is found in syslog - try dmesg | tail or so".

The last bit of dmesg related to iPod is the following:

[ 832.960000] usb 4-2.5: new high speed USB device using ehci_hcd and address 17
[ 833.052000] usb 4-2.5: configuration #1 chosen from 2 choices
[ 833.056000] scsi4 : SCSI emulation for USB Mass Storage devices
[ 833.056000] usb-storage: device found at 17
[ 833.056000] usb-storage: waiting for device to settle before scanning
[ 838.056000] usb-storage: device scan complete
[ 838.056000] scsi 4:0:0:0: Direct-Access Apple iPod 2.70 PQ: 0 ANSI: 2
[ 838.060000] SCSI device sdb: 495616 2048-byte hdwr sectors (1015 MB)
[ 838.060000] sdb: Write Protect is off
[ 838.060000] sdb: Mode Sense: 64 00 00 08
[ 838.060000] sdb: assuming drive cache: write through
[ 838.060000] SCSI device sdb: 495616 2048-byte hdwr sectors (1015 MB)
[ 838.060000] sdb: Write Protect is off
[ 838.060000] sdb: Mode Sense: 64 00 00 08
[ 838.060000] sdb: assuming drive cache: write through
[ 838.060000] sdb: unknown partition table
[ 838.088000] sd 4:0:0:0: Attached scsi removable disk sdb
[ 838.088000] sd 4:0:0:0: Attached scsi generic sg2 type 0
[ 838.788000] FAT: Unrecognized mount option "usefree" or missing value

Any suggestions?

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in linux-source-2.6.22 .

I believe that this may be a duplicate of an existing bug report, bug 88746. Care to take a look and try to workaround mentioned there? Thanks.

This bug report is being closed because we received no reponse to the last inquiry for information. Please reopen it if this is still an issue in the current Ubuntu release. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Please don't hesitate to submit bug reports in the future, we really appreciate it. Thanks again!

Changed in linux-source-2.6.22:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers