partition disappeared after reboot from desktop, Places and computer

Bug #164175 reported by KiAnKo on 2007-11-20
6
Affects Status Importance Assigned to Milestone
linux-source-2.6.22 (Ubuntu)
Undecided
Unassigned

Bug Description

(This happend first in 7.04 at an older computer but now also at in 7.10 at a newer computer).

I had 2 windows partitions before installing 7.10 and before the first update installation I hade both C (SYSTEM) and D (DATA) at my DESKTOP, in PLACES and also in COMPUTER FILE BROWSER etc.

After the first update (about 70) and a restart, SYSTEM disappeared.

FSTAB:
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/sda6
UUID=213c4f3e-e6cc-4f0e-8b09-1f7b5e7ece06 / ext3 defaults,errors=remount-ro 0 1
# /dev/sda8
UUID=6f421a36-1420-4692-89c1-19386a7440a9 /home ext3 defaults 0 2
# /dev/sda1
UUID=E8207B40207B1532 /media/sda1 ntfs defaults,umask=007,gid=46 0 1
# /dev/sda5
UUID=28A496F9A496C8A8 /media/sda5 ntfs defaults,umask=007,gid=46 0 1
# /dev/sda7
UUID=9c26b88f-fdf0-4c2a-9761-e3adbd24bdfb none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec 0 0

I think it should be /sda1 but it's empty...

jtholmes (jtholmes) wrote :

thank you for your report

could you please run this command 'sudo blkid' (without the quotes) and attach the output here

stormzen (stormzen) wrote :

I'm going to jump in on this bug. I have an external hard-drive whose partitions show up on the desktop when I first log into my computer, but they disappear (seemingly) randomly. When they do disappear, they don't show up in mount, either.

This is the output from the command above:

[babydoll 21] ~ > sudo blkid
/dev/mapper/YOGI-YOGI_VAR: UUID="ae35b03c-bb7a-4960-84bd-189e5e8b3a97" SEC_TYPE="ext2" TYPE="ext3"
/dev/mapper/YOGI-YOGI_SWAP: TYPE="swap" UUID="dc67aa7c-a4eb-44db-861b-c968a04c7418"
/dev/mapper/YOGI-YOGI_ROOT: UUID="e9c10aa6-7e48-4ef3-ab01-98935beed3b7" SEC_TYPE="ext2" TYPE="ext3"
/dev/sda1: UUID="7255c72c-fb68-46f9-b969-f0c4da16e2f1" SEC_TYPE="ext2" TYPE="ext3"
/dev/sda2: LABEL="/" UUID="eaace60f-03f7-4f70-984e-08cb5979f5f0" SEC_TYPE="ext2" TYPE="ext3"
/dev/sda3: LABEL="/home" UUID="1a8f99fd-2ea7-46b0-bfc6-a130dd0ff93e" SEC_TYPE="ext2" TYPE="ext3"
/dev/sda5: TYPE="swap"
/dev/sdb1: UUID="c3cb7f98-8ec3-4b15-a5fd-9c74d2739588" SEC_TYPE="ext2" TYPE="ext3" LABEL="mp3-m"
/dev/sdb2: LABEL="mp3-ripped" UUID="18f007e4-5cdb-45ba-9124-718f5bcbf1fc" SEC_TYPE="ext2" TYPE="ext3"
/dev/sdb3: LABEL="mp3-a" UUID="11389f52-374e-4942-a1f1-c802ff24f2ef" SEC_TYPE="ext2" TYPE="ext3"
/dev/sdb4: LABEL="workspace" UUID="6dffd19a-1fde-42b2-99e5-9fac6d2b6696" SEC_TYPE="ext2" TYPE="ext3"

This is my /etc/fstab:

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/mapper/YOGI-YOGI_ROOT
UUID=e9c10aa6-7e48-4ef3-ab01-98935beed3b7 / ext3 defaults,errors=remount-ro 0 1
# /dev/sda1
UUID=7255c72c-fb68-46f9-b969-f0c4da16e2f1 /boot ext3 defaults 0 2
# /dev/sda3
UUID=1a8f99fd-2ea7-46b0-bfc6-a130dd0ff93e /home ext3 defaults 0 2
# /dev/mapper/YOGI-YOGI_VAR
UUID=ae35b03c-bb7a-4960-84bd-189e5e8b3a97 /var ext3 defaults 0 2
# /dev/mapper/YOGI-YOGI_SWAP
UUID=dc67aa7c-a4eb-44db-861b-c968a04c7418 none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec 0 0
/dev/scd1 /media/cdrom1 udf,iso9660 user,noauto,exec 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec 0 0

( I am using LVM for my system hard drives. )

There is one other factor:

All of the partitions that disappear are also shared through samba.

This time around, the first indication that something was wrong was that I couldn't see the shares in nautilus / browsing network:///. Then I realized that they were just gone, all around.

Since the information isn't written to fstab, I wasn't sure which mount points I needed to use to remount them. I got the shares back using sudo gnome-mount /dev/ (device listed in output, above)... but ended up with two icons for one of my volumes... still.. it was better than logging out.

Please let me know if you need additional information about this bug.

stormzen (stormzen) wrote :

Sorry. Didn't mention that I'm running Gutsy with all the updates (and a few backports, namely, amarok, and maybe a few others...) BTW, putting the partitions back on the desktop (remounting them) didn't solve my SMB / nautilus problem.

KiAnKo (kianko1975) wrote :
Download full text (4.1 KiB)

The shortcut is always displayed when I have the LIVE-CD) If I choose COMPUTER from PLACES I only get my DVD and SYSTEM... (see attached picture). I haven't changed anything in any system file...

Anyway...

kim@Ubuntu-BBB:~$ sudo blkid
/dev/sda1: UUID="E8207B40207B1532" LABEL="SYSTEM" TYPE="ntfs"
/dev/sda5: UUID="28A496F9A496C8A8" LABEL="DATA" TYPE="ntfs"
/dev/sda6: UUID="213c4f3e-e6cc-4f0e-8b09-1f7b5e7ece06" SEC_TYPE="ext2" TYPE="ext3"
/dev/sda7: TYPE="swap" UUID="9c26b88f-fdf0-4c2a-9761-e3adbd24bdfb"
/dev/sda8: UUID="6f421a36-1420-4692-89c1-19386a7440a9" SEC_TYPE="ext2" TYPE="ext3"

As "stormzen" I have also had problems with external HDD via USB...

> sudo fdisk -l

Disk /dev/sda: 120.0 GB, 120060444672 bytes
255 heads, 63 sectors/track, 14596 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x2fe02fdf

   Device Boot Start End Blocks Id System
/dev/sda1 * 1 1824 14651248+ 7 HPFS/NTFS
/dev/sda2 1825 14596 102591090 f W95 Ext'd (LBA)
/dev/sda5 3826 14596 86518026 7 HPFS/NTFS
/dev/sda6 1825 3040 9767457 83 Linux
/dev/sda7 3041 3095 441756 82 Linux swap / Solaris
/dev/sda8 3096 3825 5863693+ 83 Linux

(During the time since January 5, it has been work, but today it disappeared again. This was at my newer computer, about 5 years old (Pentium 4 CPU @ 2.40GHz, with 2GB RAM. BIOS from 2003.

I also have a 10 years old Packard Bell, Pentium 2 @ 450MHz, 376MB RAM (BIOS from 1998 (?)) with the same problem after upgrading to 7.10 - sometimes it seen and sometimes not. Before update I only saw it once... then it was gone. After 7.04 there is an error direct after startup saying that there is BIOS cut at the year 2000 shown on but I haven't noticed any other problems. )

kim@Ubuntu-PackardBell:~$ sudo blkid
/dev/sda1: UUID="a2f0da01-851a-430b-849e-7735c541813d" SEC_TYPE="ext2" TYPE="ext3"
/dev/sda2: UUID="3956-328D" TYPE="vfat"
/dev/sda5: TYPE="swap" UUID="b83294e4-0b7c-43a8-887c-d37cbef7bdc0"
/dev/sdb1: LABEL="DIANA_PHOTO" UUID="5486-BD60" TYPE="vfat"

(Today it worked when I tried "blkid" above.)

Below is the same output from the other computer (at this time the partions were seen!!!)

****************************************************************************

root@Ubuntu-PackardBell:~# sudo fdisk -l

Disk /dev/sda: 12.7 GB, 12749635584 bytes
255 heads, 63 sectors/track, 1550 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x000566ee

   Device Boot Start End Blocks Id System
/dev/sda1 1 1216 9767488+ 83 Linux
/dev/sda2 1217 1459 1951897+ b W95 FAT32
/dev/sda3 1460 1550 730957+ 5 Extended
/dev/sda5 1460 1550 730926 82 Linux swap / Solaris

Disk /dev/sdb: 10.2 GB, 10240274432 bytes
255 heads, 63 sectors/track, 1244 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x07d907d9

   Device Boot Start End Blocks Id System
/dev/sdb1 * 1 12...

Read more...

Ian Weisser (ian-weisser) wrote :

Is this issue still a bug?

Is it fixed, or did it vanish after an upgrade?

Ian Weisser (ian-weisser) wrote :

This bug report is being closed since we have had no response from the submitter. For future reference you can manage the status of your own bugs -including ropening bugs- by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status . Thank you again for taking the time to report this bug and helping to make Ubuntu better. Feel free to submit any future bugs you may find.

Changed in linux-source-2.6.22:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers