strange messages "ata3.00: exception Emask (HSM violation)"

Bug #163637 reported by Manuel López-Ibáñez on 2007-11-18
4
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
linux-source-2.6.22 (Ubuntu)
Undecided
Unassigned

Bug Description

Ubuntu is really slow booting and shutting down and I noticed the following strange messages in syslog:

[ 22.028000] ata3.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x2 frozen
[ 22.028000] ata3.00: cmd b0/d2:f1:00:4f:c2/00:00:00:00:00/00 tag 0 cdb 0x0 data 123392 in
[ 22.028000] res 50/00:f1:00:4f:c2/00:00:00:00:00/00 Emask 0x202 (HSM violation)
[ 22.028000] ata3: soft resetting port

uname -a
Linux localhost 2.6.20-16-generic #2 SMP Sun Sep 23 19:50:39 UTC 2007 i686 GNU/Linux

Device Model: FUJITSU MHV2080BH PL
ATA Version is: 7
ATA Standard is: ATA/ATAPI-7 T13 1532D revision 4a

David N. Welton (davidnwelton) wrote :

I had a bunch of these, but my disk actually died:

    [440525.460000] ata2.00: configured for UDMA/33
    [440525.460000] ata2: EH complete
    [440942.908000] ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x2 frozen
    [440942.908000] ata2.00: cmd a0/01:00:00:00:00/00:00:00:00:00/a0 tag 0 cdb 0x43 data 12 in
    [440942.908000] res 50/00:01:00:00:00/00:00:00:00:00/a0 Emask 0x2 (HSM violation)
    [440942.908000] ata2: soft resetting port

This is on an up-to-date Feisty system. I noticed because all of a sudden I couldn't write to the disk, and on fsck, it basically dumped everything and I lost everything (luckily, I have good backups). So... is this a problem with Ubuntu corrupting disks, or did my disk die?

David N. Welton (davidnwelton) wrote :

I looked around on what was left in lost+found, but there's really not much that I could salvage to get information. The disk is one of these:

Device: ATA ST980813AS Version: 3.AD
Serial number: 5NH0301G

Stefan Handschuh (handschuh) wrote :

This seems to be due to a bad AHCI/ATA-implementation of the countroller in your hdd. You may check out the NCQ-blacklist for more information on your harddrive.
Updating your kernel should solve this problem _some_ time.

Bernhard Schmidt (berni) wrote :

I hit this issue too,

ata1.00: exception Emask 0x2 SAct 0x4 SErr 0x0 action 0x2 frozen
ata1.00: (spurious completions during NCQ issue=0x0 SAct=0x4 FIS=004040a1:00000002)
ata1.00: cmd 61/08:10:a3:aa:49/00:00:07:00:00/40 tag 2 cdb 0x0 data 4096 out
         res 40/00:10:a3:aa:49/00:00:07:00:00/40 Emask 0x2 (HSM violation)
ata1: soft resetting port
ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
ata1.00: configured for UDMA/133
ata1: EH complete
sd 0:0:0:0: [sda] 312581808 512-byte hardware sectors (160042 MB)
sd 0:0:0:0: [sda] Write Protect is off
sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA

its a known bug with the ahci driver and fixed in the following commit to 2.6.22-stable

http://git.kernel.org/?p=linux/kernel/git/stable/linux-2.6.22.y.git;a=commit;h=2370eae7567e06b10f68ce293cb2a6b4f773b0c7

Applying this patch and recompiling the kernel fixed this issue for me

Model Family: Maxtor DiamondMax 10 family (SATA/300)
Firmware Version: VA111900

it doesn't apply cleanly because the Ubuntu developers have changed the blacklist already, but the driver part is okay.

Beginning with the Hardy Heron 8.04 development cycle, all open Ubuntu kernel bugs need to be reported against the "linux" kernel package. We are automatically migrating this bug to the new "linux" package. However, development has already began for the upcoming Intrepid Ibex 8.10 release. It would be helpful if you could test the upcoming release and verify if this is still an issue - http://www.ubuntu.com/testing . If the issue still exists, please update this report by changing the Status of the "linux" task from "Incomplete" to "New". We appreciate your patience and understanding as we make this transition. Thanks!

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Bernhard Schmidt (berni) wrote :

As linux-2.6.22 is marked "won't fix" and the AHCI fix is incorporated in the vanilla 2.6.24 it should be fixed for Hardy and Intrepid. I can't say that this way of totally ignoring bug reports makes me want report more bugs in the future.

Hi Bernhard,

Thanks for the note. In order for patches to qualify for a Stable Release Update they need to be confirmed as fixed in the current development release - https://wiki.ubuntu.com/StableReleaseUpdates . You mention this should be resolved for you at least with Hardy and Intrepid. If you could just do a quick test with say and Intrepid LiveCD just to confirm that would be great. Then we could open a Gutsy SRU nomination. Thanks.

Brad Figg (brad-figg) wrote :

This bug report is being closed because we received no response to the previous inquiry for information. Please reopen if this is still an issue in the current Ubuntu release, Jaunty Jackalope 9.04. To reopen the bug, click on the current status, under the Status column, and change the status back to "New". Thanks.

Changed in linux (Ubuntu):
status: Incomplete → Won't Fix
Boris Malkov (hori24) wrote :

The same behavior in Karmic with all updates. The HDDs are SAS ones on LSI MegaRAID 8300XLP controller.

Changed in linux (Ubuntu):
status: Won't Fix → New
Boris Malkov (hori24) wrote :

This part is repeating in the syslog every several minutes:

[425954.573268] ata1.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
[425954.573274] ata1.00: ST_FIRST: !(DRQ|ERR|DF)
[425954.573285] ata1.00: cmd a0/00:00:00:00:00/00:00:00:00:00/a0 tag 0
[425954.573286] cdb 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
[425954.573288] res 50/00:01:00:00:00/00:00:00:00:00/a0 Emask 0x2 (HSM violation)
[425954.573292] ata1.00: status: { DRDY }
[425954.573322] ata1: soft resetting link
[425954.822733] ata1.00: configured for UDMA/33
[425954.835217] ata1: EH complete

The machine freezes at that times.

PS acpi=off in the grup.

tags: added: kj-triage
Jeremy Foshee (jeremyfoshee) wrote :

Hi manu,

This bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux 163637

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
Changed in linux (Ubuntu):
status: New → Incomplete

AlsaDevices: Error: command ['ls', '-l', '/dev/snd/'] failed with exit code 2: ls: cannot access /dev/snd/: No such file or directory
AplayDevices: aplay: device_list:223: no soundcards found...
Architecture: amd64
ArecordDevices: arecord: device_list:223: no soundcards found...
DistroRelease: Ubuntu 9.10
MachineType: ASUS RS162-E4/RX4
NonfreeKernelModules: vboxnetflt vboxdrv
Package: linux (not installed)
PciMultimedia:

ProcCmdLine: root=UUID=5a33d8dd-54ee-4695-82cc-6116c02514fa ro quiet splash acpi=off hpet=disable
ProcEnviron:
 SHELL=/bin/bash
 LANG=ru_RU.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-20.58-server
Uname: Linux 2.6.31-20-server x86_64
UserGroups: adm admin audio backup cdrom dialout dip fax fuse lpadmin plugdev sambashare tape video
dmi.bios.date: 01/04/2007
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: 1003
dmi.board.name: DSBF-DR12/SAS
dmi.board.vendor: ASUS
dmi.board.version: 1.06G
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 1
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvr1003:bd01/04/2007:svnASUS:pnRS162-E4/RX4:pvr1.00:rvnASUS:rnDSBF-DR12/SAS:rvr1.06G:cvnChassisManufacture:ct1:cvrChassisVersion:
dmi.product.name: RS162-E4/RX4
dmi.product.version: 1.00
dmi.sys.vendor: ASUS

Changed in linux (Ubuntu):
status: Incomplete → New
tags: added: apport-collected
Boris Malkov (hori24) wrote :

^ I ran apport-collect -p linux 163637 with current configuration. Since it's the working server, I wasn't able to try a development version, but I'll try it next few days when I'll be free to shut it down.

Brad Figg (brad-figg) on 2011-05-04
Changed in linux (Ubuntu):
status: New → Confirmed
tags: added: b73a1py79

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers