no sound on rev3 MacBook (Santa Rosa)

Bug #162347 reported by cleentrax on 2007-11-13
36
Affects Status Importance Assigned to Milestone
Mactel Support
Undecided
Chris Irwin
linux (Ubuntu)
Undecided
Unassigned
linux-source-2.6.22 (Ubuntu)
Undecided
Unassigned

Bug Description

amd64 alternate 7.10 install on a rev3 MacBook (2.2 ghz). Sound preference module runs tests, but no sound comes through speakers.

Chris Irwin (chrisirwin) wrote :

At the bottom of the Macbook Pro Santa Rosa wiki entry, it is suggested to add "options snd_hda_intel model=mbp3" to "/etc/modprobe.d/options". I have done this on my rev3 Macbook, and it works as well.

Can you try this and post back?

https://wiki.ubuntu.com/MacBookPro/SantaRosa

cleentrax (cleentrax) wrote :

I have tried it does activate the sound.

But it is too low to really be useful. It also sounds as though the highs and lows are missing. I have adjusted various mixer items (master, front, pcm, etc.)

Chris Irwin (chrisirwin) wrote :

My sound works fine. I have linux-backports-modules-2.6.22-14-generic installed, which updates the alsa drivers. Perhaps this makes the difference?

Chris Irwin (chrisirwin) wrote :

Assigned to Ubuntu Kernel Team as it requires a module parameter adjustment

mabovo (mabovo) wrote :

I have the rev2 MacBook2.1 with Hardy amd64 with kernel 2.6.24-3 installed. When I start ekiga a missing audio plugin is required for the sound system function.
A bug report of this problem is related at https://bugs.edge.launchpad.net/ubuntu/+source/ekiga/+bug/181656.

levmyshkin (torrey-meeks) wrote :

Hi,

I have a MacBook 3.1, and I've been diligently following the Santa Rosa setup guide (https://help.ubuntu.com/community/MacBook_Santa_Rosa). I'm a Linux newbie, but I can navigate around in Terminal and edit files.

I gedited options in /etc/modprobe.d/options with the following string: options snd_hda_intel model=mbp3

Saved it, ctrl+alt+deleted, but when it came up, still no sound.

Any suggestions?

My options file looks like this:

# Enable double-buffering so gstreamer et. al. work
options quickcam compatible=2

# Default hostap to managed mode
options hostap_pci iw_mode=2
options hostap_cs iw_mode=2
options snd_hda_intel model=mbp3

Chris Irwin (chrisirwin) wrote :

levmyshkin, try updating the initrd:

update-initramfs -u

levmyshkin (torrey-meeks) wrote :

Hi Chris,

Thanks, that did the trick! Sound works like a charm now.

-Lev

(Thanks for all these notes and setup fixes you've made at the Ubuntu forums too. I wouldn't've been able to get it going without all this info and your contributions are huge.)

Chris Irwin (chrisirwin) on 2008-02-17
Changed in mactel-support:
assignee: nobody → chrisirwin
status: New → Confirmed
Robert Nasiadek (robzon) wrote :

I just booted Hardy Beta 64bit from a live cd and I still have this bug.
MacBook 3rd gen.

Pablo Martí (pmarti) wrote :

I have a MacBook 4th gen (if that exists) and I've got sound after adding the infamous lines to /etc/modprobe.d/options and updating the initrd. There's a glitch thou, the speakers wont work until I insert and extract a (TRS) jack in the headphones jack, bizarre...

Gar Bage (garbage) wrote :

Me too, no sound.
AMD64 and MBP Rev. 3.1

Frederik (frederik-debuck) wrote :

I have a MacBook 4th gen (4.1), and I've got sound working too after adding the line to /etc/modprobe.d/options and updating the initrd (note : I had to use "sudo" to update the initrd). Sound only came on after plugging and unplugging a headphone jack, as with Pablo Marti. Very strange...

David Cottrell (davidc-cfc) wrote :

Make sure the internal speaker is enabled. Open the Volume Control by right-click (if you can) on the speaker icon, go to the switches tab and enable the speaker switch. You may need to plug in a 2 button mouse to be able to right-click... or set up the 2-finger tap thing on the touchpad.

frankie (f-southern) wrote :

i'm running hardy amd64 on a santa rosa macbook 3.1 and i'm having this problem too...

obviously i've tried the above suggestions but with no luck.
 i'd also like to say i'm impressed with how well hardy is running, i was slightly apprehensive reading
https://help.ubuntu.com/community/MacBook_Santa_Rosa
as i'm a n00b, but so far, the sound has been my only problem, so, keep up the good work :D

Beginning with the Hardy Heron 8.04 development cycle, all open Ubuntu kernel bugs need to be reported against the "linux" kernel package. We are automatically migrating this bug to the new "linux" package. However, development has already began for the upcoming Intrepid Ibex 8.10 release. It would be helpful if you could test the upcoming release and verify if this is still an issue - http://www.ubuntu.com/testing . If the issue still exists, please update this report by changing the Status of the "linux" task from "Incomplete" to "New". We appreciate your patience and understanding as we make this transition. Thanks!

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Dennis Dirdjaja (dcd-ditsch) wrote :

Still valid in Intrepid. Using AMD64 and a MBP 3,1, sound worked on the Live CD. After installing, there was only a crackling sound when sound should be played. Applying the option mentioned above had no effect.

I reverted the sound settings to use OSS, because this was the only option to get a working sound, but the system sounds still produce the crackling noise. Maybe this is related to bug #244937

Please let me know if you need more information.

Changed in linux:
status: Incomplete → New

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

tayirvadai (tayirvadai-vikram) wrote :

i have a macbook pro 3,1 with Nvidia graphics card. i installed ubuntu 8.10. The sound was initially not coming and there were no option called speaker in the volume control. after applying the snd_hda_intel option it worked like a charm. of course i had to update initramfs. Thanks for the work around / fix.

tayirvadai (tayirvadai-vikram) wrote :

i just found a problem thought trivial, thought i would tell the great programming minds. i connected my headphones and the sound shifted to the head phone rather than the speaker. i tried to mute the sound using the mute key and when i unmuted it went to speakers even though my head phones were in the slot. i had to remove it and then put it back.!! any work around?

Hi cleentrax,

This bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux-image-`uname -r` 162347

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kernel-sound
tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete

Architecture: i386
DistroRelease: Ubuntu 9.04
HibernationDevice: RESUME=UUID=7f24d2a6-4789-4adf-8d83-9e64864b7f4f
MachineType: Apple Inc. MacBook4,1
NonfreeKernelModules: wl
Package: linux-image-2.6.28-15-generic 2.6.28-15.48
PackageArchitecture: i386
ProcCmdLine: root=UUID=e5900017-f09b-4566-8113-05a87461d1bd ro locale=pt_BR quiet
ProcEnviron:
 SHELL=/bin/bash
 LANG=pt_BR.UTF-8
 LANGUAGE=pt_BR:pt:en
ProcVersionSignature: Ubuntu 2.6.28-15.48-generic
Uname: Linux 2.6.28-15-generic i686
UserGroups:

mccpiloto (mcc-helipilot) wrote :
mccpiloto (mcc-helipilot) wrote :
mccpiloto (mcc-helipilot) wrote :
mccpiloto (mcc-helipilot) wrote :
mccpiloto (mcc-helipilot) wrote :
mccpiloto (mcc-helipilot) wrote :
mccpiloto (mcc-helipilot) wrote :
mccpiloto (mcc-helipilot) wrote :
mccpiloto (mcc-helipilot) wrote :

Hi mccpiloto,

Thanks for testing the latest Jaunty and running apport-collect. However, for the time being I think it would be best if you could open a new bug report (ubuntu-bug -p linux). The reason I say this is we have still yet to hear back from the original bug reporter and I see you have a slightly different system than the original bug reporter. Sound issues are usually hardware specific as well as codec specific. As such, it's helpful to the kernel team if bug reports target one specific issue against a specific set of hardware. We can easily mark bugs as duplicates later on if necessary. Thanks in advance.

Changed in linux (Ubuntu):
status: Incomplete → New
status: New → Incomplete
tags: added: needs-reporter-logs
removed: needs-kernel-logs
dino99 (9d9) wrote :

closing that old report, as it has not got recent comment.

Changed in linux (Ubuntu):
status: Incomplete → Invalid
Changed in mactel-support:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers