usbnet no longer working

Bug #162003 reported by gwi on 2007-11-11
20
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned
linux (Ubuntu)
Medium
Unassigned
linux-source-2.6.22 (Ubuntu)
Undecided
Unassigned

Bug Description

I have a Motorola A780, that I could telnet to from Ubuntu, using usbnet and cdc-acm modules.

When following the instructions on the OpenEZX wiki (http://wiki.openezx.org/Get_a_shell#Linux) I get the first two of the three expected lines of output, but the third line:

usb0: register usbnet at usb-0000:00:10.2-2, pseudo-MDLM (BLAN) device, 8e:36:06:d5:16:9d

does not appear.

If I then try to do:

ifconfig usb0 192.168.1.1 netmask 255.255.255.0 mtu 900

I get error messages saying usb0 does not exist.

If I switch the phone from USB modem to USB LAN mode, dmesg shows the following:

[ 2134.368000] usb 2-5: USB disconnect, address 6
[ 2135.044000] usb 2-5: new full speed USB device using ohci_hcd and address 7
[ 2135.264000] usb 2-5: configuration #1 chosen from 1 choice

Nothing on usbnet.

Other articles/postings indicate I should check the contents of /proc/bus/usb/devices, but that file isn't even there.

So: what's wrong here? It has worked before (before the upgrade to Gutsy that is...), so did the upgrade (or later the fresh Gutsy install) break something?

gwi (george-willegers) wrote :

Just tried it with the Feisty live cd.
usbnet is working with Feisty, it is no longer working with Gutsy.

In http://ubuntuforums.org/showthread.php?p=3714204 it is confirmed by another user that usbnet in Gutsy is broken.

Albert Damen (albrt) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Unfortunately we can't fix it, because your description does not yet have enough information.

Please include the following additional information, if you have not already done so (pay attention to lspci's additional options), as required by the Ubuntu Kernel Team:
1. Please include the output of the command "uname -a" in your next response. It should be one, long line of text which includes the exact kernel version you're running, as well as the CPU architecture.
2. Please run the command "dmesg > dmesg.log" after a fresh boot and attach the resulting file "dmesg.log" to this bug report.
3. Please run the command "sudo lspci -vvnn > lspci-vvnn.log" and attach the resulting file "lspci-vvnn.log" to this bug report.

For your reference, the full description of procedures for kernel-related bug reports is available at [WWW] http://wiki.ubuntu.com/KernelTeamBugPolicies. Thanks in advance!

gwi (george-willegers) wrote :

1. Output of uname -a:
Linux saturnus 2.6.22-14-generic #1 SMP Sun Oct 14 23:05:12 GMT 2007 i686 GNU/Linux

2. Output of dmesg: see attachment

gwi (george-willegers) wrote :
Albert Damen (albrt) wrote :

Thanks for this information. I have two more questions:

- please connect the Motorola A780 and attach the output of the command lsusb > lsusb.log
- with the A780 connected, please follow your steps to activate usbnet, then attach the file /var/log/syslog

gwi (george-willegers) wrote :
gwi (george-willegers) wrote :

Steps for connecting A780:
1. modprobe usbnet
2. modprobe cdc-acm
3. connect the phone in modem mode
4. on the phone switch to usblan mode
5. on the pc: ifconfig usb0 192.168.1.1 netmask 255.255.255.0 mtu 900
6. telnet 192.168.1.2

Thanks for looking into this problem.

panduro (panduro) wrote :

Hello
have you tried to compile the zaurus module?
i have the a1200 and for me it's working fine.
output dmesg:
[ 1552.024000] usb 1-1: new full speed USB device using uhci_hcd and address 3
[ 1552.192000] usb 1-1: configuration #1 chosen from 1 choice
[ 1552.808000] cdc_acm 1-1:1.0: ttyACM0: USB ACM device
[ 1552.812000] usbcore: registered new interface driver cdc_acm
[ 1552.816000] /ubuntu-gutsy/drivers/usb/class/cdc-acm.c: v0.25:USB Abstract Control Model driver for USB modems and ISDN adapters
[ 1766.992000] usb 1-1: USB disconnect, address 3
[ 1767.232000] usb 1-1: new full speed USB device using uhci_hcd and address 4
[ 1767.400000] usb 1-1: configuration #1 chosen from 1 choice
[ 1767.752000] usbcore: registered new interface driver cdc_ether
[ 1767.764000] usb0: register 'zaurus' at usb-0000:00:11.2-1, pseudo-MDLM (BLAN) device, 3a:08:30:59:7c:c3
[ 1767.768000] usbcore: registered new interface driver zaurus

bye

Albert Damen (albrt) on 2007-12-08
Changed in linux-source-2.6.22:
assignee: nobody → ubuntu-kernel-team
status: Incomplete → Confirmed
Phil Dibowitz (jaymzh) wrote :

I'm having the same problem - it looks like the zaurus usbnet subdriver is no longer included in current ubuntu kernels. There's no reason it should have been dropped from the list of modules to compile - its got the vast majority of the usefulness of the usbnet driver in it.

- Phil

The case is same for kernel 2.6.24-15-generic and distribution is Hardy

root@ravi-desktop:/home/ravi# uname -r
2.6.24-15-generic

I'm also using a780 and the behavior is exactly the same.

Logs attached

Ravindran K (ravindran-k) wrote :
Albert Damen (albrt) wrote :

Affects linux. Starting with hardy, kernel bugs are filed against linux, not against linux-source-<version>. See https://wiki.ubuntu.com/Bugs/FindRightPackage.

gwi (george-willegers) wrote :

Nice, how about fixing it?

Hi Guys,

I'm reassigning to the kernel team. Also please note that this report will remain open against the actively developed kernel but against 2.6.22 this will be closed as it does not qualify for a stable release update - https://wiki.ubuntu.com/StableReleaseUpdates . Thanks.

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: New → Triaged
Changed in linux-source-2.6.22:
status: Confirmed → Won't Fix
Ravindran K (ravindran-k) wrote :

Hi.. any update on this..

Lot of ppl (Motorola A780/e680i users) are affected because of this but are unable to determine the cause.
I'm afraid they will be moving to other distributions if this is not fixed.

Ravindran K (ravindran-k) wrote :

Also, Motorola A1200 users are affected.

Ravindran K (ravindran-k) wrote :

Greetings..

Meanwhile, please try the workaround suggested by hitmansoft here http://www.motorolafans.com/forums/showthread.php?t=12984

Same steps below:

1. Install kernel sources

Code:

sudo apt-get install linux-source

2. Extract the archive (x.x.x is your version of kernel)

Code:

tar xf /usr/src/linux-source-x.x.x.tar.bz2

3. Configure the kernel
Code:

cd linux-source-x.x.x

make gconfig

The configuration window should open.

4. Select "device drivers->network device support->USB network adapters->Multi-purpose USB Networking Framework->Sharp Zaurus (stock ROMs) and compatible" and set the value to 'M' (by double-clicking)

5. Save and exit

6. Compile the module

Code:

make drivers/net/usb/zaurus.ko

7. Install the driver

Code:

sudo cp drivers/net/usb/zaurus.ko /lib/modules/<your kernel version>/kernel/drivers/net/usb/

sudo depmod -a

8. Load the module

Code:

modprobe zaurus

You may have to switch to USBNET mode and check..

Ravindran K (ravindran-k) wrote :

Do we have update on this?

Beginning with the Hardy Heron 8.04 development cycle the kernel source package naming convention changed from "linux-source-2.6.xx" to just "linux". Going forward, kernel bugs should now be reported against the "linux" package. As a result, I'm removing the 'linux-source-2.6.24' task as this bug is already correctly reported against the 'linux' package. Thanks.

Changed in linux-source-2.6.24:
status: New → Invalid

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Ravindran K (ravindran-k) wrote :

WOW!

Even this is working!!!! in latest.. Please close it :)))

root@ravi-desktop:/home/ravi# uname -a
Linux ravi-desktop 2.6.27-1-server #1 SMP Sun Aug 24 00:04:57 UTC 2008 i686 GNU/Linux

[79455.245454] cdc_acm 7-1:1.0: ttyACM0: USB ACM device
[79464.875811] usb 7-1: reset full speed USB device using uhci_hcd and address 10
[79465.018923] usb 7-1: device firmware changed
[79465.018923] cdc_acm 7-1:1.0: ttyACM0: USB ACM device
[79465.018953] usb 7-1: USB disconnect, address 10
[79465.130022] usb 7-1: new full speed USB device using uhci_hcd and address 11
[79465.321277] usb 7-1: configuration #1 chosen from 1 choice
[79465.450275] usbcore: registered new interface driver cdc_ether
[79465.456994] usb0: register 'zaurus' at usb-0000:00:1d.2-1, pseudo-MDLM (BLAN) device, b6:59:a3:69:a4:f2
[79465.457008] usbcore: registered new interface driver zaurus
[79467.849070] NET: Registered protocol family 17
root@ravi-desktop:/home/ravi# ifconfig -a
eth0 Link encap:Ethernet HWaddr 00:19:d1:a8:73:fa
          inet addr:192.168.100.99 Bcast:192.168.100.255 Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:2404375 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2752461 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          RX bytes:1656213445 (1.5 GB) TX bytes:2866118517 (2.6 GB)

lo Link encap:Local Loopback
          inet addr:127.0.0.1 Mask:255.0.0.0
          UP LOOPBACK RUNNING MTU:16436 Metric:1
          RX packets:99937 errors:0 dropped:0 overruns:0 frame:0
          TX packets:99937 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:21299413 (20.3 MB) TX bytes:21299413 (20.3 MB)

usb0 Link encap:Ethernet HWaddr b6:59:a3:69:a4:f2
          UP BROADCAST RUNNING MULTICAST MTU:1494 Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B) TX bytes:1822 (1.7 KB)

Ravindran K (ravindran-k) wrote :

Works in 2.6.27-1-server!

Daniel Swarbrick (pressureman) wrote :

Still no luck with an iPaq 2210.

[ 643.140056] usb 3-2: new full speed USB device using uhci_hcd and address 2
[ 643.341554] usb 3-2: configuration #1 chosen from 1 choice
[ 643.480600] usbcore: registered new interface driver usbserial
[ 643.481881] usbserial: USB Serial support registered for generic
[ 643.482755] usbcore: registered new interface driver usbserial_generic
[ 643.482761] usbserial: USB Serial Driver core
[ 643.495434] usbserial: USB Serial support registered for PocketPC PDA
[ 643.495441] ipaq: USB PocketPC PDA driver v0.5
[ 643.497219] ipaq 3-2:1.0: PocketPC PDA converter detected
[ 643.500510] usb 3-2: PocketPC PDA converter now attached to ttyUSB0
[ 643.501523] usbcore: registered new interface driver ipaq

That's it... no usb0 interface shows up.

gwi, since you are the original bug reporter, can you confirm if this is resolved for you? It seems we have conflicting feedback. Thanks.

Changed in linux:
status: Triaged → Incomplete
gwi (george-willegers) wrote :

I will give it a try Thursday.

gwi (george-willegers) wrote :

I tried installing 8.10a5 in a VirtualBox 2.0.2 VM. That went ok (VM boots), up to where I had to install the guest additions, to enable USB in the VM.
Then I tried the same in a VMware Server 1.0.7 VM. That also went ok (VM boots), but installing the VMware Tools failed.
I then burned the iso on a disk and booted my physical system from it. After selecting the option to try ubuntu from the cd, I ended up in a Busybox prompt.
Later this week I will give the VM's another try.
Can anyone give me some hints why the Busybox prompt appears?

it looks like it is working here too for my Motorola Ming A1200

$ uname -a
Linux gourgi 2.6.27-3-generic #1 SMP Wed Sep 10 16:18:52 UTC 2008 x86_64 GNU/Linux

Sep 15 06:42:23 gourgi kernel: [ 7232.084030] usb 1-10: new full speed USB device using ohci_hcd and address 6
Sep 15 06:42:24 gourgi kernel: [ 7232.306260] usb 1-10: configuration #1 chosen from 1 choice
Sep 15 06:42:24 gourgi kernel: [ 7232.325538] usb0: register 'zaurus' at usb-0000:00:02.0-10, pseudo-MDLM (BLAN) device, 26:d2:5c:e5:38:b9

$ ifconfig

usb0 Link encap:Ethernet HWaddr 26:d2:5c:e5:38:b9
              inet6 addr: fe80::24d2:5cff:fee5:38b9/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST MTU:1494 Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:10 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:0 (0.0 B) TX bytes:1876 (1.8 KB)

gwi (george-willegers) wrote :

Almost working here (booted the live cd with the parameter all_generic_ide).
I get to the point where I have to start telnet, and it does not get a connection.
usb0 is configured with the address 192.168.1.1, the UsbMode application on the A780 is in USBLAN mode, and reports "Connected IP: 192.168.1.2".
Any ideas?

gwi (george-willegers) wrote :

Sorry for the delay, but finally I can report usbnet is working with my Motorola A780.
(Still booting the livecd with all_generic_ide, no idea what went wrong last time.)

Changed in linux:
status: Incomplete → Fix Released

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers