Random complete lockups related to bad page states

Bug #160753 reported by Marten Klencke on 2007-11-07
6
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
linux-source-2.6.22 (Ubuntu)
Undecided
Unassigned

Bug Description

I installed Gutsy cleanly from CD and did not do any updates. The whole process so far worked perfectly.

Then, upon reboot, the system hangs randomly (complete lockups, mouse doesn't move, ping to the machine does not respond). I've tried it a few times and it always occurs a few minutes after login (but randomly). A look at the system logs revealed that just before having to power off the machine, some errors regarding bad page states were reported. A few of these occured in trackerd (which may explain that it happens a few minutes after login), but not all.

Do you have any idea what's causing this? The whole install sequence worked fine and I did a memcheck which did not reveal any faults. Please see the 'Bad page state in process' messages in the attached files.

Thanks.

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in linux-source-2.6.22

The Hardy Heron kernel was recently uploaded for testing. We'd really appreciate it if you could try testing with this newer kernel and verify if this issue still exists. Unfortunately, the Hardy Heron Alpha1 LiveCD was released with the older 2.6.22 kernel. You'll have to manually install the newer Hardy Heron kernel in order to test. This should not be the case for Alpha2. However, here are the instructions to install (if you choose to do so):

1) edit the file /etc/apt/sources.list and add the following line:

deb http://archive.ubuntu.com/ubuntu hardy main restricted

2) sudo apt-get update
3) sudo apt-get install linux-image-2.6.24-1-generic
4) reboot and select the new kernel from the grub menu

After you've tested, please feel free to revert back - ie boot into the old kernel, sudo apt-get remove linux-image-2.6.24-1-generic, and remove the line from /etc/apt/sources.list . Please update this report with your results. Thanks in advance!

Changed in linux:
importance: Undecided → Medium
status: New → Incomplete

Hardy Heron Alpha2 was recently released. It contains an updated version of the kernel. You can download and try the new Hardy Heron Alpha2 release from http://cdimage.ubuntu.com/releases/hardy/alpha-2/ . You should be able to then test the new kernel via the LiveCD. If you can, please verify if this bug still exists or not and report back your results. General information regarding the release can also be found here: http://www.ubuntu.com/testing/hardy/alpha2 . Thanks!

Marten Klencke (mklencke) wrote :

I will try to do this asap. I don't currently have access to the computer in question, but will in a few days.

I've opened a new task against the actively developed kernel and am closing the task against linux-source-2.6.22. Thanks!

Changed in linux-source-2.6.22:
status: New → Won't Fix
Marten Klencke (mklencke) wrote :

I upgraded the affected machine to Hardy Heron alpha 5 and re-enabled tracker (I completely removed tracker from the gutsy system and didn't encounter the problem anymore)

I used the system with the 2.4.24 kernel. Unfortunately, the problem persists and kicks in a few moments after trackerd starts indexing: a complete lockup of the system. However, this time without any clues. There are no messages anymore in /var/log/messages or /var/log/syslog regarding the crash.

I played around a bit more and found that tracker was set up to index a directory onto which a vfat partition is mounted (/media/shared) After removing this directory from the list of directories to watch, indexing seems to complete without any system crashes.

Following up on this, I tried some extensive file copying from the vfat partition to my home directory. This also resulted in a system crash! So it seems that somehow reading from this partition causes the system to crash...

Let me know if there is any more information you need.

Hi Marten,

Just wanted to give you a quick update. At a recent Ubuntu Technical Board meeting two technical decisions were taken with regard to the Ubuntu 8.04 release. One of the decisions relates to this bug:

 * Automatic indexing in tracker will be disabled for Ubuntu 8.04. While we
   value the functionality provided by tracker and intend to continue to
   support its rapid development by including it by default in Ubuntu, the
   side effects of automatic indexing have a significant impact on users
   regardless of whether they make use of tracker's search features.
   Instead, users who desire this functionality can turn on indexing by
   changing their preference settings.

I'm going to retarget this bug for the Intrepid Ibex 8.10 release. Thanks.

Changed in linux:
importance: Medium → Undecided
milestone: none → later
status: Incomplete → Confirmed
Dana Goyette (danagoyette) wrote :

I have also been experiencing random hard lockups, usually when either playing music, or seeding torrents, from my ntfs (-3g) partition. Oddly enough, it only ever seems to happen when I'm also using (nvidia binary) 3D functionality, including the simple rss-glx 'flux' screensaver. However, I'm not sure if the cause is the same.
I'd call it rather important to address this bug, since it seems to trigger very easily even with Tracker disabled.

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Marten Klencke (mklencke) wrote :

Using grep, I did some extensive reading on the vfat and ntfs partitions using 8.10 beta and I could not produce the lockups anymore.

Because of the comment on 2008-03-24, It may also be noteworthy that recently the ATi graphics adapter was replaced by an nVidia card and the system is now using the nVidia binary drivers.

Hi Marten,

Since you are the original bug reporter, I'm going to mark this bug Fix Released for Intrepid based on your last comment. Thanks.

Changed in linux:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers