7.10 Gutsy does not load up without noapic boot command

Bug #160718 reported by rsinghone on 2007-11-07
8
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
linux-source-2.6.22 (Ubuntu)
Undecided
Unassigned

Bug Description

Running HP Laptop dv6258se AMD Turion 64 x2, 1.8GHz, 2GB RAM Installed with Ubuntu Gutsy Gibbon 7.10. The upgrade from 7.04 failed causing irreversable damage to the install. A fresh install attempt of Ubuntu 7.10 resulted in the Live CD hanging on boot up with no response from keyboard to perform soft-reboot. Had to hard reboot. However the Live CD for 7.04 does work as long as you specify the VGA mode to be 1024x768. Tried specifying the VGA mode to 1024x768 for the 7.10 Live CD, resulting in the same problem, total system hang with blank black screen. Tried to boot up 7.10 Live CD using NOAPIC which actually works without having to specify the VGA settings.

A secondary problem was experienced during the installation I found the install process crashed consistently. Subsequently the system seemed unstable with various apps crashing. Found the problem to be attributed to something quirky in the disk partitioning and formating Install Step which would continually freeze and not finish the partition/format to show as complete. After manually partitioning the HDD and formatting it (despite again the program not reporting completion but leaving it for a few hours assuming it would have finished then terminating the app), then running the install program it seemed to continue through as normal.

After successful installation of 7.10 we have to continue using NOAPIC on bootup. However this means no USB memory sticks can be plugged in to be used. Makes the machine kinda useless. Solving this primary problem of NOAPIC during bootup would at least enable us to use this PC to it's basic degree. Many other HP users are also experiencing this problem. I am happy to assist in any testing to improve 7.10. New to Ubuntu.

Regards,
Raj

ProblemType: Bug
Architecture: amd64
Date: Wed Nov 7 12:28:20 2007
DistroRelease: Ubuntu 7.10
NonfreeKernelModules: nvidia
Package: hal 0.5.9.1-6ubuntu5
PackageArchitecture: amd64
SourcePackage: hal
Uname: Linux raj-laptop 2.6.22-14-generic #1 SMP Sun Oct 14 21:45:15 GMT 2007 x86_64 GNU/Linux

rsinghone (raj-singh) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in linux-source-2.6.22

The Hardy Heron kernel was recently uploaded for testing. We'd really appreciate it if you could try testing with this newer kernel and verify if this issue still exists. Unfortunately, the Hardy Heron Alpha1 LiveCD was released with the older 2.6.22 kernel. You'll have to manually install the newer Hardy Heron kernel in order to test. This should not be the case for Alpha2. However, here are the instructions to install (if you choose to do so):

1) edit the file /etc/apt/sources.list and add the following line:

deb http://archive.ubuntu.com/ubuntu hardy main restricted

2) sudo apt-get update
3) sudo apt-get install linux-image-2.6.24-1-generic
4) reboot and select the new kernel from the grub menu

After you've tested, please feel free to revert back - ie boot into the old kernel, sudo apt-get remove linux-image-2.6.24-1-generic, and remove the line from /etc/apt/sources.list . Please update this report with your results. Thanks in advance!

Changed in linux:
importance: Undecided → Medium
status: New → Incomplete

Leann,

Thanks, I will give this a go on the HP Pavillion dv6258se Laptop (AMD64 x2) and provide feedback. I have a number of colleagues with this laptop series (dv6000) who are unable to use 710 Gutsy Gibbon. It'll take me a week or so as I have to perform a 710 re-install as it had frozen, (as it frequently does on 710), during a system update. After this particular freeze up, 710 was not recoverable, requiring a rebuild.

There seems no "Repair" facility on the live CD, just "Install" only is readily available. This means you lose your entire setup every time you do a re-install if the system fails. (704 was actually stable and booted fine once you solved the video incompatibility issue - Nvidia restricted driver).

Anyway, will give it a go per your instructions below and provide feedback.

Warm regards,
Raj Dhillon

-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>]On Behalf Of
Leann Ogasawara
Sent: 05 December 2007 17:28
To: Dhillon, Raj [CCC-OT_IT]
Subject: [Bug 160718] Re: 7.10 Gutsy does not load up without noapic
bootcommand

The Hardy Heron kernel was recently uploaded for testing. We'd really
appreciate it if you could try testing with this newer kernel and verify
if this issue still exists. Unfortunately, the Hardy Heron Alpha1
LiveCD was released with the older 2.6.22 kernel. You'll have to
manually install the newer Hardy Heron kernel in order to test. This
should not be the case for Alpha2. However, here are the instructions
to install (if you choose to do so):

1) edit the file /etc/apt/sources.list and add the following line:

deb http://archive.ubuntu.com/ubuntu hardy main restricted

2) sudo apt-get update
3) sudo apt-get install linux-image-2.6.24-1-generic
4) reboot and select the new kernel from the grub menu

After you've tested, please feel free to revert back - ie boot into the
old kernel, sudo apt-get remove linux-image-2.6.24-1-generic, and remove
the line from /etc/apt/sources.list . Please update this report with
your results. Thanks in advance!

** Changed in: linux (Ubuntu)
   Importance: Undecided => Medium
       Status: New => Incomplete

--
7.10 Gutsy does not load up without noapic boot command
https://bugs.launchpad.net/bugs/160718
You received this bug notification because you are a direct subscriber
of the bug.

Changed in linux-source-2.6.22:
status: New → Incomplete
alej (alejandro-avila) wrote :

Leann,

I-m glad to have read your post (here and in other threads). I've been trying to boot without the noapic option for the past 9 months, and was convinced that it had something to do with the kernel version 2.6.22 . This is my first post here, I'm no expert but I'll try to be concise.

I've been partially successful in booting without the noapic option using the newer kernel 2.6.24

My system is a rare HP dv9343eu (Basically an AMD Turion X2 Broadcomm 4312 wireless card (as detected by linux))

While on Feisty or Gutsy (using 2.6.22) I had to specify noapic noirqdebug in order to get a somewhat stable system. That is the combination that best worked for me, because it booted and gave me USB support [although I don't really know whether it was USB 2.0]

Anyhow, I followed your tip and adventured myself into upgrading the kernel manually to linux-image-2.6.24-3-generic (instead of linux-image-2.6.24-1-generic you suggested). At fisrt that made no difference for me, so I decided to make sure and proceeded to install Hardy through a " update-manager -d". I must point out that before proceeding I had uninstalled bcm43xx-fwcutter and the bcm43xx firmware from the restricted firmware manager.

When I rebooted I was glad to see that even though it took considerably a longer time (precisely there was a very long idle time when loading Hardware drivers) it managed to boot up fine!.

I got a message telling me that my wlan card (detected this time as a Bcm4311) was not properly configured and that I needed to install the v.4 firmware for the b43 cards. So I went ahead and did that. First using the Restricted Manager (which installed a non-working bcm43xx-fwcutter) and then manually installing the b43-fwcutter which correctly enabled my wlan and even allowed me join a wireless network without needing ndiswrapper, wcid, etc...

Problem is that when I rebooted the comp, it once again refused to boot properly.

In Conclusion:

I am finally able to boot withouth noapic using 2.6.24 if I don't have any firmware installed for my wireless card. Other things such as suspend/resume/etc still don't work. I still have to try USB, and CPU Freq seems fine....

Please let me know how I could provide you guys with more ideal information. I so want this to work that I am keen on trying whatever it takes to fix it..

Regards,

alej

Hi Alej,

Thanks for testing and the update. I'll first want to give you a quick update that you can now test the newer 2.6.24 kernels via the Hardy Alpha LiveCD's. That way you don't have to manually update the kernel by hand. It was only for the Hardy Alpha1 release where this wasn't the case as Alpha1 went out with an older kernel version. But Alpha2 and subsequent releases have come with the newer kernels. If you can, will you please test booting with the most recent Hardy Alpha LiveCD and verify you are able to boot? I'll then close this bug if your testing is successful.

So regarding the remaining issues you're experiencing with the Hardy Alpha kernel, if you could actually open separate bug reports for each issue that would be great. It's helpful to the development teams if bug reports target a specific issue against a specific set of hardware. In those reports please include the information outlined at: https://wiki.ubuntu.com/KernelTeamBugPolicies . Also please be sure to attach each file as a separate attachment.

Let me know if you have any more questions. Thanks!

alej (alejandro-avila) wrote :
Download full text (3.4 KiB)

Hello Leann,

First and foremost, thanks for your help and interest. Since the last time I've written I've kept on upgrading here and there. Following the instructions indicated in the link you pointed out, I herein summarize all the relevant info, especially regarding the wireless (which I believe to be the partly the source of our noapic problem) and therefafter proceed to attach it as recommended.

uname -a > uname-a.log :
Linux alekubuntu 2.6.24-5-generic #1 SMP Thu Jan 24 19:29:14 UTC 2008 x86_64 GNU/Linux

cat /proc/version_signature > version.log :
Ubuntu 2.6.24-5.8-generic

sudo lspci -vvnn > lspci-vvnn.log (wireless card section):

03:00.0 Network controller [0280]: Broadcom Corporation BCM4312 802.11a/b/g [14e4:4312] (rev 01)
 Subsystem: Hewlett-Packard Company Unknown device [103c:1361]
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B-
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
 Latency: 0, Cache Line Size: 64 bytes
 Interrupt: pin A routed to IRQ 19
 Region 0: Memory at c4000000 (32-bit, non-prefetchable) [size=16K]
 Capabilities: [40] Power Management version 2
  Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=375mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
  Status: D0 PME-Enable- DSel=0 DScale=2 PME-
 Capabilities: [58] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable-
  Address: 00000000 Data: 0000
 Capabilities: [d0] Express Legacy Endpoint IRQ 0
  Device: Supported: MaxPayload 128 bytes, PhantFunc 0, ExtTag+
  Device: Latency L0s <4us, L1 unlimited
  Device: AtnBtn- AtnInd- PwrInd-
  Device: Errors: Correctable- Non-Fatal- Fatal- Unsupported-
  Device: RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop-
  Device: MaxPayload 128 bytes, MaxReadReq 128 bytes
  Link: Supported Speed 2.5Gb/s, Width x1, ASPM L0s, Port 0
  Link: Latency L0s <4us, L1 <64us
  Link: ASPM Disabled RCB 64 bytes CommClk- ExtSynch-
  Link: Speed 2.5Gb/s, Width x1

dmesg > dmesg.log :
[ 0.000000] Command line: root=UUID=84c70404-b16e-4f22-b824-38b775014fda ro

I would just like to point out tha I still needed to boot with the noapic option until I properly installed the b43 driver for my card following the indications at

http://linuxwireless.org/en/users/Drivers/b43#firmwareinstallation

Precisely for my card I used:
1. Firmware version 4.80.53.0 at http://downloads.openwrt.org/sources/broadcom-wl-4.80.53.0.tar.bz2 since I believe I am using the 2.6.24(-rc) (or earlier - but not the compat package)
2. I untared it,
3. I downloaded the b43-fwcutter version for 2.6.24(-rc) (or earlier - but not the compat package) from http://bu3sch.de/b43/fwcutter/b43-fwcutter-009.tar.bz2
4. I untared it and installed it (make & sudo make install)
5. I installed the previously untared firmware by cding to the /broadcom-wl-4.80.53.0/kmod directoring and typing the following command
sudo b43-fwcutter -w /lib/firmware /wl_apsta_mimo.o

I still have a feeling that I get inconsistent boot success.. Whenever I upgrade anything and I after I reboot my computer it crashes at "Loading Hardware Drivers" I usually end up rebooting, editing the boot command by adding noapic noirqdebug and then ...

Read more...

alej (alejandro-avila) wrote :
alej (alejandro-avila) wrote :
alej (alejandro-avila) wrote :
Changed in linux:
assignee: nobody → ubuntu-kernel-team
status: Incomplete → Triaged
Connor Imes (ckimes) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with latest Ubuntu release? Thanks in advance.

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Connor Imes (ckimes) wrote :

I closed this bug against the old linux-source package. Can you please let us know if this problem still exists in Intrepid? Thank you in advance.

Changed in linux-source-2.6.22:
status: Incomplete → Won't Fix
Changed in linux:
status: Triaged → Incomplete

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

Connor Imes (ckimes) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in linux:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers