Xorg crashes unexpectedly (amd64, gutsy, compiz)

Bug #160688 reported by Stefano Marinelli on 2007-11-07
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
linux-source-2.6.22 (Ubuntu)
Undecided
Unassigned

Bug Description

Using the Ubuntu Gutsy amd64 version (on a single core Athlon64 3000+), an ati radeon 9200 (128MB) (using the opensource driver) and an Asus k8v-x motherboard during last days I've experienced more than one crash: the Xserver freezes and in seconds restarts, bringing me back to GDM screen.
Syslog reports this issue:

[ 1323.558390] Unable to handle kernel paging request at ffffffffffffffff RIP:
[ 1323.558397] [<ffffffffffffffff>]
[ 1323.558404] PGD 203067 PUD 100c067 PMD 0
[ 1323.558408] Oops: 0010 [1] SMP
[ 1323.558411] CPU 0
[ 1323.558413] Modules linked in: snd_rtctimer tun binfmt_misc radeon drm rfcomm l2cap bluetooth af_packet xt_tcpudp xt_length ipt_ttl xt_tcpmss xt_TCPMSS iptable_mangle iptable_filter xt_multiport xt_limit ipt_tos ipt_REJECT ip_tables x_tables vboxdrv ppdev powernow_k8 cpufreq_stats cpufreq_powersave cpufreq_ondemand freq_table cpufreq_userspace cpufreq_conservative video ac dock sbs button container battery sbp2 lp loop ipv6 snd_via82xx gameport snd_pcm_oss snd_via82xx_modem snd_ac97_codec snd_mixer_oss ac97_bus snd_seq_dummy snd_seq_oss usbhid snd_pcm snd_mpu401_uart hid snd_seq_midi snd_seq_midi_event acx psmouse snd_rawmidi snd_seq snd_timer snd_seq_device pcspkr parport_pc parport k8temp serio_raw i2c_viapro snd soundcore snd_page_alloc i2c_core shpchp pci_hotplug evdev ext3 jbd mbcache ide_cd cdrom ide_disk via82cxxx ide_core ehci_hcd uhci_hcd usbcore ata_generic sata_via libata scsi_mod ohci1394 ieee1394 skge thermal processor fan fuse apparmor commoncap
[ 1323.558453] Pid: 5293, comm: Xorg Not tainted 2.6.22-14-generic #1
[ 1323.558456] RIP: 0010:[<ffffffffffffffff>] [<ffffffffffffffff>]
[ 1323.558460] RSP: 0018:ffff810044517ed0 EFLAGS: 00010286
[ 1323.558464] RAX: ffffffff88581da0 RBX: ffff810045ff2d00 RCX: ffffffffffffffff
[ 1323.558468] RDX: 00007fff7794c200 RSI: 00000000c0406429 RDI: ffff810045ff2d00
[ 1323.558471] RBP: 00007fff7794c200 R08: 0000000003b15e20 R09: 00000000ec2aa000
[ 1323.558475] R10: ffece8e4ffeeeae7 R11: 0000000000003246 R12: 00007fff7794c200
[ 1323.558478] R13: 00000000c0406429 R14: 00000000c0406429 R15: 0000000001174f10
[ 1323.558482] FS: 00002b0234877e20(0000) GS:ffffffff80560000(0000) knlGS:00000000f74976c0
[ 1323.558484] CS: 0010 DS: 0000 ES: 0000 CR0: 000000008005003b
[ 1323.558488] CR2: ffffffffffffffff CR3: 0000000044458000 CR4: 00000000000006e0
[ 1323.558491] Process Xorg (pid: 5293, threadinfo ffff810044516000, task ffff8100444ef4a0)
[ 1323.558493] Stack: ffffffff802a6e05 000000000413c984 ffff810045ff2d00 00007fff7794c200
[ 1323.558499] 0000000000000008 0000000000000008 ffffffff802a6f24 0000000000a72730
[ 1323.558504] ffff8100010141e8 0000000000000000 ffff810045ff2d00 00007fff7794c200
[ 1323.558507] Call Trace:
[ 1323.558513] [<ffffffff802a6e05>] do_ioctl+0x35/0xe0
[ 1323.558520] [<ffffffff802a6f24>] vfs_ioctl+0x74/0x2d0
[ 1323.558528] [<ffffffff802a7215>] sys_ioctl+0x95/0xb0
[ 1323.558536] [<ffffffff80209e8e>] system_call+0x7e/0x83
[ 1323.558547]
[ 1323.558548]
[ 1323.558549] Code: Bad RIP value.
[ 1323.558552] RIP [<ffffffffffffffff>]
[ 1323.558555] RSP <ffff810044517ed0>
[ 1323.558558] CR2: ffffffffffffffff
[ 1325.690437] agpgart: Found an AGP 3.5 compliant device at 0000:00:00.0.
[ 1325.690518] agpgart: Putting AGP V3 device at 0000:00:00.0 into 8x mode
[ 1325.690616] agpgart: Putting AGP V3 device at 0000:01:00.0 into 8x mode
[ 1325.883588] [drm] Setting GART location based on new memory map
[ 1325.883595] [drm] Loading R200 Microcode
[ 1325.883630] [drm] writeback test succeeded in 1 usecs

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in linux-source-2.6.22.

The Hardy Heron kernel was recently uploaded for testing. We'd really appreciate it if you could try testing with this newer kernel and verify if this issue still exists. Unfortunately, the Hardy Heron Alpha1 LiveCD was released with the older 2.6.22 kernel. You'll have to manually install the newer Hardy Heron kernel in order to test. This should not be the case for Alpha2. However, here are the instructions to install (if you choose to do so):

1) edit the file /etc/apt/sources.list and add the following line:

deb http://archive.ubuntu.com/ubuntu hardy main restricted

2) sudo apt-get update
3) sudo apt-get install linux-image-2.6.24-1-generic
4) reboot and select the new kernel from the grub menu

After you've tested, please feel free to revert back - ie boot into the old kernel, sudo apt-get remove linux-image-2.6.24-1-generic, and remove the line from /etc/apt/sources.list . Please update this report with your results. Thanks in advance!

Changed in linux:
importance: Undecided → Medium
status: New → Incomplete

Thank you for answering!
I must say that after the last kernel upgrade (2.6.22-14-generic) the
problem *seems* to have disappeared. I'll upgrade the bug report as soon
as possible.
Anyway, I'm going to try the .24 and see what happens.
Thank you!
Stefano

Leann Ogasawara ha scritto:
> The Hardy Heron kernel was recently uploaded for testing. We'd really
> appreciate it if you could try testing with this newer kernel and verify
> if this issue still exists. Unfortunately, the Hardy Heron Alpha1
> LiveCD was released with the older 2.6.22 kernel. You'll have to
> manually install the newer Hardy Heron kernel in order to test. This
> should not be the case for Alpha2. However, here are the instructions
> to install (if you choose to do so):
>
> 1) edit the file /etc/apt/sources.list and add the following line:
>
> deb http://archive.ubuntu.com/ubuntu hardy main restricted
>
> 2) sudo apt-get update
> 3) sudo apt-get install linux-image-2.6.24-1-generic
> 4) reboot and select the new kernel from the grub menu
>
> After you've tested, please feel free to revert back - ie boot into the
> old kernel, sudo apt-get remove linux-image-2.6.24-1-generic, and remove
> the line from /etc/apt/sources.list . Please update this report with
> your results. Thanks in advance!
>
> ** Changed in: linux (Ubuntu)
> Importance: Undecided => Medium
> Status: New => Incomplete
>

I can confirm it hasn't happened since last 2.6.22-14 kernel upgrade.

Changed in linux-source-2.6.22:
status: New → Fix Released
Changed in linux:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers