resume fails on Dell XPS M1330

Bug #160319 reported by Bram Vandoren on 2007-11-05
10
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
linux-source-2.6.22 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: linux-image-2.6.22-14-generic

Resume fails on my Dell XPS M1330. It either wakes up with only a single core active or doesn't wake up at all.

I tried the procedure on the wiki (https://wiki.ubuntu.com/DebuggingKernelSuspend) and managed to get these hash matches:
[ 10.865033] Magic number: 0:35:343
[ 10.865035] hash matches /build/buildd/linux-source-2.6.22-2.6.22/drivers/base/power/resume.c:57
[ 10.865078] hash matches device tty60

$ uname -a
Linux aludra 2.6.22-14-generic #1 SMP Sun Oct 14 23:05:12 GMT 2007 i686 GNU/Linux

Bram Vandoren (bram-bram) wrote :
Bram Vandoren (bram-bram) wrote :

/proc/cpuinfo (before resume)

Bram Vandoren (bram-bram) wrote :

cat /proc/kmsg during resume wakeup cycle (it comes up here but only with one core active)

Bram Vandoren (bram-bram) wrote :
Bram Vandoren (bram-bram) wrote :

I tried to enable the second core after a resume but the file /sys/devices/system/cpu/cpu0/online is missing. The file cpu1/online exists:

cat /sys/devices/system/cpu/cpu1/online
1

The Hardy Heron Alpha2 release will be coming out soon (around Dec 20). It will have an updated version of the kernel. It would be great if you could test with this new release and verify if this issue still exists. I'll be sure to update this report when Alpha2 is available. Thanks!

Changed in linux:
status: New → Incomplete

I'm opened a new task ('linux) against the actively developed kernel so will be closing this report against linux-source-2.6.22. Thanks!

Changed in linux-source-2.6.22:
status: New → Won't Fix

Hardy Heron Alpha2 was recently released. It contains an updated version of the kernel. You can download and try the new Hardy Heron Alpha2 release from http://cdimage.ubuntu.com/releases/hardy/alpha-2/ . You should be able to then test the new kernel via the LiveCD. If you can, please verify if this bug still exists or not and report back your results. General information regarding the release can also be found here: http://www.ubuntu.com/testing/hardy/alpha2 . Thanks!

Bram Vandoren (bram-bram) wrote :

I tried the LiveCD and suspend works fine now. Wakeup/sleep performance seems to be improved too.

Great, I'm glad to hear things are working with the newer release. I'll be closing this report. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at [WWW] https://wiki.ubuntu.com/Bugs/Status . Thank you again for taking the time to report this bug and helping to make Ubuntu better. Feel free to submit any future bugs you may find.

Changed in linux:
status: Incomplete → Fix Released
Fabian A. Scherschel (fabsh) wrote :

I am reopening this bug since my XPS m1330 still fails to wake up from suspend in Hardy. Please tell me which specific log output/info you want me to provide. I am prepared to help test this.

24 May 08 12:50:27 fabsh@serenity:~$ uname -a
Linux serenity 2.6.24-16-generic #1 SMP Thu Apr 10 13:23:42 UTC 2008 i686 GNU/Linux

Changed in linux:
status: Fix Released → In Progress

Hi Fabian,

Can you provide the output of 'sudo lspci -vvnn'. Also, can you attach your dmesg output after an attempted suspend/resume cycle as outlined in https://wiki.ubuntu.com/DebuggingKernelSuspend .

Another option you may want to test is that a newer 2.6.24-19 kernel is currently going through the hardy-proposed respository and should be made available in the near future. I recall some patches went in to resolve a suspend/resume regression introduced in 2.6.24-17 but your system may also benefit from the patch.

If the newer -19 kernel still exhibits issues, I may have you test the upcoming Intrepid kernel. It was most recently rebased with the upstream 2.6.26 kernel. It's available in the kernel-ppa (personal package archive) but is currently experiencing some build issues. Once it is available I'll try to update this report and provide instructions on how to test. Thanks.

Changed in linux:
status: In Progress → Incomplete

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

*This is an automated response*

This bug report is being closed because we received no response to the previous request for information. Please reopen this if it is still an issue in the actively developed pre-release of Jaunty Jackalope 9.04 - http://cdimage.ubuntu.com/releases/jaunty . To reopen the bug report simply change the Status of the "linux" task back to "New".

Changed in linux:
status: Incomplete → Won't Fix
Luke Faraone (lfaraone) wrote :

Works for me in the proposed Intrepid kernel.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers