kernel regression on ASUS L3000D laptop

Bug #160103 reported by popinet on 2007-11-05
16
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
linux-source-2.6.22 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: linux-image-2.6.22-14-386

I have an ASUS L3000D laptop. Hardware profile ID is

e3c7368a4b53e63f75ce69ff9325c52e

Everything worked fine until I upgraded to 7.10 (kernel 2.6.22). With this kernel, everything is sluggish and when the CPU fan starts (even at low CPU temperature) it never stops (even with CPU temperatures as low as 30C).

Switching back top kernel 2.6.15 (I didn't try any version between 2.6.15 and 2.6.22) everything is back to normal.

thanks for your help

Stephane Popinet

phil (philippwnrt) wrote :

Hi,
The same thing happened to me and my ASUS L3000D - so it isn't only a problem of the laptop of Popinet.
Thanks for help,
phil.

malex (malexorg) wrote :

Hi,
It happened to my <a href="https://bugs.launchpad.net/ubuntu/+bug/156995">L3000D too</a>.

Can you guys try booting with acpi=off and report back your results? Thanks.

Changed in linux-source-2.6.22:
status: New → Incomplete
malex (malexorg) wrote :

I booted with acpi=off and nothing changed.

Can you please attach the following information:

* uname -a > uname-a.log
* cat /proc/version_signature > version.log
* dmesg > dmesg.log
* sudo lspci -vvnn > lspci-vvnn.log

Please be sure to attach each file as a separate attachment. For more information regarding the kernel team bug policy, please refer to https://wiki.ubuntu.com/KernelTeamBugPolicies . Thanks again and we appreciate your help and feedback.

malex (malexorg) wrote :
malex (malexorg) wrote :
malex (malexorg) wrote :
malex (malexorg) wrote :

The Hardy Heron kernel was recently uploaded for testing. We'd really appreciate it if you could try testing with this newer kernel and verify if this issue still exists. Unfortunately, the Hardy Heron Alpha1 LiveCD was released with the older 2.6.22 kernel. You'll have to manually install the newer Hardy Heron kernel in order to test. This should not be the case for Alpha2. However, here are the instructions to install (if you choose to do so):

1) edit the file /etc/apt/sources.list and add the following line:

deb http://archive.ubuntu.com/ubuntu hardy main restricted

2) sudo apt-get update
3) sudo apt-get install linux-image-2.6.24-1-generic
4) reboot and select the new kernel from the grub menu

After you've tested, please feel free to revert back - ie boot into the old kernel, sudo apt-get remove linux-image-2.6.24-1-generic, and remove the line from /etc/apt/sources.list . Please update this report with your results. Thanks in advance!

Changed in linux:
importance: Undecided → Medium
status: New → Incomplete
popinet (popinet) wrote :

Hi,

I just tried linux-image-2.6.24-1-generic and it seems to work ok on my asus L3000D. Fan speeds seem to be consistent with CPU activity/temperature etc...

Any chance of backporting (this kernel | the corresponding fixes) to the feisty kernels?

cheers

Stephane

Changed in linux:
status: Incomplete → Fix Released
Connor Imes (ckimes) wrote :

I am closing this report for inux-source-2.6.22 (Ubuntu) since it is fixed in the latest linux kernel. Thank you.

Changed in linux-source-2.6.22:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers