Belkin usb wireless adaptor causes system freeze after upgrading to Gutsy

Bug #160102 reported by wren42 on 2007-11-05
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux-source-2.6.22 (Ubuntu)
Undecided
Unassigned

Bug Description

In Feisty, I was pleasantly surprised to find my Belkin F5D6050 USB wireless adaptor worked perfectly as soon as I plugged it in. However, today I upgraded to Gutsy, and had a terrible time. The install process went flawlessly, but on reboot the Ubuntu progress bar just stalled at around 10% and nothing happened. After much investigation with a rescue disk, I was still at a complete loss, but since the system logs seemed to suggest the last actions the computer would take before freezing involved the wireless card, I took the hint, unplugged it, and... suddenly I can boot.

Right now, if I boot with the device plugged in, the system will freeze before it can start. If I plug it in after the system is already booted, the system will go unresponsive immediately.

By removing the wireless adaptor, I was able to get my computer to boot normally. The progress bar still pauses for a long time at about 10%, but it eventually does move on. My best guess is that this is the system trying to establish a network connection without any network adaptor and timing out.

My computer is amd64 based, just for the record.

I'm not sure what exactly broke on the upgrade from Feisty to Gutsy, but I imagine it must either be the wireless driver or the kernel itself.

Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in linux-source-2.6.22.

Brian Murray (brian-murray) wrote :

Could you try booting your system with the device connected and without the 'quiet splash' kernel options and take a picture of where the boot process hangs? Thanks in advance.

Changed in linux-source-2.6.22:
status: New → Incomplete
Brian Murray (brian-murray) wrote :

We are closing this bug report as it lacks the information, described in the previous comments, we need to investigate the problem further. However, please reopen it if you can give us the missing information and feel free to submit bug reports in the future.

Changed in linux-source-2.6.22:
status: Incomplete → Invalid
Gavin McCullagh (gmccullagh) wrote :

Hi,

I can confirm this bug (or a very similar one) with my mother's laptop (a Dell Latitude CSx) and the same wireless card:

gavin@chris:~ $ sudo lsusb
Bus 001 Device 002: ID 0d5c:a002 Belkin F5D6050 802.11b Adapter
Bus 001 Device 001: ID 0000:0000

In answer to Brian's question, in my case the crash doesn't happen during the boot process. Invariably, I get to the gdm login screen, get to login and then after a minute or two (I suspect after a decent bit of network access), the system freezes up completely with two of the 3 keyboard LEDs blinking together. The <ctrl><alt><sysrq> hotkeys do nothing, a hard reset is all that you can do. I've repeated this multiple times.

I booted the feisty 2.6.17 kernel and all worked fine again, so this appears to be a regression. For now, for her benefit I've set up grub to boot that kernel.

I upgraded to Hardy, hoping the newer 2.6.24 kernel wouldn't exhibit the issue. It crashes in the same way as 2.6.22 did.

I think I need to try a couple of things:

1. Boot without the wifi card and see is everything okay (just to
    isolate that as the issue.
2. Perhaps upgrade to intrepid or install the Intrepid kernel and
    see does that crash too.

The driver for the Fd6050 is the at76c503 which was never accepted into Linus' kernel. I think Ubuntu package it themselves. I guess the bug should be against that package and should be linked against hardy (which is supported for some time to come) as well as gutsy.

gavin@chris:~ $ lspci
00:00.0 Host bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (rev 03)
00:01.0 PCI bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge (rev 03)
00:03.0 CardBus bridge: Texas Instruments PCI1225 (rev 01)
00:03.1 CardBus bridge: Texas Instruments PCI1225 (rev 01)
00:07.0 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ISA (rev 02)
00:07.1 IDE interface: Intel Corporation 82371AB/EB/MB PIIX4 IDE (rev 01)
00:07.2 USB Controller: Intel Corporation 82371AB/EB/MB PIIX4 USB (rev 01)
00:07.3 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 03)
01:00.0 VGA compatible controller: Neomagic Corporation NM2360 [MagicMedia 256ZX]
01:00.1 Multimedia audio controller: Neomagic Corporation NM2360 [MagicMedia 256ZX Audio]
06:00.0 Ethernet controller: Xircom Cardbus Ethernet 10/100 (rev 03)
06:00.1 Serial controller: Xircom Cardbus Ethernet + 56k Modem (rev 03)

gavin@chris:~ $ lsmod |grep at7
at76c505_rfmd 5772 0
at76c503_rfmd_acc 5900 0
at76c503 92896 2 at76c505_rfmd,at76c503_rfmd_acc
at76_usbdfu 6532 1 at76c503
usbcore 134912 6 at76c505_rfmd,at76c503_rfmd_acc,at76c503,at76_usbdfu,uhci_hcd

John McCourt (butterman) wrote :

This device doesn't appear to work in Natty:

~$ lsusb
Bus 004 Device 003: ID 0d5c:a002 SMC Networks, Inc. SMC2662W v2 / SMC2662W-AR / Belkin F5D6050 [Atmel at76c503a]

It shows up in lsusb but not in ifconfig

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers