ipw3945 wireless not working on kernel 2.6.22.14-generic after upgrading from feisty

Bug #154959 reported by RobPower on 2007-10-20
4
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
linux-source-2.6.22 (Ubuntu)
Undecided
Unassigned

Bug Description

Hi!
I'm running Kubuntu 7.10 on my acer aspire 5633.
I have a problem with wireless after upgrading my Feisty to Gutsy version.
The problem appears only if I boot with the new kernel (2.6.22.14-generic). Instead, if I boot using the last used kernel (2.6.20.16-lowlatency) everything works fine.

Before the upgrade all was fine: I have installed KWlan and wlassistant and configured them to auto connect on my wireless home network at startup.
After the upgrade, I noticed that the restricted-manager was integrated in Kubuntu. I thought that would have made everything easier, but i was wrong.
The restricted manager tell me that ipw3945 driver is in use. In fact, if I do "lsmod", ipw3945 is loaded.
Anyway the checkbock near the driver seems to be unchecked till I run restricted-manager with administrator rights. (I'm not sure if this is important)

If I run iwconfig it says that eth1 (that has always been the wireless interface) has no wireless extension.
So I checked under "System Settings -> Network Settings". Under the "Network Interfaces" my system recognize my interface eth1 as an Ethernet (wired) network interface, not as a wireless interface. Also the icon near eth1 is the tipical ethernet icon and not the radio one, as before.

I already tried to disable and reenable the restricted driver, to reboot, to run depmod -a, but nothing succeded in solving the problem.

PS: a problem with the traffic congestion of ubuntu servers- I think - interrupts the upgrade before ending. After that I ran dpkg --configure -a and then manually updated the packages via adept manager. Anyway, if I run adept and update the list, the "version upgrade" button appears. If I click it, it downloads and starts the "distribution upgrade" tool, but before starting to download the packges, it stops saying that the system is updated. The bug is reported here https://bugs.launchpad.net/ubuntu/+source/update-manager/+bug/154751 , maybe it is related

I attach "modinfo ipw3945" output, both from "2.6.22.14" and from the working one ("2.2.20.16").
Tell me if more information are needed.

RobPower (robpwr) wrote :
Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage. I have classified this bug as a bug in linux-source-2.6.22.

RobPower (robpwr) wrote :

Still not working!

The Hardy Heron Alpha2 release will be coming out soon. It will have an updated version of the kernel. It would be great if you could test with this new release and verify if this issue still exists. I'll be sure to update this report when Alpha2 is available. Thanks!

Changed in linux:
status: New → Incomplete

Hardy Heron Alpha2 was recently released. It contains an updated version of the kernel. You can download and try the new Hardy Heron Alpha2 release from http://cdimage.ubuntu.com/releases/hardy/alpha-2/ . You should be able to then test the new kernel via the LiveCD. If you can, please verify if this bug still exists or not and report back your results. General information regarding the release can also be found here: http://www.ubuntu.com/testing/hardy/alpha2 . Thanks!

This bug report is being closed because we received no reponse to the last inquiry for information. Please reopen it if this is still an issue in the current Ubuntu release. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Please don't hesitate to submit bug reports in the future, we really appreciate it. Thanks again!

Changed in linux:
status: Incomplete → Invalid
Changed in linux-source-2.6.22:
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers