wi-fi connection goes down - reboot is required

Bug #154549 reported by muszek on 2007-10-19
22
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
linux-source-2.6.22 (Ubuntu)
Undecided
Unassigned

Bug Description

Sometimes (twice in the last 4 hours) wi-fi connection goes down and doesn't want to reconnect.
When it happens:
 * nm-applet asks me for WPA password and tries to connect for a very long time.
 * nm-applet behaves strangely - I can't select another network.
 * /etc/init.d/networking doesn't help and executes _really_ quickly (0.x second), producing just one line.
 * when I restart gnome, nm-applet doesn't show wi-fi hotspots at all.
 * reboot helps.
At the same time, my girlfriends windows-based laptop is connected without any problems.

I can't reproduce the bug.

I don't know what I can do to troubleshoot this - please tell me and I'll do that next time this thing happens.
I'm using gutsy (fresh install) since this morning on Dell Inspiron 1720. I think it happened to me on Feisty (running since I got this laptop in mid August).

lspci | grep Wireless
0c:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)

Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage. I have classified this bug as a bug in linux-source-2.6.22.

muszek (muszek) wrote :

I've lived a bit longer with this bug. Here's what I've observed.
Most important: I guess it's NetworkManager. It has just happened to me and I noticed that System Monitor panel applet indicates that 50% CPU is used (I have Core 2 Duo). Weird thing though: at the same time top showed that NetworkManager used 100% cpu... (but that's another issue I guess). Anyways, I killed NM, started it again and networking works... .

This bug happens few times a day (I'd say 3-5x / 24h). I still can't really tell what behavior causes that.

muszek (muszek) wrote :

2 days later. It happened a few more times. New observations:
I can observe three different behaviors when the situation occurs:
 * as noted above - I kill & start NetworkManager and everything's fine. Actually it only happened once.
 * more frequent - the whole OS becomes unstable - I can use running programs, but can't run gnome-terminal. Even sudo doesn't work - I switched to CLI (via CTRL+ALT+F1). when I use sudo, it just goes to the new line and cursor blinks... and I can't do anything in that console.
 * also happened a few times - I can kill & start NetworkManager and everything else seems to be fine, except it keeps connecting for ever. I ran sudo NetworkManager --no-daemon and saved the output (attached to this message).

Also, for the whole day today NM showed only one access point (it always shows 5-11 different APs).

syslog attached... bug occured here:
Oct 25 15:59:12 bobek kernel: [ 2670.668000] ipw3945: Error sending DAEMON: Already sending a synchronous daemon command

a.sweets (a-sweets) wrote :

I can confirm this also.

I just upgraded to Gutsy, everything wireless was fine in Feisty, but the network manager lags and hangs and won't switch wireless networks and often won't connect (or takes forever) and freezes eventually if I try to do too much with it.

I've tried reloading but for me it takes a complete reboot. Often when it freezes I have other strange issues like I can't open system monitor or a terminal session.

I've got Intel PRO wireless 3945 ABG as well.

a.sweets (a-sweets) wrote :

What is the meaning of the following error I'm seeing over and over and over again? (Muszek, I followed your lead and checked my /var/log/syslog as well)

Oct 26 08:17:01 dell NetworkManager: <info> Error getting killswitch power: org.freedesktop.Hal.Device.KillSwitch.NotSupported - Access type not supported
Oct 26 08:17:37 dell last message repeated 6 times
Oct 26 08:18:37 dell last message repeated 10 times
Oct 26 08:19:37 dell last message repeated 10 times
Oct 26 08:20:37 dell last message repeated 10 times
Oct 26 08:21:38 dell last message repeated 10 times
Oct 26 08:22:38 dell last message repeated 10 times
Oct 26 08:23:38 dell last message repeated 10 times
Oct 26 08:24:38 dell last message repeated 10 times
Oct 26 08:25:38 dell last message repeated 10 times
Oct 26 08:26:38 dell last message repeated 10 times
Oct 26 08:27:38 dell last message repeated 10 times
Oct 26 08:28:38 dell last message repeated 10 times
Oct 26 08:29:39 dell last message repeated 10 times
Oct 26 08:30:39 dell last message repeated 10 times
Oct 26 08:31:33 dell last message repeated 9 times
Oct 26 08:32:33 dell last message repeated 10 times
Oct 26 08:33:33 dell last message repeated 10 times
Oct 26 08:34:33 dell last message repeated 10 times
Oct 26 08:35:33 dell last message repeated 10 times
Oct 26 08:36:33 dell last message repeated 10 times
Oct 26 08:37:15 dell last message repeated 7 times

It seems a little strange, is that normal or significant in any way?
That's what I see in my log right before/during a hang for the network manager.

Changed in linux-source-2.6.22:
status: New → Confirmed
muszek (muszek) wrote :

Perhaps this bug should be marked as duplicate of https://bugs.launchpad.net/ipw3945/+bug/134515 , which has reports of similar or the same problem from more competent users ;

a.sweets (a-sweets) wrote :

I read through that other thread and I'm not sure if I'm having that exact same problem. It seems that the problem they're having with the driver is maybe a lot more drastic, mine only goes down once in a while. I've found recently that I don't need to reboot, per se, but just kill the Network Manager Applet and reload it. If it were an issue with the driver, would reloading the Manager also reload the driver?

I don't know, I'll have to do some more poking around per their suggestions in the other thread.

Honestly, it's been fine the last couple of days so I haven't been messing with it.

a.sweets (a-sweets) wrote :

Ok, I kept switching networks until NM froze, at this point I did "sudo iwlist eth1 scan" and it listed 12 separate networks (actually more networks than NM was showing). So, I reloaded NM and it worked fine and connected to my preferred network. I repeated this again until NM froze for the second time and as I went to type "sudo iwlist eth1 scan" again, my terminal session quit and X pretty much died. I could click on things but I couldn't get any programs/applets to open, not system monitor, not terminal, not even the 'quit' applet to shutdown/reboot. Ctl+alt+backspace to reload X didn't work, neither did any desktop effects. So I was forced to reboot the hard way. I was unable to see if it was the driver that froze my system or NM.

:-\

Brian Murray (brian-murray) wrote :

I am assigning this bug to the 'ubuntu-kernel-team' per their bug policy. For future reference you can learn more about their bug policy at https://wiki.ubuntu.com/KernelTeamBugPolicies .

Changed in linux-source-2.6.22:
assignee: nobody → ubuntu-kernel-team
gyp (gyp-impulzus) wrote :

I can confirm muszek's second problem in https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.22/+bug/154549/comments/3 -- the system becomes unstable and I cannot sudo anymore. I'm running the latest Gutsy as of today on a Thinkpad R61 with a stock ubuntu 2.6.22-14.52 and the ipw3495 driver. The problem happens about once daily under heavy network traffic and it does not seem to happen on a WEP connection.

I'm attaching the relevant part of syslog.

gyp (gyp-impulzus) wrote :

And I'm attaching more logs about my system as the kernel team bug policy tells me to.

gyp (gyp-impulzus) wrote :
gyp (gyp-impulzus) wrote :

The dmesg log is taken a some time after a fresh boot, tell me if you need one from right after when the bug happened.

gyp (gyp-impulzus) wrote :

...and here goes the the last one.

Also, answering the questions in the bug policy: Kubuntu Gutsy was the first thing installed on this laptop and -- as this is my production computer full of data -- I don't have the chance to test it with other distributions unless it's absolutely necessary. I can test it, however, with other self-compiled kernels if you tell me which version to try.

Michael W. (hotdog003-gmail) wrote :

I can confirm this on my Dell Vostro 1500. Some things happen:
*I can't use sudo
*I can't start most programs (e.g. gnome-terminal refuses to run, but say gnome calculator works). If the program is already running, it seems to be fine.
*The hardware wifi killswitch does absolutely nothing. If the wireless card was on, it doesn't turn off the card, even though it normally does.
*NM still reports a connection, but says the connection quality is 0%.

If it helps, I'm also running the NVidia binary driver.
michael@northbound:~$ lspci | grep -i wireless
0c:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)

Michael W. (hotdog003-gmail) wrote :

Oh, yeah- also forgot to report that this happens very randomly, e.g. I can't do any one thing to reproduce it. Happens about once per every two days or so for me.

Gerard (g-gorman) wrote :

I'm also having this trouble on a Dell precision m4300. I'm running:
Linux version 2.6.22-14-generic (buildd@terranova) (gcc version 4.1.3 20070929 (prerelease) (Ubuntu 4.1.2-16ubuntu2)) #1 SMP Tue Feb 12 07:42:25 UTC 2008
The only customization I've performed is installed the driver NVIDIA-Linux-x86-169.12-pkg1.run.

I'm getting all kinds of errors in addition to the previously reported,
ipw3945: Error sending DAEMON: Already sending a synchronous daemon command

e.g.
[ 163.576000] ieee80211_crypt: registered algorithm 'WEP'
[ 477.840000] ipw3945: Error sending cmd #07 to daemon: time out after 500ms.
[ 498.928000] ipw3945: association process canceled
[ 511.936000] ipw3945: association process canceled
[ 659.912000] ipw3945: Daemon command aborted.
[ 1015.264000] ipw3945: association process canceled

It's really very embarrassing at conferences etc having to reboot my laptop in front of MS and Mac users (3 times today). So please, can someone find the magic bullet. The same problem does not occur when the laptop is booted into XP so it's unlike to be a hardware issue.

Beginning with the Hardy Heron 8.04 development cycle, all open Ubuntu kernel bugs need to be reported against the "linux" kernel package. We are automatically migrating this bug to the new "linux" package. However, development has already began for the upcoming Intrepid Ibex 8.10 release. It would be helpful if you could test the upcoming release and verify if this is still an issue - http://www.ubuntu.com/testing . If the issue still exists, please update this report by changing the Status of the "linux" task from "Incomplete" to "New". We appreciate your patience and understanding as we make this transition. Thanks!

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

Stefan Bader (smb) wrote :

This bug report is being closed because we received no response to the previous inquiry for information. Please reopen if this is still an issue in the current Ubuntu release, Jaunty Jackalope 9.04 - http://www.ubuntu.com/getubuntu/download. To reopen the bug, click on the current status under the Status column and change the status back to "New". Thanks.

Changed in linux (Ubuntu):
status: Incomplete → Won't Fix
Varun (varunthacker) wrote :

i have the same problem.Ill describe it anyways.
When my network disconnects for a long time (more than 2 mins. or so) then network manager cannot connect to the same network again without restarting the laptop or if i use the commands mentioned:

$ sudo /etc/init.d/network-manager restart
$ sudo restart network-manager

once i restart network manager by this method it reconnects.
I'm using a Lenovo r61 and have upgraded to 9.10 from 9.04 and this problem was not there in 9.04.

please let me know what additional information do i need to provide.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers