Live CD for i386: ISOLINUX 3.36 (on 7.10) and 3.53 (on 8.04) hang at "loading . . ." before Ubuntu boot loader; 3.31 (Feisty 7.04) was OK

Bug #152257 reported by Owen PG on 2007-10-13
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
linux-source-2.6.22 (Ubuntu)
Medium
Unassigned
syslinux (Ubuntu)
Medium
Unassigned

Bug Description

I burnt the 7.10 kubuntu release candidate CD (original MD5 not available on web page) from using k3B - and verified the burnt disk as OK from the ISO I downloaded.

Source was:
http://mirror.optus.net/ubuntu-releases/kubuntu/7.10/kubuntu-7.10-rc-desktop-i386.iso

Back on my Via CL Eden 600MHz PC (the test install) it loads as far as:

ISOLINUX 3.36 Debian . . . Peter Anvin
Loading . . . _

And that's it.

The Via CL was quite happily running 7.04 prior to being wiped for this trial.

Please feel free to contact me at <email address hidden> - although I wouldn't know what else to say :-(

Cheers and good luck.

Owen

Owen PG (owen-pg) wrote :

I tried the CD in another machine, AMD 64 bit. It boots up to KDE using the install CD OK.

Owen PG (owen-pg) wrote :

Update, I also burnt another CD on another PC to try on the Via CL - it hangs at the same place:

ISOLINUX 3.36 Debian . . . Peter Anvin
Loading . . . _

FYI the MD5 of the ISO image:
kubuntu-7.10-rc-desktop-i386.iso is f379ea37e1121d4f088dce9d49e171de

VIA EPIA CL spec is here:
http://www.via.com.tw/en/products/mainboards/motherboards.jsp?motherboard_id=181
and it has 512MB RAM with 64 used for video

P.S. I was hoping to see if the VIA Unichrome AGP graphics was going to be supported now so that I can get 1280 x 768 resolution.

Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Could you try booting without the 'quiet' and 'usplash' options and see if there is anything more informative output to the terminal? Thanks in advance.

Owen PG (owen-pg) wrote :

Unfortunately, there isn't anything to add.

This is the CD boot loader we're talking about here not kubuntu itself loading. Here's what happens:

I insert "Kubuntu 7.10 i38" CD into Via EPIA PC.

Power On PC:

. . . BIOS / Memory blah things . . .

PCI device listing . . .
. . . blah . . .

Verifying DMI Pool Data . . . . . . . . . . .
. . . blah . . .

Boot from CD :
ISOLINUX 3.36 Debian-2007-08-30 Copyright (C) 1994-2007 H. Peter Anvin
Loading . . . _

Nothing else.

If there's any way to get more info out of this, please let me know how.

Cheers,

Owen

Hi Brian,

I posted my reply here:
https://bugs.launchpad.net/ubuntu/+bug/152257

Regards,

Owen

--- Brian Murray <email address hidden> wrote:

> Thank you for taking the time to report this bug and
> helping to make
> Ubuntu better. Could you try booting without the
> 'quiet' and 'usplash'
> options and see if there is anything more
> informative output to the
> terminal? Thanks in advance.
>
> ** Changed in: ubuntu
> Status: New => Incomplete
>
> --
> kubuntu 7.10RC(1) for i386 from CD hangs at "loading
> . . ."
> https://bugs.launchpad.net/bugs/152257
> You received this bug notification because you are a
> direct subscriber
> of the bug.
>

Can confirm this error. Tried to install ubuntu-7.10-server-i386.iso on an old VIA C3 (cat /proc/cpuinfo see below). It hangs at the ISOLINUX CD boot loader. With 7.04 no problem to boot the CD.

Regards,

Klaus

cat /proc/cpuinfo

processor : 0
vendor_id : CentaurHauls
cpu family : 6
model : 7
model name : VIA Ezra
stepping : 8
cpu MHz : 735.099
cache size : 64 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 1
wp : yes
flags : fpu de tsc msr cx8 mtrr pge mmx 3dnow up
bogomips : 1471.35

lyalc (vba-lsc) wrote :

I get a similar effect on a Nehemiah CPU - error is "Panic CPU too old"

cheers.
lyalc

Klaus Layer (klaus-layer) wrote :

By replaceing isolinux in ubuntu-7.10-server-i386.iso with isolinux from ubuntu-7.04-server-i386.iso I was able to install 7.10 server on a machine with VIA C3.

Here are the steps:

1.) Create mount points for the ISO files

# mkdir ~/ubuntu-7.10-server-i386
# mkdir ~/ubuntu-7.04-server-i386

2.) mount the ISO files

# sudo mount -o loop,ro -t iso9660 ~/ubuntu-7.04-server-i386.iso ~/ubuntu-7.04-server-i386
# sudo mount -o loop,ro -t iso9660 ~/ubuntu-7.10-server-i386.iso ~/ubuntu-7.10-server-i386

3.) copy ubuntu-7.10-server-i386 to temporary directory

# sudo cp -r ~/ubuntu-7.10-server-i386/ ~/my_ubuntu-7.10-server-i386/

4.) remove isolinux from ubuntu-7.10-server-i386

# sudo rm -rf ~/my_ubuntu-7.10-server-i386/isolinux

5.) copy isolinux from ubuntu-7.04-server-i386 to ~/my_ubuntu-7.10-server-i386

# sudo cp -r ~/ubuntu-7.04-server-i386/isolinux ~/my_ubuntu-7.10-server-i386/isolinux

6.) create an iso from the modified tree

# sudo mkisofs -ldots -o my_ubuntu-7.10-server-i386.iso -b isolinux/isolinux.bin -c isolinux/boot.cat -no-emul-boot -boot-load-size 4 -boot-info-table ~/my_ubuntu-7.10-server-i386/

Hope that helps others to workaround this bug.

Regards,

Klaus Layer

Owen PG (owen-pg) wrote :

Or there is the easier alternative - which also works:
http://www.pcbsd.org/
(tested)

Owen

Changed in linux-source-2.6.22:
importance: Undecided → Medium
Owen PG (owen-pg) wrote :

Also a problem with 8.04:

HardyHeron/Alpha4 for i386 CD: ISOLINUX hangs at "loading . . ."

https://bugs.launchpad.net/ubuntu/+bug/190080

Care to boot without the 'quiet' and 'splash' options and then take a digital picture of your screen when you witness the hang? Thanks.

Changed in linux:
status: New → Incomplete
Owen PG (owen-pg) wrote :

The system hangs BEFORE there is any chance to use boot options - see
previous notes.

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: Incomplete → Triaged
Changed in linux-source-2.6.24:
status: New → Invalid

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Owen PG (owen-pg) wrote :

"move to the 2.6.27 kernel" - will have no effect on this bug. The problem is with Isolinux not the Linux kernel. Again, I would refer posters to the previous notes:
Owen PG wrote on 2007-10-17
Owen PG wrote on 2008-02-08

I'm closing the kernel tasks then and opening a syslinux task. Thanks.

Changed in linux-source-2.6.22:
status: Confirmed → Invalid
Changed in linux:
status: Triaged → Invalid
Daniel T Chen (crimsun) on 2008-11-28
Changed in syslinux:
importance: Undecided → Medium
status: New → Confirmed

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

I am afraid you are wrong.
The quiet boot and the quick boot and splash boot are options you disable at Bios Setup, not at any prompt from the Ubuntu (or any other distro) cd / image / anything_you_are_booting_from.
If you disable this at Bios, pretty much it gonna work.
If you don't know what's Bios, get back to Windows. Or MacOS.

----------
Julio Simões - MacOS X Lion @ MacBook Air 11''
Not a i-tech professional, but an old-time user: since 1987, on a CP400 Color II

Owen PG (owen-pg) wrote :

Hi there Julio E S R Simoes,

Since I reported this bug some 5 years ago, I don't need your posturising that this is anything to do with BIOS. If I was like you, I'd suggest that
"If you don't know what's Bios, get back to Windows. Or MacOS."

Meanwhile. I'll un-subscribe from this bug. Cheerio.

tags: removed: iso-testing
Phillip Susi (psusi) wrote :

Does anyone still experience this on 12.04 or later?

Changed in syslinux (Ubuntu):
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for syslinux (Ubuntu) because there has been no activity for 60 days.]

Changed in syslinux (Ubuntu):
status: Incomplete → Expired
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/152257

tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers