PANIC: CPU too old for this kernel

Bug #151942 reported by Per Øyvind on 2007-10-12
42
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Virtualbox
Fix Released
Unknown
base-installer (Ubuntu)
Undecided
Rolf Leggewie
linux (Ubuntu)
Undecided
Unassigned
linux-source-2.6.22 (Ubuntu)
High
Unassigned

Bug Description

After installing Ubuntu 7.10 Release Candidate om my laptop (compac Evo N620c with Intel Pentium -M prosessor 1.5 GHz)
Nothing happens. After booting, the screen is black with the text :
"Starting up......"
"PANIC: CPU too old for this kernel."

KWierso (kwierso) wrote :

Same error occured with me on the final release of the server version. This is on my laptop (Dell Inspiron 600m with Intel Pentium Mobile 1.7 GHz)

Jani Averbach (jaa-jaa-iki) wrote :

Same thing here, this time with:

Ubuntu Server 7.10
HW: Via C3 1GHZ embedded system

processor : 0
vendor_id : CentaurHauls
cpu family : 6
model : 9
model name : VIA Nehemiah
stepping : 8
cpu MHz : 996.016

KWierso (kwierso) wrote :

I just installed the desktop version of 7.10 on my laptop, and it boots fine.

Same error occured with me on the server version (7.10 final), I installed on a Virtual Box machine.

Changed in linux-source-2.6.22:
assignee: nobody → ubuntu-kernel-team
status: New → Triaged
Eric Dong (eric-anlu-dong) wrote :

Same error as KWierso on 7.10 server, also on a Dell Inspiron 600m with an Intel Pentium-M 1.7 GHz processor.

Eric Dong (eric-anlu-dong) wrote :

Correction: it is a Dell Latitude D600. After searching around, it seems like this problem has something to do with PAE support compiled into the server kernel. I was able to install a working kernel by booting from the server install CD, launching a recovery shell, and running
apt-get install linux-generic

When booting, press ESC to enter the GRUB boot menu and select the -generic kernel (probably the third one in the list). (Even better, you can edit /boot/grub/menu.lst and make this the default kernel.)

This is the easy way out. Those feeling more adventurous can compile the server kernel without PAE support.

chastell (chastell) wrote :

This is a bug in VirtualBox not supporting PAE (or, from another point of view, the server kernel assuming PAE support without checking for it). The VirtualBox issue for this is http://virtualbox.org/ticket/212

chastell (chastell) wrote :

The current workaround for this:
1. Boot the server from the CD, choose to ‘Rescue a broken system’.
2. Get a shell in your installed system.
3. If /boot contains the generic kernel, then it’s the CD’s /boot; unmount it and mount it to get your server’s /boot in there.
4. aptitude install linux-generic
5. Reboot and choose the generic kernel in GRUB.

Same problem with a Thinkpad T42p, how is it possible to recompile the kernel without this PAE problem ?

In fact i would like compile a LAMP server with a reduced software.

Changed in virtualbox:
status: Unknown → New
Ben Collins (ben-collins) wrote :

It's not a bug in the server kernel that the hw doesn't support PAE. One could say it is a bug in the installer, because it boots -386 kernel, and installs -server kernel, which cannot always be expected to work.

Changed in linux-source-2.6.22:
status: Triaged → Invalid
chastell (chastell) wrote :

> It's not a bug in the server kernel that the hw doesn't support PAE. One could say it is a bug in the installer, because it boots -386 kernel, and installs -server kernel, which cannot always be expected to work.

So shouldn’t this be reassigned to debian-installer instead of being marked invalid? VirtualBox will get PAE in one of their subsequent releases (note: Gutsy’s virtualbox-ose is also affected, so maybe this should be opened against it as well), but other PAE-less systems still won’t be able to boot the server kernel.

Same problem here. My laptop is HP/Compaq nc800 with Intel Pentium-M processor 1.6GHz. I used the workaround decribed by Shot above on 2007-10-25.

nodata (ubuntu-nodata) wrote :

Shall we close this? We can fix this The Ubuntu Way (TM) - look the other way until Debian have it fixed, then tell people to upgrade.

y@ (wyattwalter) wrote :

This is a Ubuntu/Debian problem.. I work with both Parallels and Virtualbox. It happens with Ubuntu 7.10 server every time. The workaround provided by Shot works for me in both situations.

pipe (pipatron) wrote :

There has been a couple of posts to this thread: https://answers.launchpad.net/ubuntu/+question/23343 but it doesn't seem like anyone actually bothers reading those comments, so I thought I should pass it on to this, it seems to be the same bug with just another message from the kernel.

Kevin Williams (bthylafh) wrote :

This is a similar problem I have:

This kernel requires the following features not present on the CPU:
0:6
Unable to boot - please use a kernel appropriate for you CPU.

Does this on Parallels 3 on my Intel Macbook. No problem with the other 32-bit editions of [U|K|X]buntu nor JeOS nor Studio. Enabling and disabling VT-X instructions doesn't change anything.

That's really fucking professional, guys. An LTS release for the /server/ that evidently wasn't tested enough. Shuttleworth should have given you a few more weeks like he did for 6.06. At the /least/ you should detect, during the installation process, whether the CPU supports these extra instructions that the -server kernel needs.

f3a97 (f3a97) wrote :

I have the same problem too,
        so what's up with ubuntu server edition?

Tim Gardner (timg-tpi) wrote :

The server flavour requires PAE support in the CPU.

Changed in linux-source-2.6.24:
status: New → Won't Fix
chastell (chastell) wrote :

So isn’t this a bug in the installer that it boots a -386 kernel, but installs only a -server kernel? If so, shouldn’t this bug be opened against the installer?

I can confirm this bug trying to install Ubuntu-server on my Thinkpad T40.

Nikolaus Filus (nfilus) wrote :

Hi,
I just run into the same problem while rebooting a fresh install of 8.04 LTS i386 on VMWare Server 1.0.4. This is not only a
"me too", but as there seems to be a lot of activity in
  https://answers.launchpad.net/ubuntu/+question/23343 and
  https://answers.launchpad.net/ubuntu/+question/31405
but no response or action here, I'm asking to re-evaluate this report.

I think, that debian-installer should be fixed, either by installing 1 fitting kernel or 2 kernels (optimised and safe).
Additionaly there is no hint during the installation, that a special kind of hardware is required!

I added the affection of debian-installer as already said in a comment before.

As another data point 8.04 server installed in VBox 1.6.0 provides same.

This kernel requires the following features not present on the CPU:
0:6
Unable to boot - please use a kernel appropriate for your CPU.

This is 8.04-server-i386 running on a centrino machine with 8.04-Desktop-i386 as the host. I also have about 9 different distros successfully working in my Vbox install. Exact laptop model (not that it matters) is a Dell Latitude D610.

Kibbled_bits (scott-w-white) wrote :

We may be able to change this defect to fixed. The latest version of VirtualBox 1.6.2 contains a feature to enable PAE. If you go to the settings for a machine you will find a checkbox called: POE/NX, check it and you should be able to boot.

Changed in virtualbox:
status: New → Fix Released
nciampa (nciampa) wrote :

Using "Sun xVM Virtual Box" and using "Ubuntu server 8.04.1".

Oh someone allready reported th PAE/NX check box :D

Nick Rapoport (nrapopor) wrote :

Same/similar problem with dell 600 and 8.0.4.1 server. The same solution worked
The message was :

The kernel requires the following features not present on the CPU
0:6
Unable to boot - please use a kernel appropriate for your CPU

Will this be fixed?

Sorry for the me-too.

Nick

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

Huygens (huygens-25) wrote :

I have the same problem with Ubuntu server 8.04.2 LTS on VirtualBox 2.1 (host Windows XP SP2, Intel Core 2 Duo T5500)
Though, Shot workaround (see https://bugs.launchpad.net/virtualbox/+bug/151942/comments/8) worked for me :-)

Huygens (huygens-25) wrote :

OK, it seems that since VB 1.6 it is possible in the advanced option to set the PAE/NX support. When checked, it is possible to boot Ubuntu server.
Though 2 remarks:
* My VM had only 256MB set, so PAE is not necessary (it's for 4GB+ dynamic memory)!
* The message reported by the kernel is only interesting to kernel developer, but of no use even for advanced Linux user (I have more than 10 years experience with Linux), see below:
The kernel requires the following features not present on the CPU
0:6
Unable to boot - please use a kernel appropriate for your CPU

Information how to fix this was found here:
http://tombuntu.com/index.php/2007/09/05/making-ubuntu-server-work-in-virtualbox/

Rolf Leggewie (r0lf) wrote :

Is this still a problem in lucid and/or oneiric?

Changed in base-installer (Ubuntu):
assignee: nobody → Rolf Leggewie (r0lf)
status: New → Incomplete
Rolf Leggewie (r0lf) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in base-installer (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.