usb cardreader not recognized

Bug #148223 reported by Robert on 2007-10-02
6
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
linux-source-2.6.22 (Ubuntu)
Medium
Unassigned

Bug Description

After upgrading to gutsy from feisty I have problems using USB devices :

1. When inserting a sd-card into my usb cardreader the cardreader is not visible within dolphin so I cannot acces it.
 there is no way to get my cardreader accesible.
2. After reboot and when my external harddrive is still turned on it is not accessible : I get an error : device busy. When I turn off my harddrive during computer reboot everything works fine.

I run kubuntu 7.10 kernel 2.6.22-12
Everything worked fine before upgrading

Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Unfortunately we can't fix it, because your description doesn't yet have enough information.
Please include as attachments the following additional information, if you have not already done so (please pay attention to lspci's additional options), as required by the Ubuntu Kernel Team:
1. Please include the output of the command 'uname -a' in your next response. It should be one, long line of text which includes the exact kernel version you're running, as well as the CPU architecture.
2. Please run the command 'dmesg > dmesg.log' after a fresh boot and attach the resulting file 'dmesg.log' to this bug report.
3. Please run the command 'sudo lspci -vvnn > lspci-vvnn.log' and attach the resulting file 'lspci-vvnn.log' to this bug report.
4. Please also run the command 'sudo lsusb > lsusb.log' and attach the resulting file 'lsusb.log' to this bug report.
For your reference, the full description of procedures for kernel-related bug reports is available at https://wiki.ubuntu.com/KernelTeamBugPolicies . Thanks in advance!

Robert (robertvanreij) wrote :

Hi,

here's the output from uname -a

Linux ubunturvr 2.6.22-12-386 #1 Sun Sep 23 17:37:35 GMT 2007 i686 GNU/Linux
 in the attachment you find dmesg.log

Robert (robertvanreij) wrote :
Robert (robertvanreij) wrote :
Brian Murray (brian-murray) wrote :

It seems to be mounted as /dev/sdb :

[ 330.020094] sd 2:0:0:0: [sdb] 246016 512-byte hardware sectors (126 MB)
[ 330.028018] sd 2:0:0:0: [sdb] Write Protect is off
[ 330.028022] sd 2:0:0:0: [sdb] Mode Sense: 03 00 00 00
[ 330.028024] sd 2:0:0:0: [sdb] Assuming drive cache: write through
[ 330.051917] sd 2:0:0:0: [sdb] 246016 512-byte hardware sectors (126 MB)
[ 330.059317] sd 2:0:0:0: [sdb] Write Protect is off
[ 330.059323] sd 2:0:0:0: [sdb] Mode Sense: 03 00 00 00
[ 330.059325] sd 2:0:0:0: [sdb] Assuming drive cache: write through
[ 330.059329] sdb: sdb1

Could you please add the output of 'fdisk -l /dev/sdb' after adding the sd-card to the reader? Additionally, it would be helpful if you could post the full contents of your '/etc/fstab'. Thanks again.

Robert (robertvanreij) wrote :

The output from fdisk -l /dev/sdb :

Disk /dev/sdb: 125 MB, 125960192 bytes
8 heads, 32 sectors/track, 961 cylinders
Units = cylinders of 256 * 512 = 131072 bytes
Disk identifier: 0x00000000

   Device Boot Start End Blocks Id System
/dev/sdb1 1 961 122959+ 6 FAT16

Additional info:

If I put in a sd-card first and then try to print to my usb-printer then my printer doens't work and my external harddrive is also not accessible.
Attaching a memory stick doesn't work also.

So I see the following :

1. turn on pc, then turn on my external harddrive and printer and then card in usb-cardreader : Only the cardreader does't work.
2. turn on pc, then card in usb-reader, then external harddrive and printer. Nothing works.
3. turn on pc, then turn on external harddrive: harddrive is accessible, reboot with harddrive turned on external harddrive isn't accessible anymore.

I try to test so more scenario's and some more usb-devices (digital camera, memory sticks and ipod)

Robert (robertvanreij) wrote :

I saw that 1 procesess was using up all of the cpu. This was udevd, so I killed this process and started it up again with sudo udevd --daemon. After this I did a safely remove, deattached the device and re-attached again. And now I was able to access the sd-card.
It looks to me that the problem lies in the udevd program : after startup it consumes all of the cpu aviable on my machine, even the mouse isn't working properly anymore when I insert a sd-card in my cardreader.

Brian Murray (brian-murray) wrote :

Could you try and capture some udevd information when it uses all of the cpu using the instructions at https://wiki.ubuntu.com/DebuggingRemovableDevices ? Additionally what filesystem does your external hard drive use? Thanks again!

Changed in linux-source-2.6.22:
importance: Undecided → Medium
Robert (robertvanreij) wrote :

Problem is solved.
I tried to change /etc/evns.conf and put in "*" in the sysfs_devices section of /etc/evms.conf. It worked for me. See this bugs for more detail:

https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.22/+bug/115616

Beginning with the Hardy Heron 8.04 development cycle, all open Ubuntu kernel bugs need to be reported against the "linux" kernel package. We are automatically migrating this bug to the new "linux" package. However, development has already began for the upcoming Intrepid Ibex 8.10 release. It would be helpful if you could test the upcoming release and verify if this is still an issue - http://www.ubuntu.com/testing . If the issue still exists, please update this report by changing the Status of the "linux" task from "Incomplete" to "New". We appreciate your patience and understanding as we make this transition. Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers